summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-09 07:34:39 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-09 07:34:39 +0000
commit2aae7e291921c08bd94ef20c309051ccd24071a8 (patch)
treec1ba1360716acfb6e563e0ed066a71f9541c4aeb /app-arch/rpm
parentadd file/neon for app-arch/rpm (diff)
downloadgentoo-2-2aae7e291921c08bd94ef20c309051ccd24071a8.tar.gz
gentoo-2-2aae7e291921c08bd94ef20c309051ccd24071a8.tar.bz2
gentoo-2-2aae7e291921c08bd94ef20c309051ccd24071a8.zip
Version bump #190132 by Andrey Falko.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'app-arch/rpm')
-rw-r--r--app-arch/rpm/ChangeLog10
-rw-r--r--app-arch/rpm/files/digest-rpm-5.0_alpha43
-rw-r--r--app-arch/rpm/rpm-5.0_alpha4.ebuild97
3 files changed, 109 insertions, 1 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index b91305057b1f..1e6ce7334ea4 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/rpm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.81 2007/10/05 13:26:46 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.82 2007/12/09 07:34:38 vapier Exp $
+
+ 09 Dec 2007; Mike Frysinger <vapier@gentoo.org> +rpm-5.0_alpha4.ebuild:
+ Version bump #190132 by Andrey Falko.
+
+*rpm-5.0_alpha4 (09 Dec 2007)
+
+ 09 Dec 2007; Mike Frysinger <vapier@gentoo.org> +rpm-5.0_alpha4.ebuild:
+ Version bump #190132 by Andrey Falko.
05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rpm-4.4.7-r3.ebuild:
Adding ~sparc for testing (because masked as well for testing ---
diff --git a/app-arch/rpm/files/digest-rpm-5.0_alpha4 b/app-arch/rpm/files/digest-rpm-5.0_alpha4
new file mode 100644
index 000000000000..047720be3447
--- /dev/null
+++ b/app-arch/rpm/files/digest-rpm-5.0_alpha4
@@ -0,0 +1,3 @@
+MD5 ced6a7563f31ad191681233cabb7884a rpm-5.0a4.tar.gz 8919298
+RMD160 91ee2d3221229b2194089abb6b3477878a525ef7 rpm-5.0a4.tar.gz 8919298
+SHA256 a870025af0db1fb08d86d3252a1a60e475f40affc19aa025bef12563eb108032 rpm-5.0a4.tar.gz 8919298
diff --git a/app-arch/rpm/rpm-5.0_alpha4.ebuild b/app-arch/rpm/rpm-5.0_alpha4.ebuild
new file mode 100644
index 000000000000..2cb4e42a387a
--- /dev/null
+++ b/app-arch/rpm/rpm-5.0_alpha4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-5.0_alpha4.ebuild,v 1.1 2007/12/09 07:34:38 vapier Exp $
+
+inherit multilib distutils
+
+MY_P=${P/_alpha/a}
+
+DESCRIPTION="RPM Package Manager"
+HOMEPAGE="http://rpm5.org/"
+SRC_URI="http://rpm5.org/files/rpm/rpm-5.0/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="berkdb bzip2 doc file lua neon nls pcre perl python selinux sqlite"
+
+# dmalloc? ( dev-libs/dmalloc )
+# efence? ( dev-util/efence )
+# keyutils? ( sys-apps/keyutils )
+# xar? ( app-arch/xar )
+RDEPEND="dev-libs/beecrypt
+ dev-libs/popt
+ berkdb? ( sys-libs/db )
+ bzip2? ( app-arch/bzip2 )
+ lua? ( dev-lang/lua )
+ neon? ( net-misc/neon )
+ pcre? ( dev-libs/libpcre )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ selinux? ( sys-libs/libselinux )
+ sqlite? ( dev-db/sqlite )"
+# comes bundled with modified zlib
+# >=sys-libs/zlib-1.2.3-r1
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -rf file xar #db
+}
+
+src_compile() {
+# $(use_with dmalloc) \
+# $(use_with efence) \
+# $(use_with keyutils) \
+# $(use_with xar) \
+ # --with-libelf
+ econf \
+ $(use_with berkdb db) \
+ $(use_with bzip2) \
+ $(use_with doc apidocs) \
+ $(use_with file) \
+ $(use_with lua) \
+ $(use_with neon) \
+ $(use_with nls) \
+ $(use_with pcre) \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with selinux) \
+ $(use_with sqlite) \
+ $(use berkdb || use sqlite || echo --with-db) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGES CREDITS NEWS README TODO
+}
+
+pkg_preinst() {
+ enewgroup rpm 37
+ enewuser rpm 37 /bin/sh /var/lib/rpm rpm
+}
+
+pkg_postinst() {
+ chown -R rpm:rpm "${ROOT}"/usr/$(get_libdir)/rpm
+ chown -R rpm:rpm "${ROOT}"/var/lib/rpm
+ chown rpm:rpm "${ROOT}"/usr/bin/rpm{,2cpio,build,db,query,sign,verify}
+ if [[ ${ROOT} == "/" ]] ; then
+ if [[ -f ${ROOT}/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${ROOT}"/usr/bin/rpm --rebuilddb --root="${ROOT}"
+ else
+ einfo "No RPM database found... Creating database..."
+ "${ROOT}"/usr/bin/rpm --initdb --root="${ROOT}"
+ fi
+ fi
+ chown rpm:rpm "${ROOT}"/var/lib/rpm/*
+
+ distutils_pkg_postinst
+}