summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-03-26 22:43:53 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-03-26 22:43:53 +0000
commit0fed00f44dfa52e34d6bc83736b94dbc2d39c96d (patch)
treeecc7839c8e1c5fe80ec3d700f6b04e9177c814c6 /app-arch/pigz
parentInitial commit for socnetv application (diff)
downloadgentoo-2-0fed00f44dfa52e34d6bc83736b94dbc2d39c96d.tar.gz
gentoo-2-0fed00f44dfa52e34d6bc83736b94dbc2d39c96d.tar.bz2
gentoo-2-0fed00f44dfa52e34d6bc83736b94dbc2d39c96d.zip
New ebuild
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/pigz')
-rw-r--r--app-arch/pigz/ChangeLog10
-rw-r--r--app-arch/pigz/files/pigz-2.1.4-respect-flags.patch11
-rw-r--r--app-arch/pigz/metadata.xml13
-rw-r--r--app-arch/pigz/pigz-2.1.4.ebuild32
4 files changed, 66 insertions, 0 deletions
diff --git a/app-arch/pigz/ChangeLog b/app-arch/pigz/ChangeLog
new file mode 100644
index 000000000000..47ab9a35d7f2
--- /dev/null
+++ b/app-arch/pigz/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-arch/pigz
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/ChangeLog,v 1.1 2009/03/26 22:43:53 drizzt Exp $
+
+*pigz-2.1.4 (26 Mar 2009)
+
+ 26 Mar 2009; Timothy Redaelli <drizzt@gentoo.org>
+ +files/pigz-2.1.4-respect-flags.patch, +metadata.xml, +pigz-2.1.4.ebuild:
+ New ebuild
+
diff --git a/app-arch/pigz/files/pigz-2.1.4-respect-flags.patch b/app-arch/pigz/files/pigz-2.1.4-respect-flags.patch
new file mode 100644
index 000000000000..7fae2e17765c
--- /dev/null
+++ b/app-arch/pigz/files/pigz-2.1.4-respect-flags.patch
@@ -0,0 +1,11 @@
+--- pigz-2.1.4.orig/Makefile
++++ pigz-2.1.4/Makefile
+@@ -1,7 +1,5 @@
+-CFLAGS=-O2
+-
+ pigz: pigz.o yarn.o
+- cc -o pigz pigz.o yarn.o -lpthread -lz
++ $(CC) $(LDFLAGS) -o pigz pigz.o yarn.o -lpthread -lz
+
+ pigz.o: pigz.c yarn.h
+
diff --git a/app-arch/pigz/metadata.xml b/app-arch/pigz/metadata.xml
new file mode 100644
index 000000000000..af510a4b4f20
--- /dev/null
+++ b/app-arch/pigz/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>drizzt@gentoo.org</email>
+<name>Timothy Redaelli</name>
+</maintainer>
+<longdescription lang="en">
+A parallel implementation of gzip for modern
+multi-processor, multi-core machines.
+</longdescription>
+</pkgmetadata>
diff --git a/app-arch/pigz/pigz-2.1.4.ebuild b/app-arch/pigz/pigz-2.1.4.ebuild
new file mode 100644
index 000000000000..3b8b0e19e5eb
--- /dev/null
+++ b/app-arch/pigz/pigz-2.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/pigz-2.1.4.ebuild,v 1.1 2009/03/26 22:43:53 drizzt Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A parallel implementation of gzip."
+HOMEPAGE="http://www.zlib.net/pigz/"
+SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz"
+
+LICENSE="PIGZ"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-respect-flags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin ${PN} || die "Failed to install"
+ dodoc README
+}