summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-13 23:35:04 +0000
committerDror Levin <spatz@gentoo.org>2010-03-13 23:35:04 +0000
commita537a1bf8881ccf981c5d2f3bd52134a5e4d8edc (patch)
treed2c8a8ea30a76374ebc0972ee538f96b09a312a0 /app-arch/pbzip2
parentmirrors -> mirror in SRC_URI (diff)
downloadgentoo-2-a537a1bf8881ccf981c5d2f3bd52134a5e4d8edc.tar.gz
gentoo-2-a537a1bf8881ccf981c5d2f3bd52134a5e4d8edc.tar.bz2
gentoo-2-a537a1bf8881ccf981c5d2f3bd52134a5e4d8edc.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/pbzip2')
-rw-r--r--app-arch/pbzip2/ChangeLog8
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.1.0-makefile.patch57
-rw-r--r--app-arch/pbzip2/pbzip2-1.1.0.ebuild46
3 files changed, 110 insertions, 1 deletions
diff --git a/app-arch/pbzip2/ChangeLog b/app-arch/pbzip2/ChangeLog
index a0f681c789e3..cc3b97e57962 100644
--- a/app-arch/pbzip2/ChangeLog
+++ b/app-arch/pbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/pbzip2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.81 2010/02/09 20:03:12 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.82 2010/03/13 23:35:03 spatz Exp $
+
+*pbzip2-1.1.0 (13 Mar 2010)
+
+ 13 Mar 2010; Dror Levin <spatz@gentoo.org> +pbzip2-1.1.0.ebuild,
+ +files/pbzip2-1.1.0-makefile.patch:
+ Version bump.
*pbzip2-1.0.5-r3 (09 Feb 2010)
diff --git a/app-arch/pbzip2/files/pbzip2-1.1.0-makefile.patch b/app-arch/pbzip2/files/pbzip2-1.1.0-makefile.patch
new file mode 100644
index 000000000000..81885e56ef33
--- /dev/null
+++ b/app-arch/pbzip2/files/pbzip2-1.1.0-makefile.patch
@@ -0,0 +1,57 @@
+--- Makefile.orig 2010-03-14 01:24:19.049620304 +0200
++++ Makefile 2010-03-14 01:29:23.231630037 +0200
+@@ -2,8 +2,6 @@
+ SHELL = /bin/sh
+
+ # Compiler to use
+-CC = g++
+-CFLAGS = -O2
+ #CFLAGS += -g -Wall
+ #CFLAGS += -ansi
+ #CFLAGS += -pedantic
+@@ -12,7 +10,7 @@
+ # Comment out CFLAGS line below for compatability mode for 32bit file sizes
+ # (less than 2GB) and systems that have compilers that treat int as 64bit
+ # natively (ie: modern AIX)
+-CFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++CXXFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+
+ # Uncomment CFLAGS line below if you want to compile pbzip2 without load
+ # average support for systems that do not support it
+@@ -22,17 +20,17 @@
+ #CFLAGS += -DPBZIP_DEBUG
+
+ # Comment out CFLAGS line below to disable pthread semantics in code
+-CFLAGS += -D_POSIX_PTHREAD_SEMANTICS
++CXXFLAGS += -D_POSIX_PTHREAD_SEMANTICS
+
+ # Comment out CFLAGS line below to disable Thread stack size customization
+-CFLAGS += -DUSE_STACKSIZE_CUSTOMIZATION
++CXXFLAGS += -DUSE_STACKSIZE_CUSTOMIZATION
+
+ # On some compilers -pthreads
+-CFLAGS += -pthread
++CXXFLAGS += -pthread
+
+ # External libraries
+-LDFLAGS = -lbz2
+-LDFLAGS += -lpthread
++LIBS = -lbz2
++LIBS += -lpthread
+
+ # Where you want pbzip2 installed when you do 'make install'
+ PREFIX = /usr
+@@ -41,11 +39,11 @@
+
+ # Standard pbzip2 compile
+ pbzip2: pbzip2.cpp BZ2StreamScanner.cpp
+- $(CC) $(CFLAGS) $^ -o pbzip2 $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS) -o pbzip2
+
+ # Choose this if you want to compile in a static version of the libbz2 library
+ pbzip2-static: pbzip2.cpp BZ2StreamScanner.cpp libbz2.a
+- $(CC) $(CFLAGS) $^ -o pbzip2 -I. -L. $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS) -o pbzip2 -I. -L.
+
+ # Install the binary pbzip2 program and man page
+ install: pbzip2
diff --git a/app-arch/pbzip2/pbzip2-1.1.0.ebuild b/app-arch/pbzip2/pbzip2-1.1.0.ebuild
new file mode 100644
index 000000000000..84b4fc163192
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.1.0.ebuild,v 1.1 2010/03/13 23:35:03 spatz Exp $
+
+EAPI=2
+
+inherit multilib eutils
+
+DESCRIPTION="parallel bzip2 (de)compressor using libbz2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static symlink"
+
+DEPEND="app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CXX
+}
+
+src_compile() {
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a "${S}"
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README
+ doman pbzip2.1 || die "Failed to install man page"
+ dosym /usr/bin/pbzip2 /usr/bin/pbunzip2
+
+ if use symlink; then
+ dosym /usr/bin/pbzip2 /usr/bin/bzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bunzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bzcat
+ fi
+}