summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2007-01-26 20:59:01 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2007-01-26 20:59:01 +0000
commit9c1ecc151bd4b7969f381601e840bc9e38d40800 (patch)
tree3a6e87fe61b608d97d2aafb089ccd3cb095bb09e /app-arch/p7zip
parentAllow the package to build with LDFLAGS="-Wl,--as-needed", thanks to a patch ... (diff)
downloadgentoo-2-9c1ecc151bd4b7969f381601e840bc9e38d40800.tar.gz
gentoo-2-9c1ecc151bd4b7969f381601e840bc9e38d40800.tar.bz2
gentoo-2-9c1ecc151bd4b7969f381601e840bc9e38d40800.zip
version bump
(Portage version: 2.1.2-r4)
Diffstat (limited to 'app-arch/p7zip')
-rw-r--r--app-arch/p7zip/ChangeLog7
-rw-r--r--app-arch/p7zip/files/digest-p7zip-4.202
-rw-r--r--app-arch/p7zip/files/digest-p7zip-4.443
-rw-r--r--app-arch/p7zip/p7zip-4.44.ebuild72
4 files changed, 83 insertions, 1 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index d806133efb01..b2c51158287f 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.51 2007/01/04 14:18:28 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.52 2007/01/26 20:59:00 radek Exp $
+
+*p7zip-4.44 (26 Jan 2007)
+
+ 26 Jan 2007; Radoslaw Stachowiak <radek@gentoo.org> +p7zip-4.44.ebuild:
+ version bump
04 Jan 2007; Bryan Østergaard <kloeri@gentoo.org> p7zip-4.43.ebuild:
Add ~alpha keyword.
diff --git a/app-arch/p7zip/files/digest-p7zip-4.20 b/app-arch/p7zip/files/digest-p7zip-4.20
index 6c066396c0ed..fe52208d40b9 100644
--- a/app-arch/p7zip/files/digest-p7zip-4.20
+++ b/app-arch/p7zip/files/digest-p7zip-4.20
@@ -1 +1,3 @@
MD5 91abf73ddfc92a0ed87dd5bb9fc3a38d p7zip_4.20_src.tar.bz2 328976
+RMD160 3ae10d0ed32a1334728d0b59adfa7574e3216ba3 p7zip_4.20_src.tar.bz2 328976
+SHA256 a8fd139d6c590beb7448a75eb746d0e9308bab9c2e6b88cab5746f6a272a8c3d p7zip_4.20_src.tar.bz2 328976
diff --git a/app-arch/p7zip/files/digest-p7zip-4.44 b/app-arch/p7zip/files/digest-p7zip-4.44
new file mode 100644
index 000000000000..abaf25e60b0c
--- /dev/null
+++ b/app-arch/p7zip/files/digest-p7zip-4.44
@@ -0,0 +1,3 @@
+MD5 78b04bed16a1e7e91b5bf2f1f84ab811 p7zip_4.44_src_all.tar.bz2 1518820
+RMD160 a04f13c55ce21781c463debc578fd4819f171adf p7zip_4.44_src_all.tar.bz2 1518820
+SHA256 cb87304f682e7176ab95ce73d3ce2b7b65384e051272fc34ef934e2427bbd3af p7zip_4.44_src_all.tar.bz2 1518820
diff --git a/app-arch/p7zip/p7zip-4.44.ebuild b/app-arch/p7zip/p7zip-4.44.ebuild
new file mode 100644
index 000000000000..dbf32e90bfc1
--- /dev/null
+++ b/app-arch/p7zip/p7zip-4.44.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.44.ebuild,v 1.1 2007/01/26 20:59:00 radek Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Port of 7-Zip archiver for Unix"
+HOMEPAGE="http://p7zip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~sparc ~x86 ~x86-fbsd"
+IUSE="static doc"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CXX=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
+ -e 's:-s ::' \
+ makefile* || die "changing makefiles"
+
+ if use amd64; then
+ ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
+ cp -f makefile.linux_amd64 makefile.machine
+ elif use ppc-macos; then
+ # Mac OS X needs this special makefile, because it has a non-GNU linker
+ cp -f makefile.macosx makefile.machine
+ elif use x86-fbsd; then
+ # FreeBSD needs this special makefile, because it hasn't -ldl
+ sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
+ fi
+ use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
+}
+
+src_compile() {
+ emake all3 || die "compilation error"
+}
+
+src_install() {
+ # this wrappers can not be symlinks, p7zip should be called with full path
+ make_wrapper 7zr "/usr/lib/${PN}/7zr"
+ make_wrapper 7za "/usr/lib/${PN}/7za"
+ make_wrapper 7z "/usr/lib/${PN}/7z"
+
+ dobin ${FILESDIR}/p7zip
+
+ # gzip introduced in 4.42, so beware :)
+ # mv needed just as rename, because dobin installs using old name
+ mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg
+ dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
+ exeinto /usr/$(get_libdir)/${PN}/Codecs
+ doexe bin/Codecs/* || die "doexe Codecs"
+ exeinto /usr/$(get_libdir)/${PN}/Formats
+ doexe bin/Formats/* || die "doexe Formats"
+
+ doman man1/7z.1 man1/7za.1 man1/7zr.1
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dodoc DOCS/*.txt
+ dohtml -r DOCS/MANUAL/*
+ fi
+}