summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-08-03 16:15:24 +0000
committerJeroen Roovers <jer@gentoo.org>2009-08-03 16:15:24 +0000
commit33ca37ecba643a58ff2d0d94940879e56bd304ad (patch)
treefa20bdc0f933e590dfc673385f5ef948b6c0bf9d /app-arch/mt-st
parentAdding IUSE=+alsa to fully satisfy Bug #279786 (diff)
downloadgentoo-2-33ca37ecba643a58ff2d0d94940879e56bd304ad.tar.gz
gentoo-2-33ca37ecba643a58ff2d0d94940879e56bd304ad.tar.bz2
gentoo-2-33ca37ecba643a58ff2d0d94940879e56bd304ad.zip
Version bump. Move to EAPI="2". Remove DEPEND.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-arch/mt-st')
-rw-r--r--app-arch/mt-st/ChangeLog9
-rw-r--r--app-arch/mt-st/mt-st-1.1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/app-arch/mt-st/ChangeLog b/app-arch/mt-st/ChangeLog
index 37319d24dd80..cea3181f22a0 100644
--- a/app-arch/mt-st/ChangeLog
+++ b/app-arch/mt-st/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/mt-st
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/ChangeLog,v 1.27 2008/10/23 02:42:32 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/ChangeLog,v 1.28 2009/08/03 16:15:24 jer Exp $
+
+*mt-st-1.1 (03 Aug 2009)
+
+ 03 Aug 2009; Jeroen Roovers <jer@gentoo.org> +mt-st-1.1.ebuild:
+ Version bump. Move to EAPI="2". Remove DEPEND.
23 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> mt-st-0.9b.ebuild:
Respect CFLAGS, LDFLAGS and CC.
diff --git a/app-arch/mt-st/mt-st-1.1.ebuild b/app-arch/mt-st/mt-st-1.1.ebuild
new file mode 100644
index 000000000000..3bd98e095e77
--- /dev/null
+++ b/app-arch/mt-st/mt-st-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/mt-st-1.1.ebuild,v 1.1 2009/08/03 16:15:24 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Enhanced mt command for Linux, supporting Linux 2.4 ioctls"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="http://www.ibiblio.org/pub/linux/system/backup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "s:-O2:${CFLAGS}:g" Makefile
+}
+
+src_compile() {
+ # Builds straight from .c to final binary
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die
+}
+
+src_install() {
+ dosbin mt stinit || die
+ doman mt.1 stinit.8
+ dodoc README* stinit.def.examples
+}