summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-11 19:02:41 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-11 19:02:41 +0000
commit64add33941c36786cb1fb38867542f981e0935af (patch)
tree0d0523033548f3dbef25a7a91c4c045f8bd28808 /app-arch/macutil
parentLoosened xerces dependency (bug #115158). (diff)
downloadgentoo-2-64add33941c36786cb1fb38867542f981e0935af.tar.gz
gentoo-2-64add33941c36786cb1fb38867542f981e0935af.tar.bz2
gentoo-2-64add33941c36786cb1fb38867542f981e0935af.zip
Add patch to fix compilation with gcc-4; bug #105847
(Portage version: 2.0.53)
Diffstat (limited to 'app-arch/macutil')
-rw-r--r--app-arch/macutil/ChangeLog6
-rw-r--r--app-arch/macutil/Manifest13
-rw-r--r--app-arch/macutil/files/macutil-2.0_beta3-gcc4.patch15
-rw-r--r--app-arch/macutil/macutil-2.0_beta3.ebuild5
4 files changed, 25 insertions, 14 deletions
diff --git a/app-arch/macutil/ChangeLog b/app-arch/macutil/ChangeLog
index 05e3fde3c3f0..021c93dd16d1 100644
--- a/app-arch/macutil/ChangeLog
+++ b/app-arch/macutil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/macutil
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/ChangeLog,v 1.11 2005/09/16 20:17:35 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/ChangeLog,v 1.12 2005/12/11 19:02:41 halcy0n Exp $
+
+ 11 Dec 2005; Mark Loeser <halcy0n@gentoo.org>
+ +files/macutil-2.0_beta3-gcc4.patch, macutil-2.0_beta3.ebuild:
+ Add patch to fix compilation with gcc-4; bug #105847
16 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/app-arch/macutil/Manifest b/app-arch/macutil/Manifest
index 741bacdc5ed1..ed1b50e2c820 100644
--- a/app-arch/macutil/Manifest
+++ b/app-arch/macutil/Manifest
@@ -1,15 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 faee22559c09a7669e9077ff6b6623c3 ChangeLog 1445
MD5 21ef82f8cce2374982bfad3dc94e92b2 files/2.0_beta3-gentoo.patch 523
MD5 6f82b90c8d88acde1cb4ddbdbaf56c80 files/digest-macutil-2.0_beta3 64
-MD5 f4d95133be2e14d4f66e937dbe0ccbe3 macutil-2.0_beta3.ebuild 1007
+MD5 4e55406c6504081ec32d9b1f40cf164a files/macutil-2.0_beta3-gcc4.patch 394
+MD5 1ab93a36c558a3f2ed16e06589cc59fb macutil-2.0_beta3.ebuild 1047
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDi8RWgIKl8Uu19MoRAgrTAJwN9t8RAn3SVtdzspT6z0aVVNEDTACggxua
-wNWWI260765ehUgFNJRIjkY=
-=l9Re
------END PGP SIGNATURE-----
diff --git a/app-arch/macutil/files/macutil-2.0_beta3-gcc4.patch b/app-arch/macutil/files/macutil-2.0_beta3-gcc4.patch
new file mode 100644
index 000000000000..959f3433b1ad
--- /dev/null
+++ b/app-arch/macutil/files/macutil-2.0_beta3-gcc4.patch
@@ -0,0 +1,15 @@
+diff -ur macutil-orig/macunpack/lzh.h macutil/macunpack/lzh.h
+--- macutil-orig/macunpack/lzh.h 2005-11-10 00:34:04.000000000 -0500
++++ macutil/macunpack/lzh.h 2005-11-10 00:34:42.000000000 -0500
+@@ -58,10 +58,4 @@
+ #define lz5 7
+ #define lzs 8
+
+-extern char *lzh_pointer;
+-extern char *lzh_data;
+-extern char *lzh_finfo;
+-extern int lzh_fsize;
+-extern int lzh_kind;
+-extern char *lzh_file;
+
+
diff --git a/app-arch/macutil/macutil-2.0_beta3.ebuild b/app-arch/macutil/macutil-2.0_beta3.ebuild
index 71155064b571..fc1544440fc0 100644
--- a/app-arch/macutil/macutil-2.0_beta3.ebuild
+++ b/app-arch/macutil/macutil-2.0_beta3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/macutil-2.0_beta3.ebuild,v 1.11 2005/11/29 02:58:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/macutil-2.0_beta3.ebuild,v 1.12 2005/12/11 19:02:41 halcy0n Exp $
inherit eutils
@@ -19,7 +19,8 @@ S="${WORKDIR}/${PN}"
src_unpack() {
gzip -dc ${DISTDIR}/${A} | /bin/sh || die
- epatch ${FILESDIR}/${PV}-gentoo.patch || die
+ epatch "${FILESDIR}"/${PV}-gentoo.patch || die
+ epatch "${FILESDIR}"/${P}-gcc4.patch
cd ${PN}