summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-20 10:20:04 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-20 10:20:04 +0000
commit606719159cf171c56dd45f07465a02d8d3d2089a (patch)
treed0a5eac1a47b4324be8e20871cab665620c4d235 /app-arch/macutil
parent(Portage version: 2.0.51.19) (Manifest recommit) (diff)
downloadgentoo-2-606719159cf171c56dd45f07465a02d8d3d2089a.tar.gz
gentoo-2-606719159cf171c56dd45f07465a02d8d3d2089a.tar.bz2
gentoo-2-606719159cf171c56dd45f07465a02d8d3d2089a.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-arch/macutil')
-rw-r--r--app-arch/macutil/ChangeLog6
-rw-r--r--app-arch/macutil/files/2.0_beta3-gentoo.patch19
-rw-r--r--app-arch/macutil/macutil-2.0_beta3.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/app-arch/macutil/ChangeLog b/app-arch/macutil/ChangeLog
index 90795426f8d0..8d4a0e8989bd 100644
--- a/app-arch/macutil/ChangeLog
+++ b/app-arch/macutil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/macutil
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/ChangeLog,v 1.6 2005/01/01 11:48:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/ChangeLog,v 1.7 2005/03/20 10:20:04 mkennedy Exp $
+
+ 20 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/2.0_beta3-gentoo.patch, macutil-2.0_beta3.ebuild:
+ Compilation fix for GCC 3.4.x; Resolves Bug #76435
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
macutil-2.0_beta3.ebuild:
diff --git a/app-arch/macutil/files/2.0_beta3-gentoo.patch b/app-arch/macutil/files/2.0_beta3-gentoo.patch
new file mode 100644
index 000000000000..6ee325b4cba4
--- /dev/null
+++ b/app-arch/macutil/files/2.0_beta3-gentoo.patch
@@ -0,0 +1,19 @@
+diff -ur macutil.orig/hexbin/buffer.c macutil/hexbin/buffer.c
+--- macutil.orig/hexbin/buffer.c 2005-02-01 23:57:21.489383480 -0600
++++ macutil/hexbin/buffer.c 2005-02-02 00:00:23.574583423 -0600
+@@ -1,12 +1,11 @@
++
++#include <stdlib.h>
++
+ #include "globals.h"
+ #include "../util/util.h"
+ #include "buffer.h"
+ #include "../fileio/wrfile.h"
+
+-extern char *malloc();
+-extern char *realloc();
+-extern void exit();
+-
+ char *data_fork, *rsrc_fork;
+ int data_size, rsrc_size;
+ static int max_data_size, max_rsrc_size;
diff --git a/app-arch/macutil/macutil-2.0_beta3.ebuild b/app-arch/macutil/macutil-2.0_beta3.ebuild
index 4cc34bcea6af..afdf8ed9a74b 100644
--- a/app-arch/macutil/macutil-2.0_beta3.ebuild
+++ b/app-arch/macutil/macutil-2.0_beta3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/macutil-2.0_beta3.ebuild,v 1.6 2005/01/01 11:48:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/macutil/macutil-2.0_beta3.ebuild,v 1.7 2005/03/20 10:20:04 mkennedy Exp $
inherit eutils
@@ -23,6 +23,8 @@ S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
unshar ${MY_P/-/}.shar
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+
cd ${PN}
sed -i.orig \