summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-30 22:03:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-30 22:03:51 +0000
commita64ab2c0c3672155f8e6199a109738fc04524513 (patch)
tree1d3872b1ed7931266d98f517990d68733d67bf1b /app-arch/lzma
parentRemove old (diff)
downloadgentoo-2-a64ab2c0c3672155f8e6199a109738fc04524513.tar.gz
gentoo-2-a64ab2c0c3672155f8e6199a109738fc04524513.tar.bz2
gentoo-2-a64ab2c0c3672155f8e6199a109738fc04524513.zip
Bump to 4.65, incorporating small changes from Tim Harder. Fixes #265712
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/lzma')
-rw-r--r--app-arch/lzma/ChangeLog7
-rw-r--r--app-arch/lzma/lzma-4.65.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/app-arch/lzma/ChangeLog b/app-arch/lzma/ChangeLog
index fba9a00f2852..d33e203f1347 100644
--- a/app-arch/lzma/ChangeLog
+++ b/app-arch/lzma/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/lzma
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.12 2009/01/25 19:56:29 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.13 2009/04/30 22:03:51 patrick Exp $
+
+*lzma-4.65 (30 Apr 2009)
+
+ 30 Apr 2009; Patrick Lauer <patrick@gentoo.org> +lzma-4.65.ebuild:
+ Bump to 4.65, incorporating small changes from Tim Harder. Fixes #265712
*lzma-4.63 (25 Jan 2009)
diff --git a/app-arch/lzma/lzma-4.65.ebuild b/app-arch/lzma/lzma-4.65.ebuild
new file mode 100644
index 000000000000..b7c2a4f94ad9
--- /dev/null
+++ b/app-arch/lzma/lzma-4.65.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/lzma-4.65.ebuild,v 1.1 2009/04/30 22:03:51 patrick Exp $
+
+inherit toolchain-funcs versionator
+
+MY_P="${PN}$(replace_all_version_separators '')"
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="http://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~ia64 ~mips ~sparc ~x86"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd CPP/7zip/Compress/LZMA_Alone
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS}" \
+ || die "Make failed"
+}
+
+src_install() {
+ newbin CPP/7zip/Compress/LZMA_Alone/lzma lzma_alone || die
+ dodoc history.txt
+ use doc && dodoc 7zC.txt 7zFormat.txt lzma.txt Methods.txt
+
+ einfo "Starting from app-arch/lzma version 4.63 binary name was changed"
+ einfo "to /usr/bin/lzma_alone to avoid conflict with lzma-utils package"
+}