summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2009-01-25 19:56:29 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2009-01-25 19:56:29 +0000
commit67b708449f68124d2f05e0e6ad4b132791249d76 (patch)
tree1b44b855099687e0c39a52c0355ea195fc6ce4fb /app-arch/lzma
parentFix kernel version with which udev runs reliable. Also apply documentation ud... (diff)
downloadgentoo-2-67b708449f68124d2f05e0e6ad4b132791249d76.tar.gz
gentoo-2-67b708449f68124d2f05e0e6ad4b132791249d76.tar.bz2
gentoo-2-67b708449f68124d2f05e0e6ad4b132791249d76.zip
Version bump, and changed binary name due to #218459
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'app-arch/lzma')
-rw-r--r--app-arch/lzma/ChangeLog9
-rw-r--r--app-arch/lzma/lzma-4.63.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/app-arch/lzma/ChangeLog b/app-arch/lzma/ChangeLog
index daa638a1dc90..fba9a00f2852 100644
--- a/app-arch/lzma/ChangeLog
+++ b/app-arch/lzma/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/lzma
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.11 2008/05/11 19:44:38 solar Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/ChangeLog,v 1.12 2009/01/25 19:56:29 radek Exp $
+
+*lzma-4.63 (25 Jan 2009)
+
+ 25 Jan 2009; Radoslaw Stachowiak <radek@gentoo.org> +lzma-4.63.ebuild:
+ Version bump, and changed binary name due to #218459
11 May 2008; <solar@gentoo.org> lzma-4.57.ebuild:
- Keyworded ~arm
diff --git a/app-arch/lzma/lzma-4.63.ebuild b/app-arch/lzma/lzma-4.63.ebuild
new file mode 100644
index 000000000000..400d7e00e3b9
--- /dev/null
+++ b/app-arch/lzma/lzma-4.63.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/lzma-4.63.ebuild,v 1.1 2009/01/25 19:56:29 radek Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="http://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${PN}463.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~ia64 ~mips ~sparc ~x86"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd CPP/7zip/Compress/LZMA_Alone
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS}" \
+ || die "Make failed"
+}
+
+src_install() {
+ newbin CPP/7zip/Compress/LZMA_Alone/lzma lzma_alone|| die
+ dodoc history.txt
+ use doc && dodoc 7zC.txt 7zFormat.txt lzma.txt Methods.txt
+
+ einfo "Starting from app-arch/lzma version 4.63 binary name was changed"
+ einfo "to /usr/bin/lzma_alone to avoid conflict with lzma-utils package"
+}
+
+