summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-27 15:29:15 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-27 15:29:15 +0000
commitbc7754f49aa2e598fabc32e95d31a793a4d8e3a6 (patch)
tree99c86541fa09defde91e6785b60d3e04a5a7ee19 /app-arch/lzlib
parentBetter USE=-web handling for 3.5.1, fixes bug #537974, btw the whole -web thi... (diff)
downloadgentoo-2-bc7754f49aa2e598fabc32e95d31a793a4d8e3a6.tar.gz
gentoo-2-bc7754f49aa2e598fabc32e95d31a793a4d8e3a6.tar.bz2
gentoo-2-bc7754f49aa2e598fabc32e95d31a793a4d8e3a6.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-arch/lzlib')
-rw-r--r--app-arch/lzlib/ChangeLog9
-rw-r--r--app-arch/lzlib/lzlib-1.6.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-arch/lzlib/ChangeLog b/app-arch/lzlib/ChangeLog
index 7d563eb557f0..c25fdd82d1f8 100644
--- a/app-arch/lzlib/ChangeLog
+++ b/app-arch/lzlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/lzlib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzlib/ChangeLog,v 1.1 2014/02/27 10:55:45 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzlib/ChangeLog,v 1.2 2015/01/27 15:29:15 mgorny Exp $
+
+*lzlib-1.6 (27 Jan 2015)
+
+ 27 Jan 2015; Michał Górny <mgorny@gentoo.org> +lzlib-1.6.ebuild:
+ Version bump.
*lzlib-1.5 (27 Feb 2014)
diff --git a/app-arch/lzlib/lzlib-1.6.ebuild b/app-arch/lzlib/lzlib-1.6.ebuild
new file mode 100644
index 000000000000..826bea556407
--- /dev/null
+++ b/app-arch/lzlib/lzlib-1.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzlib/lzlib-1.6.ebuild,v 1.1 2015/01/27 15:29:15 mgorny Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for lzip compression"
+HOMEPAGE="http://www.nongnu.org/lzip/lzlib.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --enable-shared \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: install
+ einstalldocs
+
+ # this sucking thing does not support disabling static libs
+ if ! use static-libs; then
+ rm "${ED%/}"/usr/$(get_libdir)/*.a || die
+ fi
+}