summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-06 20:36:16 +0000
committerDror Levin <spatz@gentoo.org>2010-03-06 20:36:16 +0000
commitc650f1be0baad5ad72ec00b30fe5ab639b6c979f (patch)
treeae8a8375ff28e15876513d147db6383e3af1fd0e /app-arch/lzip/lzip-1.9.ebuild
parentalpha/ia64 stable wrt #307385 (diff)
downloadgentoo-2-c650f1be0baad5ad72ec00b30fe5ab639b6c979f.tar.gz
gentoo-2-c650f1be0baad5ad72ec00b30fe5ab639b6c979f.tar.bz2
gentoo-2-c650f1be0baad5ad72ec00b30fe5ab639b6c979f.zip
Version bump.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/lzip/lzip-1.9.ebuild')
-rw-r--r--app-arch/lzip/lzip-1.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/lzip/lzip-1.9.ebuild b/app-arch/lzip/lzip-1.9.ebuild
new file mode 100644
index 000000000000..26a3ee7c3463
--- /dev/null
+++ b/app-arch/lzip/lzip-1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzip/lzip-1.9.ebuild,v 1.1 2010/03/06 20:36:15 spatz Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="lossless data compressor based on the LZMA algorithm"
+HOMEPAGE="http://www.nongnu.org/lzip/lzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ tc-export CC CXX
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS README NEWS ChangeLog
+}