summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-10-13 11:16:59 +0000
committerRichard Yao <ryao@gentoo.org>2013-10-13 11:16:59 +0000
commitf6b71affb25bf55cfdc1821de0a42537c949371d (patch)
tree3e52c9f0d595c683ed516c9806ab644870919b2e /app-arch/lz4
parentversion bump (diff)
downloadgentoo-2-f6b71affb25bf55cfdc1821de0a42537c949371d.tar.gz
gentoo-2-f6b71affb25bf55cfdc1821de0a42537c949371d.tar.bz2
gentoo-2-f6b71affb25bf55cfdc1821de0a42537c949371d.zip
Add app-arch/lz4-0_p106 (snapshot of upstream r106), which is initially keyworded on ~amd64 (additional keywords welcome); invoke cmake_src_prepare() in src_prepare()
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'app-arch/lz4')
-rw-r--r--app-arch/lz4/ChangeLog10
-rw-r--r--app-arch/lz4/lz4-0_p106.ebuild50
-rw-r--r--app-arch/lz4/lz4-9999.ebuild26
3 files changed, 75 insertions, 11 deletions
diff --git a/app-arch/lz4/ChangeLog b/app-arch/lz4/ChangeLog
index 2b3ad91dab4d..ec5bf303027c 100644
--- a/app-arch/lz4/ChangeLog
+++ b/app-arch/lz4/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/lz4
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.5 2013/10/13 10:54:32 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.6 2013/10/13 11:16:59 ryao Exp $
+
+*lz4-0_p106 (13 Oct 2013)
+
+ 13 Oct 2013; Richard Yao <ryao@gentoo.org> +lz4-0_p106.ebuild,
+ lz4-9999.ebuild:
+ Add app-arch/lz4-0_p106 (snapshot of upstream r106), which is initially
+ keyworded on ~amd64 (additional keywords welcome); invoke cmake_src_prepare()
+ in src_prepare()
13 Oct 2013; Richard Yao <ryao@gentoo.org> lz4-9999.ebuild:
Fix build regressions
diff --git a/app-arch/lz4/lz4-0_p106.ebuild b/app-arch/lz4/lz4-0_p106.ebuild
new file mode 100644
index 000000000000..c5af6c033c6c
--- /dev/null
+++ b/app-arch/lz4/lz4-0_p106.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-0_p106.ebuild,v 1.1 2013/10/13 11:16:59 ryao Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+CMAKE_USE_DIR="${S}/cmake"
+PREFIX="/usr/bin"
+
+if [ ${PV} == "9999" ] ; then
+ inherit subversion
+ ESVN_REPO_URI="http://lz4.googlecode.com/svn/trunk/"
+ ESVN_PROJECT="lz4-read-only"
+else
+ SRC_URI="http://dev.gentoo.org/~ryao/dist/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://code.google.com/p/lz4/"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ [ ${PV} == "9999" ] && subversion_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(-DBUILD_SHARED_LIBS=ON)
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if [ -f "${ED}usr/bin/lz4c64" ]
+ then
+ dosym /usr/bin/{lz4c64,lz4c}
+ else
+ dosym /usr/bin/{lz4c32,lz4c}
+ fi
+}
diff --git a/app-arch/lz4/lz4-9999.ebuild b/app-arch/lz4/lz4-9999.ebuild
index 6bbe04ce1552..cf534c118cac 100644
--- a/app-arch/lz4/lz4-9999.ebuild
+++ b/app-arch/lz4/lz4-9999.ebuild
@@ -1,30 +1,36 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-9999.ebuild,v 1.5 2013/10/13 10:54:32 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-9999.ebuild,v 1.6 2013/10/13 11:16:59 ryao Exp $
EAPI=5
-inherit cmake-utils subversion
+inherit cmake-utils
-DESCRIPTION="Extremely Fast Compression algorithm"
-HOMEPAGE="https://code.google.com/p/lz4/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://lz4.googlecode.com/svn/trunk/"
-ESVN_PROJECT="lz4-read-only"
CMAKE_USE_DIR="${S}/cmake"
PREFIX="/usr/bin"
+if [ ${PV} == "9999" ] ; then
+ inherit subversion
+ ESVN_REPO_URI="http://lz4.googlecode.com/svn/trunk/"
+ ESVN_PROJECT="lz4-read-only"
+else
+ SRC_URI="http://dev.gentoo.org/~ryao/dist/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://code.google.com/p/lz4/"
+
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
src_prepare() {
- subversion_src_prepare
+ [ ${PV} == "9999" ] && subversion_src_prepare
+ cmake-utils_src_prepare
}
src_configure() {