summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-11 19:12:15 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-11 19:12:15 +0000
commite0b731937df59bac5c509ef9e782361c82469355 (patch)
tree9444a015c0d2c436d1b64c567e90b07975417a62 /app-arch/innoextract/files/innoextract-1.4-cmake.patch
parentversion bump wrt #461390 (diff)
downloadgentoo-2-e0b731937df59bac5c509ef9e782361c82469355.tar.gz
gentoo-2-e0b731937df59bac5c509ef9e782361c82469355.tar.bz2
gentoo-2-e0b731937df59bac5c509ef9e782361c82469355.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'app-arch/innoextract/files/innoextract-1.4-cmake.patch')
-rw-r--r--app-arch/innoextract/files/innoextract-1.4-cmake.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/innoextract/files/innoextract-1.4-cmake.patch b/app-arch/innoextract/files/innoextract-1.4-cmake.patch
new file mode 100644
index 000000000000..199a10e14fac
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.4-cmake.patch
@@ -0,0 +1,30 @@
+--- innoextract-1.4/CMakeLists.txt
++++ innoextract-1.4/CMakeLists.txt
+@@ -6,6 +6,7 @@
+ # Define configuration options
+
+ option(USE_LZMA "Build lzma decompression support." ON)
++option(WITH_DEBUG "Debug build" OFF)
+ option(DEBUG_EXTRA "Expensive debug options" OFF)
+ option(SET_WARNING_FLAGS "Adjust compiler warning flags" ON)
+ option(SET_OPTIMIZATION_FLAGS "Adjust compiler optimization flags" ON)
+--- innoextract-1.4/cmake/BuildType.cmake
++++ innoextract-1.4/cmake/BuildType.cmake
+@@ -8,7 +8,7 @@
+ if(CMAKE_BUILD_TYPE STREQUAL "")
+ set(CMAKE_BUILD_TYPE "Release")
+ endif()
+-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
++if(CMAKE_BUILD_TYPE STREQUAL "Debug" OR WITH_DEBUG)
+ add_definitions(-DDEBUG)
+ set(DEBUG 1)
+ endif()
+@@ -64,7 +64,7 @@
+ # Specifically, the need for libboost_system depends on the Boost version
+ add_ldflag("-Wl,--as-needed")
+
+- if(CMAKE_BUILD_TYPE STREQUAL "Debug")
++ if(CMAKE_BUILD_TYPE STREQUAL "Debug" OR WITH_DEBUG)
+
+ # set debug symbol level to -g3
+ check_compiler_flag(RESULT "-g3")