summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-12 04:38:32 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-12 04:38:32 +0000
commitd239b8511ab225f5b5abdba309fd8b8f5525a3fd (patch)
tree713c6ec9a0a005f50f3a317761c48e30cf71abd7 /app-arch/dump
parentnew version (diff)
downloadgentoo-2-d239b8511ab225f5b5abdba309fd8b8f5525a3fd.tar.gz
gentoo-2-d239b8511ab225f5b5abdba309fd8b8f5525a3fd.tar.bz2
gentoo-2-d239b8511ab225f5b5abdba309fd8b8f5525a3fd.zip
version bump
Diffstat (limited to 'app-arch/dump')
-rw-r--r--app-arch/dump/ChangeLog9
-rw-r--r--app-arch/dump/dump-0.4.28.ebuild39
-rw-r--r--app-arch/dump/dump-0.4.29.ebuild68
-rw-r--r--app-arch/dump/files/digest-dump-0.4.281
-rw-r--r--app-arch/dump/files/digest-dump-0.4.291
-rw-r--r--app-arch/dump/files/dump-0.4.21-dump-main.c-gentoo.diff11
-rw-r--r--app-arch/dump/files/dump-0.4.21-dump-optr.c-gentoo.diff11
7 files changed, 77 insertions, 63 deletions
diff --git a/app-arch/dump/ChangeLog b/app-arch/dump/ChangeLog
index 896de1292c0d..95261210bb42 100644
--- a/app-arch/dump/ChangeLog
+++ b/app-arch/dump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/dump
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.4 2002/06/05 08:15:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.5 2002/07/12 04:38:32 seemant Exp $
+
+*dump-0.4.29 (11 Jul 2002)
+
+ 11 Jul 2002; Seemant Kulleen <seemant@gentoo.org> dump-0.4.29.ebuild
+ files/digest-dump-0.4.29 :
+
+ Version bump.
*dump-0.4.28-r1 (5 Jun 2002)
diff --git a/app-arch/dump/dump-0.4.28.ebuild b/app-arch/dump/dump-0.4.28.ebuild
deleted file mode 100644
index 83f0d3dcdfcb..000000000000
--- a/app-arch/dump/dump-0.4.28.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.28.ebuild,v 1.3 2002/07/11 06:30:09 drobbins Exp $
-
-MY_P=${P/4./4b}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="Dump/restore ext2fs backup utilities"
-SRC_URI="http://download.sourceforge.net/dump/${MY_P}.tar.gz"
-HOMEPAGE="http://dump.sourceforge.net"
-LICENSE="BSD"
-
-DEPEND=">=sys-apps/e2fsprogs-1.27
- >=sys-apps/bzip2-1.0.2
- >=sys-libs/zlib-1.1.4
- >=sys-kernel/linux-headers-2.4.10"
-
-RDEPEND="sys-apps/star"
-
-src_compile() {
- local myconf
- ./configure --prefix=/usr \
- --with-dumpdatespath=/etc \
- --with-bingroup=root \
- --enable-largefile ${rlconf} \
- --disable-readline \
- --enable-static \
- || die
-
- emake || die
-}
-src_install () {
- into /
- dosbin dump/dump restore/restore
- doman restore/restore.8
- doman dump/dump.8
- dodoc CHANGES COPYRIGHT INSTALL KNOWNBUGS MAINTAINERS README \
- REPORTING-BUGS THANKS TODO
- cp -a examples/dump_on_cd ${D}/usr/share/doc/${PF}
-}
diff --git a/app-arch/dump/dump-0.4.29.ebuild b/app-arch/dump/dump-0.4.29.ebuild
new file mode 100644
index 000000000000..98c1a3016bba
--- /dev/null
+++ b/app-arch/dump/dump-0.4.29.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.29.ebuild,v 1.1 2002/07/12 04:38:32 seemant Exp $
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+SRC_URI="http://download.sourceforge.net/dump/${MY_P}.tar.gz"
+HOMEPAGE="http://dump.sourceforge.net"
+
+DEPEND=">=sys-apps/e2fsprogs-1.27
+ >=sys-apps/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4
+ >=sys-kernel/linux-headers-2.4.10
+ readline? ( sys-libs/readline )"
+
+RDEPEND="sys-apps/star"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ use readline && ( \
+ for i in configure configure.in
+ do
+ cp ${i} ${i}.orig
+ sed "s:-ltermcap:-lncurses:g" \
+ ${i}.orig > ${i}
+ done
+ )
+}
+
+src_compile() {
+
+ local myconf
+
+ use readline \
+ && myconf="--enable-readline" \
+ || myconf="--disable-readline"
+
+ use static \
+ && myconf="${myconf} --snable-static" \
+ || myconf="${myconf} --enable-shared"
+
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-binowner=root \
+ --with-bingroup=root \
+ --enable-largefile \
+ ${myconf} || die
+
+ emake || die
+}
+src_install () {
+# into /
+# dosbin dump/dump restore/restore
+# doman restore/restore.8
+# doman dump/dump.8
+ einstall \
+ MANDIR=${D}/usr/share/man/man8 || die
+ dodoc CHANGES COPYRIGHT INSTALL KNOWNBUGS MAINTAINERS README \
+ REPORTING-BUGS THANKS TODO
+ dodoc -r examples/dump_on_cd
+}
diff --git a/app-arch/dump/files/digest-dump-0.4.28 b/app-arch/dump/files/digest-dump-0.4.28
deleted file mode 100644
index 9882cd227c63..000000000000
--- a/app-arch/dump/files/digest-dump-0.4.28
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b92b77229e607dcd9b3a508bb97a6c8c dump-0.4b28.tar.gz 206402
diff --git a/app-arch/dump/files/digest-dump-0.4.29 b/app-arch/dump/files/digest-dump-0.4.29
new file mode 100644
index 000000000000..48d87e24bac2
--- /dev/null
+++ b/app-arch/dump/files/digest-dump-0.4.29
@@ -0,0 +1 @@
+MD5 05e8be5f7c265f73911bfb4e1ca58e9a dump-0.4b29.tar.gz 211650
diff --git a/app-arch/dump/files/dump-0.4.21-dump-main.c-gentoo.diff b/app-arch/dump/files/dump-0.4.21-dump-main.c-gentoo.diff
deleted file mode 100644
index 22fc5ba22ec9..000000000000
--- a/app-arch/dump/files/dump-0.4.21-dump-main.c-gentoo.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- dump/main.c~ Thu Dec 21 11:14:54 2000
-+++ dump/main.c Mon Apr 9 23:12:44 2001
-@@ -46,7 +46,7 @@
-
- #include <config.h>
- #include <sys/param.h>
--#include <sys/time.h>
-+#include <time.h>
- #ifdef __linux__
- #include <linux/ext2_fs.h>
- #include <sys/stat.h>
diff --git a/app-arch/dump/files/dump-0.4.21-dump-optr.c-gentoo.diff b/app-arch/dump/files/dump-0.4.21-dump-optr.c-gentoo.diff
deleted file mode 100644
index 3019be704c60..000000000000
--- a/app-arch/dump/files/dump-0.4.21-dump-optr.c-gentoo.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- dump/optr.c~ Thu Dec 21 11:14:54 2000
-+++ dump/optr.c Mon Apr 9 23:12:54 2001
-@@ -47,7 +47,7 @@
- #include <config.h>
- #include <sys/param.h>
- #include <sys/wait.h>
--#include <sys/time.h>
-+#include <time.h>
-
- #include <errno.h>
- #include <fstab.h>