summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-11-25 16:52:12 +0000
committerJeroen Roovers <jer@gentoo.org>2011-11-25 16:52:12 +0000
commitba094c49ba3acb5e55433900b27cebfecb13b9f1 (patch)
treeae9658109e717c46d373aee38457f4964011d738 /app-arch/dpkg
parent0.8.28 version bump. (diff)
downloadgentoo-2-ba094c49ba3acb5e55433900b27cebfecb13b9f1.tar.gz
gentoo-2-ba094c49ba3acb5e55433900b27cebfecb13b9f1.tar.bz2
gentoo-2-ba094c49ba3acb5e55433900b27cebfecb13b9f1.zip
Version bump.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/ChangeLog7
-rw-r--r--app-arch/dpkg/dpkg-1.16.1.2.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 1ff7cc7df231..7406a6246645 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.176 2011/10/18 21:58:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.177 2011/11/25 16:52:12 jer Exp $
+
+*dpkg-1.16.1.2 (25 Nov 2011)
+
+ 25 Nov 2011; Jeroen Roovers <jer@gentoo.org> +dpkg-1.16.1.2.ebuild:
+ Version bump.
18 Oct 2011; Jeroen Roovers <jer@gentoo.org> dpkg-1.16.1.ebuild,
dpkg-1.16.1.1.ebuild, +files/dpkg-1.16.1-bootstrap.patch:
diff --git a/app-arch/dpkg/dpkg-1.16.1.2.ebuild b/app-arch/dpkg/dpkg-1.16.1.2.ebuild
new file mode 100644
index 000000000000..238441e36940
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.16.1.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.1.2.ebuild,v 1.1 2011/11/25 16:52:12 jer Exp $
+
+EAPI=3
+
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="bzip2 dselect nls test unicode zlib"
+
+LANGS="
+ ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
+ nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
+"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ dev-util/pkgconfig
+ nls? ( app-text/po4a )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ )"
+
+src_prepare() {
+ # don't mess with linker optimisation, respect user's flags (don't break!)
+ sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ # this test depends on a Debian only gzip extension that adds --rsyncable
+ # which will therefore always fail on Gentoo. (bug #310847).
+ sed -i scripts/Makefile.am \
+ -e '/850_Dpkg_Compression.t/d' \
+ || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-1.16.1-bootstrap.patch
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ local myconf
+ if use nls; then
+ myconf="--enable-nls $(use_with dselect)"
+ else
+ if use dselect; then
+ elog "Building dselect requires USE=nls - disabling USE=dselect..."
+ fi
+ myconf="--disable-nls --without-dselect"
+ fi
+ econf \
+ ${myconf} \
+ $(use_with bzip2 bz2) \
+ $(use_enable unicode) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --without-selinux \
+ --without-start-stop-daemon
+}
+
+src_install() {
+ strip-linguas ${LANGS}
+ if [ -z "${LINGUAS}" ] ; then
+ LINGUAS=none
+ fi
+
+ emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
+ rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
+ dodoc ChangeLog THANKS TODO
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}