summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-18 21:42:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-18 21:42:46 +0000
commit323d79b0523f7c329bafd2855346b85739b45095 (patch)
treeaaa0e598c0a34b5eab81dddcf4d86d5eef96a815 /app-arch/cpio
parentMark 0.8.11 stable on ia64 (diff)
downloadgentoo-2-323d79b0523f7c329bafd2855346b85739b45095.tar.gz
gentoo-2-323d79b0523f7c329bafd2855346b85739b45095.tar.bz2
gentoo-2-323d79b0523f7c329bafd2855346b85739b45095.zip
Fix by Benigno B. Junior for building on *BSD systems #123237.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-arch/cpio')
-rw-r--r--app-arch/cpio/ChangeLog8
-rw-r--r--app-arch/cpio/cpio-2.6-r5.ebuild5
-rw-r--r--app-arch/cpio/files/cpio-2.6-stpcpy-hack.patch50
3 files changed, 59 insertions, 4 deletions
diff --git a/app-arch/cpio/ChangeLog b/app-arch/cpio/ChangeLog
index 790aee1dd404..b69d7b121c95 100644
--- a/app-arch/cpio/ChangeLog
+++ b/app-arch/cpio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/cpio
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.46 2005/12/25 01:05:28 kumba Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.47 2006/02/18 21:42:46 vapier Exp $
+
+ 18 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/cpio-2.6-stpcpy-hack.patch, cpio-2.6-r5.ebuild:
+ Fix by Benigno B. Junior for building on *BSD systems #123237.
25 Dec 2005; Joshua Kinard <kumba@gentoo.org> cpio-2.6-r5.ebuild:
Marked stable on mips.
diff --git a/app-arch/cpio/cpio-2.6-r5.ebuild b/app-arch/cpio/cpio-2.6-r5.ebuild
index de18980ef328..5650aaf17a97 100644
--- a/app-arch/cpio/cpio-2.6-r5.ebuild
+++ b/app-arch/cpio/cpio-2.6-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6-r5.ebuild,v 1.10 2005/12/25 01:05:28 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6-r5.ebuild,v 1.11 2006/02/18 21:42:46 vapier Exp $
inherit eutils
@@ -28,6 +28,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-checksum.patch
epatch "${FILESDIR}"/${P}-warnings.patch
epatch "${FILESDIR}"/${P}-writeOutHeaderBufferOverflow.patch #112140
+ epatch "${FILESDIR}"/${P}-stpcpy-hack.patch #123237
}
src_compile() {
diff --git a/app-arch/cpio/files/cpio-2.6-stpcpy-hack.patch b/app-arch/cpio/files/cpio-2.6-stpcpy-hack.patch
new file mode 100644
index 000000000000..c5f0d855a8c0
--- /dev/null
+++ b/app-arch/cpio/files/cpio-2.6-stpcpy-hack.patch
@@ -0,0 +1,50 @@
+This is a hack to provide stpcpy on systems where the system libc does
+not provide the function. Upstream has incorporated a proper fix that
+utilizes gnulib; we use this version instead because it is much smaller.
+
+Patch by Benigno B. Junior
+
+http://bugs.gentoo.org/123237
+
+--- cpio-2.6/configure
++++ cpio-2.6/configure
+@@ -11727,7 +11726,7 @@
+
+
+
+-for ac_func in bcopy mkdir strdup strerror
++for ac_func in bcopy mkdir strdup strerror stpcpy
+ do
+ as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ echo "$as_me:$LINENO: checking for $ac_func" >&5
+--- cpio-2.6/config.h.in
++++ cpio-2.6/config.h.in
+@@ -251,6 +251,9 @@
+ /* Define to 1 if you have the <stdlib.h> header file. */
+ #undef HAVE_STDLIB_H
+
++/* Define to 1 if you have the `stpcpy' function. */
++#undef HAVE_STPCPY
++
+ /* Define to 1 if you have the `strcasecmp' function. */
+ #undef HAVE_STRCASECMP
+
+--- cpio-2.6/src/copyout.c
++++ cpio-2.6/src/copyout.c
+@@ -356,7 +356,16 @@
+ char ascii_header[110];
+ char *p;
+
++#ifdef HAVE_STPCPY
+ p = stpcpy (ascii_header, magic_string);
++#else
++ {
++ unsigned long __length = strlen (magic_string);
++ memcpy (ascii_header, magic_string, __length);
++ p += __length;
++ }
++#endif
++
+ to_ascii_or_warn (p, file_hdr->c_ino, 8, LG_16,
+ file_hdr->c_name, _("inode number"));
+ p += 8;