summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-05-11 21:27:33 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-05-11 21:27:33 +0000
commita14022dc5f02a1068be555e97bc17db4f0062144 (patch)
tree2c43b64ef3c38bd57592c3d3a30463fc17dc8c16 /app-antivirus
parentNew version, that is compatible with ghc-6.4. (diff)
downloadgentoo-2-a14022dc5f02a1068be555e97bc17db4f0062144.tar.gz
gentoo-2-a14022dc5f02a1068be555e97bc17db4f0062144.tar.bz2
gentoo-2-a14022dc5f02a1068be555e97bc17db4f0062144.zip
Version bump.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/Manifest12
-rw-r--r--app-antivirus/clamav/clamav-0.85.ebuild76
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.851
4 files changed, 85 insertions, 11 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 3357ad389fa4..65c46981361a 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.64 2005/05/01 18:09:54 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.65 2005/05/11 21:27:33 ticho Exp $
+
+*clamav-0.85 (11 May 2005)
+
+ 11 May 2005; Andrej Kacian <ticho@gentoo.org> +clamav-0.85.ebuild:
+ Version bump.
*clamav-0.84 (01 May 2005)
diff --git a/app-antivirus/clamav/Manifest b/app-antivirus/clamav/Manifest
index c8f2eee034d7..c2535b0c263a 100644
--- a/app-antivirus/clamav/Manifest
+++ b/app-antivirus/clamav/Manifest
@@ -1,6 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 da3bf6c2ae42f55aff22b1531c76b3f9 clamav-0.85.ebuild 2214
MD5 bf2cf15ce5fddd93fffa28e8b0a3f50f clamav-0.84.ebuild 2314
MD5 8e2b83a7b7693295340f617bb00d13d2 ChangeLog 13228
MD5 7e32edfd72887a57b16ecd73f0f7a1a0 metadata.xml 184
@@ -8,12 +6,6 @@ MD5 6ea55388f51845c2f815589dfed047a4 clamav-0.83.ebuild 2332
MD5 ad7d45b1be51c06986cb42c53e733d19 files/clamav-milter.README.gentoo 1311
MD5 9bbf2754f8178fd5164875d784aa9ffa files/digest-clamav-0.83 64
MD5 3e9877b8901f604bd65ea89ff18833b6 files/digest-clamav-0.84 64
+MD5 0bd0d31062475433335752e126830799 files/digest-clamav-0.85 64
MD5 e8dcbdecd955708ddc7c79399ffa6276 files/clamd.conf 166
MD5 1b3268d3723e003ad99bf706e6bf4312 files/clamd.rc 1444
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCdRuKQlM6RnzZP+IRAs1eAJ4ku79UbvONVSwDVdOboCak/Vjo/wCeJkHJ
-GOR7LBsAMYdbWaNdF/pRTxM=
-=JsW3
------END PGP SIGNATURE-----
diff --git a/app-antivirus/clamav/clamav-0.85.ebuild b/app-antivirus/clamav/clamav-0.85.ebuild
new file mode 100644
index 000000000000..ca135184239d
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.85.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.85.ebuild,v 1.1 2005/05/11 21:27:33 ticho Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/clamav/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~hppa ~alpha ~ppc64 ~ia64"
+IUSE="crypt milter selinux"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( mail-mta/sendmail )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0
+ net-dns/libidn"
+RDEPEND="selinux? ( sec-policy/selinux-clamav )"
+PROVIDE="virtual/antivirus"
+
+pkg_setup() {
+ if use milter; then
+ if ! built_with_use mail-mta/sendmail milter; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
+ enewgroup clamav
+ enewuser clamav -1 /bin/false /dev/null clamav
+ pwconv || die
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+
+ use milter && myconf="${myconf} --enable-milter"
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
+ newinitd ${FILESDIR}/clamd.rc clamd
+ newconfd ${FILESDIR}/clamd.conf clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+}
+
+pkg_postinst() {
+ echo
+ einfo "NOTE: As of clamav-0.80, the config file for clamd is no longer"
+ einfo " /etc/clamav.conf, but /etc/clamd.conf. Adjust your"
+ einfo " configuration accordingly before (re)starting clamd."
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ einfo "For simple instructions howto setup the clamav-milter..."
+ einfo ""
+ einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.85 b/app-antivirus/clamav/files/digest-clamav-0.85
new file mode 100644
index 000000000000..dc72428f9d37
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.85
@@ -0,0 +1 @@
+MD5 b6bf9b04d69b4e9cf917beca99d8169a clamav-0.85.tar.gz 4047244