summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-01-25 16:08:09 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-01-25 16:08:09 +0000
commit062bbbdbdb914d053b8042f8117af807d8303cad (patch)
treeeb2ca4069fa95b11ee25001816343f531727de0c /app-antivirus
parentsb16_csp won't build on ppc64 (diff)
downloadgentoo-2-062bbbdbdb914d053b8042f8117af807d8303cad.tar.gz
gentoo-2-062bbbdbdb914d053b8042f8117af807d8303cad.tar.bz2
gentoo-2-062bbbdbdb914d053b8042f8117af807d8303cad.zip
Version bump. Closes #78796.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/clamav-0.81_rc1.ebuild62
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.81_rc11
3 files changed, 69 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 3f4e06389e27..8adc0c1d06f0 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.32 2005/01/25 11:21:50 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.33 2005/01/25 16:08:09 ticho Exp $
+
+*clamav-0.81_rc1 (25 Jan 2005)
+
+ 25 Jan 2005; Andrej Kacian <ticho@gentoo.org> +clamav-0.81_rc1.ebuild:
+ Version bump. Closes #78796, reported by djfunk <djfunk@free.fr>.
25 Jan 2005; Thomas Raschbacher <lordvan@gentoo.org> files/clamd.rc:
changed init script dependency from 'need net' to 'use net'. fixes bug
diff --git a/app-antivirus/clamav/clamav-0.81_rc1.ebuild b/app-antivirus/clamav/clamav-0.81_rc1.ebuild
new file mode 100644
index 000000000000..1bc517b0aad9
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.81_rc1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.81_rc1.ebuild,v 1.1 2005/01/25 16:08:09 ticho Exp $
+
+inherit eutils flag-o-matic
+
+#MY_P="${PN}-0.81rc1"
+#MY_P="${P}"
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/clamav/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~hppa ~alpha ~ppc64"
+IUSE="milter crypt"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )"
+PROVIDE="virtual/antivirus"
+
+S="${WORKDIR}/${P/_/}"
+
+pkg_setup() {
+ enewgroup clamav
+ enewuser clamav -1 /bin/false /dev/null clamav
+ pwconv || die
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+ use milter && myconf="--enable-milter"
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog TODO FAQ INSTALL
+ exeinto /etc/init.d ; newexe ${FILESDIR}/clamd.rc clamd
+ insinto /etc/conf.d ; newins ${FILESDIR}/clamd.conf clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+}
+
+pkg_postinst() {
+ echo
+ einfo "NOTE: As of clamav-0.80, the config file for clamd is no longer"
+ einfo " /etc/clamav.conf, but /etc/clamd.conf. Adjust your"
+ einfo " configuration accordingly before (re)starting clamd."
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ einfo "For simple instructions howto setup the clamav-milter..."
+ einfo ""
+ einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.81_rc1 b/app-antivirus/clamav/files/digest-clamav-0.81_rc1
new file mode 100644
index 000000000000..d9afdc3804c8
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.81_rc1
@@ -0,0 +1 @@
+MD5 f38933eb64d108a9ab3f0e5d6c0a69c1 clamav-0.81rc1.tar.gz 3018361