summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-02-27 23:21:30 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-02-27 23:21:30 +0000
commit017ec7cbb5db449c2d1c81aaa0859462c349fbea (patch)
treebaf81dada5f89370ce1637085e536b9c6b7d9287 /app-antivirus/clamav
parentNew version. (diff)
downloadgentoo-2-017ec7cbb5db449c2d1c81aaa0859462c349fbea.tar.gz
gentoo-2-017ec7cbb5db449c2d1c81aaa0859462c349fbea.tar.bz2
gentoo-2-017ec7cbb5db449c2d1c81aaa0859462c349fbea.zip
Fix milter stuff. Closes #83477.
(Portage version: 2.0.51.16)
Diffstat (limited to 'app-antivirus/clamav')
-rw-r--r--app-antivirus/clamav/ChangeLog13
-rw-r--r--app-antivirus/clamav/clamav-0.83.ebuild11
2 files changed, 19 insertions, 5 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 29329375ca89..33c659b75639 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.51 2005/02/17 10:48:15 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.52 2005/02/27 23:21:30 ticho Exp $
+
+ 27 Feb 2005; Andrej Kacian <ticho@gentoo.org> clamav-0.83.ebuild:
+ Fixed milter issue - added a conditional depend on mail-mta/sendmail, and a
+ check for milter USE flag being enabled for sendmail. Closes #83477,
+ reported by Drake Wyrm <bigwyrm@myrealbox.com>, who also suggested the fix.
17 Feb 2005; Guy Martin <gmsoft@gentoo.org> clamav-0.82-r1.ebuild:
Stable on hppa.
@@ -37,7 +42,7 @@
06 Feb 2005; Markus Rothe <corsair@gentoo.org> clamav-0.80.ebuild:
Stable on ppc64
- 30 Jan 2005; Bryan Østergaard <kloeri@gentoo.org> clamav-0.81.ebuild:
+ 30 Jan 2005; Bryan Østergaard <kloeri@gentoo.org> clamav-0.81.ebuild:
Stable on alpha, bug 78656.
28 Jan 2005; Michael Hanselmann <hansmi@gentoo.org> clamav-0.81.ebuild:
@@ -87,7 +92,7 @@
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
- 11 Dec 2004; Bryan Østergaard <kloeri@gentoo.org> clamav-0.80.ebuild:
+ 11 Dec 2004; Bryan Østergaard <kloeri@gentoo.org> clamav-0.80.ebuild:
~alpha keyword.
30 Nov 2004; Guy Martin <gmsoft@gentoo.org> clamav-0.80.ebuild:
@@ -197,7 +202,7 @@
04 May 2004; Luca Barbato <lu_zero@gentoo.org> clamav-0.70.ebuild:
Marked ppc
- 30 Apr 2004; Bryan Østergaard <kloeri@gentoo.org> clamav-0.70.ebuild:
+ 30 Apr 2004; Bryan Østergaard <kloeri@gentoo.org> clamav-0.70.ebuild:
Stable on alpha.
29 Apr 2004; Jason Wever <weeve@gentoo.org> clamav-0.70.ebuild:
diff --git a/app-antivirus/clamav/clamav-0.83.ebuild b/app-antivirus/clamav/clamav-0.83.ebuild
index bd32441b2095..04583b1d2f08 100644
--- a/app-antivirus/clamav/clamav-0.83.ebuild
+++ b/app-antivirus/clamav/clamav-0.83.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.83.ebuild,v 1.1 2005/02/14 01:47:19 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.83.ebuild,v 1.2 2005/02/27 23:21:30 ticho Exp $
inherit eutils flag-o-matic
@@ -15,6 +15,7 @@ IUSE="crypt milter selinux"
DEPEND="virtual/libc
crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( mail-mta/sendmail )
>=sys-libs/zlib-1.2.1-r3
>=net-misc/curl-7.10.0"
RDEPEND="selinux? ( sec-policy/selinux-clamav )"
@@ -23,6 +24,14 @@ PROVIDE="virtual/antivirus"
#S="${WORKDIR}/${P/_/}"
pkg_setup() {
+ if use milter; then
+ if ! built_with_use mail-mta/sendmail milter; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
enewgroup clamav
enewuser clamav -1 /bin/false /dev/null clamav
pwconv || die