summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-07-08 20:22:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-07-08 20:22:49 +0000
commitf7dec5216561cb8684b62b0474e4f595025d949e (patch)
treec7b95596f23dce323d8eddfd920ba4eb2bf1dc53 /app-admin
parentadded ~alpha to KEYWORDS to fix dep problems (diff)
downloadgentoo-2-f7dec5216561cb8684b62b0474e4f595025d949e.tar.gz
gentoo-2-f7dec5216561cb8684b62b0474e4f595025d949e.tar.bz2
gentoo-2-f7dec5216561cb8684b62b0474e4f595025d949e.zip
fix userpriv and sandbox issue
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/amanda/ChangeLog5
-rw-r--r--app-admin/amanda/Manifest4
-rw-r--r--app-admin/amanda/amanda-2.4.4-r1.ebuild10
3 files changed, 11 insertions, 8 deletions
diff --git a/app-admin/amanda/ChangeLog b/app-admin/amanda/ChangeLog
index 9a4a6ab373d2..78f70c7b574f 100644
--- a/app-admin/amanda/ChangeLog
+++ b/app-admin/amanda/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/amanda
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/ChangeLog,v 1.2 2003/07/08 07:23:48 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/ChangeLog,v 1.3 2003/07/08 20:22:46 robbat2 Exp $
+
+ 08 Jul 2003; Robin Johnson <robbat2@gentoo.org> amanda-2.4.4-r1.ebuild:
+ Fix userpriv+sandbox issue in ebuild.
*amanda-2.4.4-r1 (08 Jul 2003)
diff --git a/app-admin/amanda/Manifest b/app-admin/amanda/Manifest
index a20b58d79bbc..3fa11678c5f1 100644
--- a/app-admin/amanda/Manifest
+++ b/app-admin/amanda/Manifest
@@ -1,6 +1,6 @@
MD5 b2f5b785a20a1b356e58629612c0aab5 amanda-2.4.4.ebuild 8488
-MD5 f376bcdf8ea3c00e0fa0a359ae85aac4 amanda-2.4.4-r1.ebuild 11277
-MD5 3f994b4f0c3d0b2a2cfccb164876d661 ChangeLog 1304
+MD5 ce62d43fec8c669a9e462c87071b08db amanda-2.4.4-r1.ebuild 11277
+MD5 5f810b2498df02e883d204547428af27 ChangeLog 1419
MD5 b21569120561b1c58ad59e93ce6df732 files/amanda-devfs 216
MD5 fe28f64731a2dbf85f76b6f38942e032 files/example_disklist 55
MD5 a98390eb2ab16398b7332c42560c190f files/amanda-cron 419
diff --git a/app-admin/amanda/amanda-2.4.4-r1.ebuild b/app-admin/amanda/amanda-2.4.4-r1.ebuild
index 19f6c962d1bd..0be4dda32b98 100644
--- a/app-admin/amanda/amanda-2.4.4-r1.ebuild
+++ b/app-admin/amanda/amanda-2.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/amanda-2.4.4-r1.ebuild,v 1.1 2003/07/08 07:23:48 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/amanda-2.4.4-r1.ebuild,v 1.2 2003/07/08 20:22:46 robbat2 Exp $
inherit eutils
DESCRIPTION="The Advanced Maryland Automatic Network Disk Archiver"
@@ -38,8 +38,6 @@ ENVDFILE="97amanda"
TMPENVFILE="${MYTMPDIR}/${ENVDFILE}"
amanda_variable_setup() {
- # places for us to work in
- mkdir -p ${MYFILESDIR} ${MYTMPDIR}
# Setting vars
local currentamanda
@@ -92,8 +90,6 @@ amanda_variable_setup() {
# Re-apply the new settings if any
[ -n "${currentamanda}" ] && eval `echo "${currentamada}"`
- # Now we store the settings we just created
- set | egrep "^AMANDA_" > ${TMPENVFILE}
}
pkg_setup() {
@@ -106,6 +102,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
amanda_variable_setup
+ # places for us to work in
+ mkdir -p ${MYFILESDIR} ${MYTMPDIR}
+ # Now we store the settings we just created
+ set | egrep "^AMANDA_" > ${TMPENVFILE}
}
src_compile() {