summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-08-29 21:02:02 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-08-29 21:02:02 +0000
commite158666ca015a88804aacf1cc14996fa2e76ff7e (patch)
treed62f6632e0f151156253e917475ba74c30f25c26 /app-admin
parentAdd dev-libs/liblognorm, bug #348698 (diff)
downloadgentoo-2-e158666ca015a88804aacf1cc14996fa2e76ff7e.tar.gz
gentoo-2-e158666ca015a88804aacf1cc14996fa2e76ff7e.tar.bz2
gentoo-2-e158666ca015a88804aacf1cc14996fa2e76ff7e.zip
Bump version to support and fix the following:
* Newer Intel XvMC (i915). Based on patch from Otávio Cipriani <otavio.n.cipriani@gmail.com> bug #378827 * Fix bad redirect. bug #314031 * Add unichrome support (Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-xvmc/ChangeLog12
-rw-r--r--app-admin/eselect-xvmc/eselect-xvmc-0.3.ebuild20
-rw-r--r--app-admin/eselect-xvmc/files/eselect-xvmc-0.3.eselect189
3 files changed, 220 insertions, 1 deletions
diff --git a/app-admin/eselect-xvmc/ChangeLog b/app-admin/eselect-xvmc/ChangeLog
index 602233e5e96d..6ff162677475 100644
--- a/app-admin/eselect-xvmc/ChangeLog
+++ b/app-admin/eselect-xvmc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-admin/eselect-xvmc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-xvmc/ChangeLog,v 1.17 2011/08/29 06:31:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-xvmc/ChangeLog,v 1.18 2011/08/29 21:02:02 cardoe Exp $
+
+*eselect-xvmc-0.3 (29 Aug 2011)
+
+ 29 Aug 2011; Doug Goldstein <cardoe@gentoo.org> +eselect-xvmc-0.3.ebuild,
+ +files/eselect-xvmc-0.3.eselect:
+ Bump version to support and fix the following:
+ * Newer Intel XvMC (i915). Based on patch from Otávio Cipriani
+ <otavio.n.cipriani@gmail.com> bug #378827
+ * Fix bad redirect. bug #314031
+ * Add unichrome support
29 Aug 2011; Jeroen Roovers <jer@gentoo.org> eselect-xvmc-0.2.ebuild:
Stable for HPPA (bug #376283).
diff --git a/app-admin/eselect-xvmc/eselect-xvmc-0.3.ebuild b/app-admin/eselect-xvmc/eselect-xvmc-0.3.ebuild
new file mode 100644
index 000000000000..4e28876fba03
--- /dev/null
+++ b/app-admin/eselect-xvmc/eselect-xvmc-0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-xvmc/eselect-xvmc-0.3.ebuild,v 1.1 2011/08/29 21:02:02 cardoe Exp $
+
+DESCRIPTION="Manages XvMC implementations"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.0.10"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/${P}.eselect xvmc.eselect || die "newins failed"
+}
diff --git a/app-admin/eselect-xvmc/files/eselect-xvmc-0.3.eselect b/app-admin/eselect-xvmc/files/eselect-xvmc-0.3.eselect
new file mode 100644
index 000000000000..8e9659ae5600
--- /dev/null
+++ b/app-admin/eselect-xvmc/files/eselect-xvmc-0.3.eselect
@@ -0,0 +1,189 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: eselect-xvmc-0.3.eselect,v 1.1 2011/08/29 21:02:02 cardoe Exp $
+
+DESCRIPTION="Manage the XvMC implementation used by your system"
+MAINTAINER="cardoe@gentoo.org"
+SVN_DATE='$Date: 2011/08/29 21:02:02 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+XVMCLIBS=(
+"libXvMCNVIDIA_dynamic.so.1"
+"libXvMC.so.1"
+"libviaXvMC.so.1"
+"libviaXvMCPro.so.1"
+"libchromeXvMC.so.1"
+"libchromeXvMCPro.so.1"
+"libXvMCVIA.so"
+"libXvMCVIAPro.so"
+"libI810XvMC.so.1"
+"/usr/lib/libIntelXvMC.so"
+"libAMDXvBA.so.1" )
+XVMCPRETTY=(
+"nvidia"
+"xorg-x11"
+"via"
+"via-pro"
+"openchrome"
+"openchrome-pro"
+"unichrome"
+"unichrome-pro"
+"intel-i815"
+"intel-i915"
+"ati" )
+
+get_implementation_indices() {
+ local ret n
+ for (( n = 0; n < ${#XVMCLIBS[@]}; ++n )); do
+ [[ -e "${ROOT}/usr/lib/${XVMCLIBS[n]}" ]] && ret+=($n)
+ done
+
+ echo ${ret[@]}
+}
+
+get_current_implementation_index() {
+ local n
+ if [[ -f "${ROOT}/etc/X11/XvMCConfig" ]]; then
+ local current=$(< "${ROOT}/etc/X11/XvMCConfig")
+ for (( n = 0; n < ${#XVMCLIBS[@]}; ++n )); do
+ if [[ "${XVMCLIBS[n]}" = "${current}" ]]; then
+ echo "${n}"
+ return
+ fi
+ done
+ fi
+
+ echo "-1"
+}
+
+set_new_implementation() {
+ echo -n "Switching to ${XVMCPRETTY[$1]} XvMC implementation..."
+ touch "${ROOT}/etc/X11/XvMCConfig" 2>&1 > /dev/null
+ if [[ $? -eq 0 ]]; then
+ echo "${XVMCLIBS[$1]}" > "${ROOT}/etc/X11/XvMCConfig"
+ chmod 644 "${ROOT}/etc/X11/XvMCConfig"
+ chown 0:0 "${ROOT}/etc/X11/XvMCConfig"
+ echo " done"
+ else
+ echo " failed!"
+ echo "Insufficient privileges"
+ fi
+}
+
+### list action
+
+## {{{ list stuff
+describe_list() {
+ echo "List Available XvMC implementations"
+}
+
+do_list() {
+ local output n
+ local avail=( $(get_implementation_indices) )
+ local current=$(get_current_implementation_index)
+ write_list_start "Available XvMC implementations ( $(highlight '*') is current ):"
+
+ if (( ${#avail[@]} )) ; then
+ for n in "${avail[@]}" ; do
+ output[n]="${XVMCPRETTY[n]}"
+ [[ ${current} -eq ${n} ]] && \
+ output[n]+=" $(highlight '*')"
+ done
+ write_numbered_list "${output[@]}"
+ else
+ write_kv_list_entry "(none found)" ""
+ fi
+
+ return 0
+}
+## }}}
+
+### show action
+
+## {{{ show stuff
+describe_show() {
+ echo "Print the current XvMC implementation."
+}
+
+do_show() {
+ local current=$(get_current_implementation_index)
+ write_list_start "Current XvMC implementation:"
+
+ if [[ ${current} -ne -1 ]]; then
+ echo "${XVMCPRETTY[current]}"
+ return 0
+ else
+ echo "(none)"
+ return 2
+ fi
+}
+## }}}
+
+### set action
+
+## {{{ set stuff
+describe_set() {
+ echo "Select the XvMC implementation"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+describe_set_options() {
+ echo "<target> : XvMC implementation to activate"
+ echo "--use-old : If an implementation is already set, use that one instead"
+}
+
+do_set() {
+ local current=$(get_current_implementation_index)
+ local avail=( $(get_implementation_indices) )
+ local n new action
+
+ while [[ ${#@} -gt 0 ]]; do
+ local opt=${1}
+ shift
+ case ${opt} in
+ --use-old)
+ if [[ ${current} -gt -1 ]]; then
+ (( ${current} < ${#XVMCPRETTY[@]} )) && action="old-implementation"
+ fi
+ ;;
+ *)
+ [[ -z ${action} ]] && action="set-implementation"
+
+ if is_number ${opt} ; then
+ new=${avail[opt - 1]}
+ if [[ -z ${new} ]]; then
+ die -q "Unrecognized option: ${opt}"
+ fi
+ elif has ${opt} ${XVMCPRETTY[@]}; then
+ for (( n = 0; n < ${#XVMCPRETTY[@]}; ++n )); do
+ [[ "${XVMCPRETTY[n]}" = "${opt}" ]] && new=${n}
+ done
+ else
+ die -q "Unrecognized option: ${opt}"
+ fi
+ ;;
+ esac
+ done
+
+ case ${action} in
+ old-implementation)
+ set_new_implementation ${current}
+ return $?
+ ;;
+ set-implementation)
+ if [[ -n ${new} ]]; then
+ set_new_implementation ${new}
+ return $?
+ else
+ die -q "Please specify an implementation to set"
+ fi
+ ;;
+ *)
+ die -q "Invalid usage of set action."
+ esac
+}
+
+# vim: ts=4 sw=4 noet fdm=marker