summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-13 23:46:59 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-13 23:46:59 +0000
commite00912908d5b3fe0ad16341d80bebb49e2476ea3 (patch)
treef673cbbcd139e8049553f76910fd80dd50edac0d /app-admin
parentnew version; removed older; masked until all dependant apps/libs is fixed for... (diff)
downloadgentoo-2-e00912908d5b3fe0ad16341d80bebb49e2476ea3.tar.gz
gentoo-2-e00912908d5b3fe0ad16341d80bebb49e2476ea3.tar.bz2
gentoo-2-e00912908d5b3fe0ad16341d80bebb49e2476ea3.zip
Added msyslog, a modular-designed syslog, with log protection.
This baby supports standard syslogd configuration syntax, logging to an SQL database (comes with modules for MySQL and PostgreSQL), regex filtering and more. Features an implementation of PEO-1 and L-PEO, two new algorithmic protocols for integrity checking of logs, even when the root account was comprimised. The default config file (/etc/msyslog/msyslog.conf) turns on two simple, classic style logs. There are examples for MySQL and PostgreSQL included. --Enjoy :)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/msyslog/files/digest-msyslog-1.08a1
-rw-r--r--app-admin/msyslog/files/msyslog-1.08a-gentoo.diff608
-rw-r--r--app-admin/msyslog/files/msyslog-confd4
-rw-r--r--app-admin/msyslog/files/msyslog-init20
-rw-r--r--app-admin/msyslog/files/msyslog.conf71
-rw-r--r--app-admin/msyslog/msyslog-1.08a.ebuild61
6 files changed, 765 insertions, 0 deletions
diff --git a/app-admin/msyslog/files/digest-msyslog-1.08a b/app-admin/msyslog/files/digest-msyslog-1.08a
new file mode 100644
index 000000000000..1f6dd44973c4
--- /dev/null
+++ b/app-admin/msyslog/files/digest-msyslog-1.08a
@@ -0,0 +1 @@
+MD5 76a3501b89c2a90a336242ac2b325891 msyslog-v1.08a.tgz 126976
diff --git a/app-admin/msyslog/files/msyslog-1.08a-gentoo.diff b/app-admin/msyslog/files/msyslog-1.08a-gentoo.diff
new file mode 100644
index 000000000000..6601cbc227c5
--- /dev/null
+++ b/app-admin/msyslog/files/msyslog-1.08a-gentoo.diff
@@ -0,0 +1,608 @@
+diff -ur msyslog-v1.08a.orig/src/modules/Makefile.in msyslog-v1.08a/src/modules/Makefile.in
+--- msyslog-v1.08a.orig/src/modules/Makefile.in Mon Dec 3 15:31:14 2001
++++ msyslog-v1.08a/src/modules/Makefile.in Sat Jan 12 22:32:05 2002
+@@ -29,13 +29,12 @@
+ #
+
+ CC= @CC@
+-LD= ld
+ CFLAGS= @CFLAGS@
+ DCCFLAGS= @DCCFLAGS@
+ CPPFLAGS= -I.. @CPPFLAGS@
+
+ INSTALL= @INSTALL@
+-INSTALL_LIBDIR= @prefix@/lib/alat
++INSTALL_LIBDIR= @prefix@/lib
+
+ MLIBNAME= @MLIBNAME@
+ MSRCS= @MSRCS@
+@@ -49,7 +48,7 @@
+ $(MLIBNAME): $(MSRCS) $(HASH_SRCS) ../config.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(DCCFLAGS) -c $(HASH_SRCS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(DCCFLAGS) -c $(MSRCS)
+- $(LD) $(SHARED_PARAMS) -o $(MLIBNAME) $(MOBJS) $(HASH_OBJS)
++ $(CC) $(SHARED_PARAMS) -o $(MLIBNAME) $(MOBJS) $(HASH_OBJS)
+
+ all: $(MLIBNAME)
+
+diff -ur msyslog-v1.08a.orig/src/examples/syslog.conf.peo msyslog-v1.08a/src/examples/syslog.conf.peo
+--- msyslog-v1.08a.orig/src/examples/syslog.conf.peo Mon Dec 3 15:31:14 2001
++++ msyslog-v1.08a/src/examples/syslog.conf.peo Sat Jan 12 16:51:19 2002
+@@ -1,3 +1,3 @@
+ # Protect a log of classic module
+-auth.info %peo -l -k /var/ssyslog/.var.log.authlog.key %classic /var/log/authlog
++auth.info %peo -l -k /var/lib/msyslog/.var.log.authlog.key %classic /var/log/authlog
+
+diff -ur msyslog-v1.08a.orig/src/modules/om_peo.c msyslog-v1.08a/src/modules/om_peo.c
+--- msyslog-v1.08a.orig/src/modules/om_peo.c Mon Dec 3 15:31:14 2001
++++ msyslog-v1.08a/src/modules/om_peo.c Sat Jan 12 16:53:15 2002
+@@ -156,7 +156,7 @@
+ * INIT -- Initialize om_peo
+ * args:
+ *
+- * -k <keyfile> (default: /var/ssyslog/.var.log.messages)
++ * -k <keyfile> (default: /var/lib/msyslog/.var.log.messages)
+ * -l line number corruption detect mode
+ * (generates a strcat(keyfile, ".mac") file)
+ * -m <hash_method> md5, rmd160, or sha1 (default: sha1)
+diff -ur msyslog-v1.08a.orig/src/peo/hash.c msyslog-v1.08a/src/peo/hash.c
+--- msyslog-v1.08a.orig/src/peo/hash.c Mon Dec 3 15:31:14 2001
++++ msyslog-v1.08a/src/peo/hash.c Sat Jan 12 16:57:18 2002
+@@ -73,7 +73,7 @@
+ #endif
+
+
+-char *default_keyfile = "/var/ssyslog/.var.log.messages.key";
++char *default_keyfile = "/var/lib/msyslog/.var.log.messages.key";
+ char *hmstr[] = { /* enum order */
+ "md5",
+ "rmd160",
+diff -ur msyslog-v1.08a.orig/src/peo/peochk.c msyslog-v1.08a/src/peo/peochk.c
+--- msyslog-v1.08a.orig/src/peo/peochk.c Mon Dec 3 15:31:14 2001
++++ msyslog-v1.08a/src/peo/peochk.c Sat Jan 12 16:59:23 2002
+@@ -45,7 +45,7 @@
+ *
+ * defaults:
+ * logfile: /var/log/messages
+- * keyfile: /var/ssyslog/.var.log.messages.key
++ * keyfile: /var/lib/msyslog/.var.log.messages.key
+ * hash_method: sha1
+ *
+ * NOTES:
+@@ -475,12 +475,12 @@
+ if (keyfile == default_keyfile && logfile != default_logfile) {
+ char *tmp;
+
+- if ( (tmp = strallocat("/var/ssyslog/", logfile)) == NULL) {
++ if ( (tmp = strallocat("/var/lib/msyslog/", logfile)) == NULL) {
+ release();
+ perror("buffer for keyfile");
+ exit(-1);
+ }
+- strdot(tmp+13);
++ strdot(tmp+strlen("/var/lib/msyslog/"));
+ if ( (keyfile = strallocat(tmp, ".key")) == NULL) {
+ free(tmp);
+ release();
+diff -ur msyslog-v1.08a.orig/src/syslogd.h msyslog-v1.08a/src/syslogd.h
+--- msyslog-v1.08a.orig/src/syslogd.h Mon Dec 3 15:31:14 2001
++++ msyslog-v1.08a/src/syslogd.h Sat Jan 12 17:02:48 2002
+@@ -64,7 +64,7 @@
+ /* #warning using _PATH_KLOG "/dev/klog" */
+ #endif
+
+-#define _PATH_LOGCONF "/etc/syslog.conf"
++#define _PATH_LOGCONF "/etc/msyslog/msyslog.conf"
+
+ /*
+ * Debug reporting levels
+diff -ur msyslog-v1.08a.orig/configure msyslog-v1.08a/configure
+--- msyslog-v1.08a.orig/configure Mon Dec 3 15:31:14 2001
++++ msyslog-v1.08a/configure Sun Jan 13 16:07:14 2002
+@@ -3586,7 +3586,7 @@
+ prefix=$ac_default_prefix
+ fi
+ cat >>confdefs.h <<EOF
+-#define INSTALL_LIBDIR "$prefix/lib/alat"
++#define INSTALL_LIBDIR "$prefix/lib"
+ EOF
+
+ echo "$as_me:3592: checking wheter optreset is needed" >&5
+@@ -3745,7 +3745,7 @@
+ EOF
+
+ MAIN_CPPFLAGS="-Xlinker -E";
+- SHARED_PARAMS="-Bshareable"
++ SHARED_PARAMS="-shared"
+ DCCFLAGS=""
+ cat >>confdefs.h <<\EOF
+ #define _GNU_SOURCE 1
+@@ -3833,7 +3833,7 @@
+ # Name of pidfile
+ if test "$UNAME" = "Linux" ; then
+ cat >>confdefs.h <<\EOF
+-#define PID_FILE "syslogd.pid"
++#define PID_FILE "msyslogd.pid"
+ EOF
+
+ else
+diff -ur msyslog-v1.08a.orig/src/examples/im_bsd.8 msyslog-v1.08a/src/examples/im_bsd.8
+--- msyslog-1.08a.orig/src/man/im_bsd.8
++++ msyslog-1.08a/src/man/im_bsd.8
+@@ -53,7 +53,7 @@
+ .Pp
+ .Sh SEE ALSO
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr im_doors 8 ,
+ .Xr im_linux 8 ,
+ .Xr im_streams 8 ,
+@@ -69,7 +69,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/im_doors.8 msyslog-v1.08a/src/examples/im_doors.8
+--- msyslog-1.08a.orig/src/man/im_doors.8
++++ msyslog-1.08a/src/man/im_doors.8
+@@ -75,7 +75,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/im_linux.8 msyslog-v1.08a/src/examples/im_linux.8
+--- msyslog-1.08a.orig/src/man/im_linux.8
++++ msyslog-1.08a/src/man/im_linux.8
+@@ -116,7 +116,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/im_streams.8 msyslog-v1.08a/src/examples/im_streams.8
+--- msyslog-1.08a.orig/src/man/im_streams.8
++++ msyslog-1.08a/src/man/im_streams.8
+@@ -75,7 +75,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/im_tcp.8 msyslog-v1.08a/src/examples/im_tcp.8
+--- msyslog-1.08a.orig/src/man/im_tcp.8
++++ msyslog-1.08a/src/man/im_tcp.8
+@@ -87,7 +87,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/im_udp.8 msyslog-v1.08a/src/examples/im_udp.8
+--- msyslog-1.08a.orig/src/man/im_udp.8
++++ msyslog-1.08a/src/man/im_udp.8
+@@ -90,7 +90,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/im_unix.8 msyslog-v1.08a/src/examples/im_unix.8
+--- msyslog-1.08a.orig/src/man/im_unix.8
++++ msyslog-1.08a/src/man/im_unix.8
+@@ -77,7 +77,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/om_classic.8 msyslog-v1.08a/src/examples/om_classic.8
+--- msyslog-1.08a.orig/src/man/om_classic.8
++++ msyslog-1.08a/src/man/om_classic.8
+@@ -40,7 +40,7 @@
+ .Ar filename | user{,user} | * | @hostname
+ .Sh DESCRIPTION
+ If there is no module mentioned in a
+-.Xr syslog.conf 5
++.Xr msyslog.conf 5
+ line,
+ .Xr om_classic 8
+ is used.
+@@ -79,7 +79,7 @@
+ .Pp
+ .Sh SEE ALSO
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_mysql 8 ,
+ .Xr om_peo 8 ,
+ .Xr om_pgsql 8 ,
+@@ -96,7 +96,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/om_mysql.8 msyslog-v1.08a/src/examples/om_mysql.8
+--- msyslog-1.08a.orig/src/man/om_mysql.8
++++ msyslog-1.08a/src/man/om_mysql.8
+@@ -58,7 +58,7 @@
+ .It Fl p Ar password
+ The plaintext password for this MySQL user. Thus it is recommended NOT to
+ leave
+-.Xr syslog.conf 5
++.Xr msyslog.conf 5
+ world readable if this module is used.
+ .It Fl d Ar database
+ The database name to use on the specified MySQL server.
+@@ -96,7 +96,7 @@
+ features.
+ .Sh SEE ALSO
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_classic 8 ,
+ .Xr om_peo 8 ,
+ .Xr om_pgsql 8 ,
+@@ -117,7 +117,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/om_peo.8 msyslog-v1.08a/src/examples/om_peo.8
+--- msyslog-1.08a.orig/src/man/om_peo.8
++++ msyslog-1.08a/src/man/om_peo.8
+@@ -51,7 +51,7 @@
+ .Bl -tag -width Ds
+ .It Fl k Ar keyfile
+ Specify the key file pathname; the default is
+-.Pa /var/ssyslog/.var.log.messages.key
++.Pa /var/lib/msyslog/.var.log.messages.key
+ .It Fl l
+ This option enables the line corrupted detection mode;
+ the module generates two keys, the first explained above and a second
+@@ -79,12 +79,12 @@
+ If you want to protect the
+ .Pa /var/log/authlog
+ file you should edit the
+-.Pa /etc/syslog.conf
++.Pa /etc/msyslog/msyslog.conf
+ file (see
+-.Xr syslog.conf 5
++.Xr msyslog.conf 5
+ ) and add a line with something like this:
+ .Pp
+-.Dl auth.info %peo -l -k /var/ssyslog/.var.log.authlog.key %classic /var/log/authlog
++.Dl auth.info %peo -l -k /var/lib/msyslog/.var.log.authlog.key %classic /var/log/authlog
+ .Pp
+ You should generate the initial key with
+ .Xr peochk 8
+@@ -93,7 +93,7 @@
+ .Sh SEE ALSO
+ .Li Vcr and Peo Revised documentation - http://www.corest.com/papers/peo.ps
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_classic 8 ,
+ .Xr om_mysql 8 ,
+ .Xr om_pgsql 8 ,
+@@ -110,28 +110,28 @@
+ .Pp
+ .Dl *.err /var/log/messages
+ .Pp
+-.Dl *.err %peo -k /var/ssyslog/.var.log.messages.key
++.Dl *.err %peo -k /var/lib/msyslog/.var.log.messages.key
+ .Pp
+ the following is wrong either:
+ .Pp
+ .Dl *.err %classic /var/log/messages
+ .Pp
+-.Dl *.err %peo -k /var/ssyslog/.var.log.messages.key
++.Dl *.err %peo -k /var/lib/msyslog/.var.log.messages.key
+ .Pp
+ The correct line is:
+ .Pp
+-.Dl *.err %classic /var/log/messages %peo -k /var/ssyslog/.var.log.messages.key
++.Dl *.err %classic /var/log/messages %peo -k /var/lib/msyslog/.var.log.messages.key
+ .Pp
+ or
+ .Pp
+-.Dl *.err %peo -k /var/ssyslog/.var.log.messages.key %classic /var/log/messages
++.Dl *.err %peo -k /var/lib/msyslog/.var.log.messages.key %classic /var/log/messages
+ .It
+ Submit bugs at this project's Sourceforge Bug reporting system at:
+ http://sourceforge.net/tracker/?func=add&group_id=25741&atid=385117
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/om_pgsql.8 msyslog-v1.08a/src/examples/om_pgsql.8
+--- msyslog-1.08a.orig/src/man/om_pgsql.8
++++ msyslog-1.08a/src/man/om_pgsql.8
+@@ -57,7 +57,7 @@
+ .It Fl p Ar password
+ The plaintext password for this PostgreSQL user. Thus it is recommended NOT to
+ leave
+-.Xr syslog.conf 5
++.Xr msyslog.conf 5
+ world readable if this module is used.
+ .It Fl d Ar database
+ The database name to use on the specified PostgreSQL server.
+@@ -67,7 +67,7 @@
+ Create the table.
+ .Sh EXAMPLES
+ Example entry for
+-.Xr syslog.conf 5
++.Xr msyslog.conf 5
+ :
+ .Pp
+ .Bd -literal
+@@ -93,7 +93,7 @@
+ can be any text format smaller than 128 and 1024 chars respectively.
+ .Sh SEE ALSO
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_classic 8 ,
+ .Xr om_mysql 8 ,
+ .Xr om_peo 8 ,
+@@ -114,7 +114,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/om_regex.8 msyslog-v1.08a/src/examples/om_regex.8
+--- msyslog-1.08a.orig/src/man/om_regex.8
++++ msyslog-1.08a/src/man/om_regex.8
+@@ -64,7 +64,7 @@
+ .Ed
+ .Sh SEE ALSO
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_classic 8 ,
+ .Xr om_mysql 8 ,
+ .Xr om_peo 8 ,
+@@ -83,7 +83,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/om_tcp.8 msyslog-v1.08a/src/examples/om_tcp.8
+--- msyslog-1.08a.orig/src/man/om_tcp.8
++++ msyslog-1.08a/src/man/om_tcp.8
+@@ -66,14 +66,14 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+ .Sh SEE ALSO
+ .Xr im_tcp 8 ,
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_classic 8 ,
+ .Xr om_mysql 8 ,
+ .Xr om_peo 8 ,
+diff -ur msyslog-v1.08a.orig/src/examples/peochk.8 msyslog-v1.08a/src/examples/peochk.8
+--- msyslog-1.08a.orig/src/man/peochk.8
++++ msyslog-1.08a/src/man/peochk.8
+@@ -92,7 +92,7 @@
+ Specify the key pathname (this file is used by the
+ .Em peo output module
+ to generate a hash key from the last logged message); the default is
+-.Pa /var/ssyslogd/xxx.key
++.Pa /var/lib/msyslog/xxx.key
+ where
+ .Pa xxx
+ is
+@@ -146,16 +146,16 @@
+ .Pp
+ .It
+ Edit
+-.Xr syslog.conf 5
++.Xr msyslog.conf 5
+ file and enable
+ .Em peo output module
+ with something like this:
+ .Pp
+-.Dl auth.info %classic /var/log/authlog %peo -m rmd160 -l -k /var/ssyslog/.var.log.authlog.key
++.Dl auth.info %classic /var/log/authlog %peo -m rmd160 -l -k /var/lib/msyslog/.var.log.authlog.key
+ .Pp
+ .It
+ Inform new changes on
+-.Xr syslog.conf 5
++.Xr msyslog.conf 5
+ to
+ .Xr syslogd 8 :
+ .Pp
+@@ -180,7 +180,7 @@
+ ).
+ .El
+ .Sh SEE ALSO
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_peo 8 ,
+ .Xr syslogd 8
+ .Sh BUGS
+@@ -189,6 +189,6 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+diff -ur msyslog-v1.08a.orig/src/examples/syslog.conf.5 msyslog-v1.08a/src/examples/syslog.conf.5
+--- msyslog-1.08a.orig/src/man/syslog.conf.5
++++ msyslog-1.08a/src/man/syslog.conf.5
+@@ -1,4 +1,4 @@
+-.\" $CoreSDI: syslog.conf.5,v 1.7.2.1.2.1.4.6 2001/11/20 09:56:23 alejo Exp $
++.\" $CoreSDI:msyslog.conf.5,v 1.7.2.1.2.1.4.6 2001/11/20 09:56:23 alejo Exp $
+ .\"
+ .\" Copyright (c) 1990, 1991, 1993
+ .\" The Regents of the University of California. All rights reserved.
+@@ -27,15 +27,15 @@
+ .\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ .\" SUCH DAMAGE.
+ .\"
+-.\" from: @(#)syslog.conf.5 8.1 (Berkeley) 6/9/93
+-.\" $OpenBSD: syslog.conf.5,v 1.4 1997/11/09 09:45:04 todd Exp $
+-.\" $NetBSD: syslog.conf.5,v 1.4 1996/01/02 17:41:46 perry Exp $
++.\" from: @(#msyslog.conf.5 8.1 (Berkeley) 6/9/93
++.\" $OpenBSD:msyslog.conf.5,v 1.4 1997/11/09 09:45:04 todd Exp $
++.\" $NetBSD:msyslog.conf.5,v 1.4 1996/01/02 17:41:46 perry Exp $
+ .\"
+ .Dd June 9, 1993
+ .Dt SYSLOG.CONF 5
+ .Os Core-SDI
+ .Sh NAME
+-.Nm syslog.conf
++.Nm msyslog.conf
+ .Nd
+ .Xr syslogd 8
+ configuration file
+@@ -314,8 +314,8 @@
+ .Ed
+ .El
+ .Sh FILES
+-.Bl -tag -width /etc/syslog.conf -compact
+-.It Pa /etc/syslog.conf
++.Bl -tag -width /etc/msyslog/msyslog.conf -compact
++.It Pa /etc/msyslog/msyslog.conf
+ The
+ .Xr syslogd 8
+ configuration file.
+@@ -364,7 +364,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/syslogd.8 msyslog-v1.08a/src/examples/syslogd.8
+--- msyslog-1.08a.orig/src/man/syslogd.8
++++ msyslog-1.08a/src/man/syslogd.8
+@@ -72,7 +72,7 @@
+ .It Fl f Ar config_file
+ Specify the pathname of an alternate configuration file;
+ the default is
+-.Pa /etc/syslog.conf .
++.Pa /etc/msyslog/msyslog.conf .
+ .It Fl m Ar mark_interval
+ Select the number of minutes between ``mark'' messages;
+ the default is 20 minutes.
+@@ -116,7 +116,7 @@
+ receives a hangup signal.
+ For information on the format of the configuration file,
+ see
+-.Xr syslog.conf 5 .
++.Xr msyslog.conf 5 .
+ .Pp
+ .Nm Syslogd
+ creates the file
+@@ -168,7 +168,7 @@
+ socket to log standard messages.
+ .Sh FILES
+ .Bl -tag -width /var/run/syslog.pid -compact
+-.It Pa /etc/syslog.conf
++.It Pa /etc/msyslog/msyslog.conf
+ The configuration file.
+ .It Pa /var/run/syslog.pid
+ The process id of current
+@@ -182,7 +182,7 @@
+ .El
+ .Sh SEE ALSO
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr im_bsd 8 ,
+ .Xr im_doors 8 ,
+ .Xr im_linux 8 ,
+@@ -210,6 +210,6 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+diff -ur msyslog-v1.08a.orig/src/examples/im_file.8 msyslog-v1.08a/src/examples/im_file.8
+--- msyslog-1.08a.orig/src/man/im_file.8
++++ msyslog-1.08a/src/man/im_file.8
+@@ -86,7 +86,7 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+diff -ur msyslog-v1.08a.orig/src/examples/om_udp.8 msyslog-v1.08a/src/examples/om_udp.8
+--- msyslog-1.08a.orig/src/man/om_udp.8
++++ msyslog-1.08a/src/man/om_udp.8
+@@ -64,13 +64,13 @@
+ You may also report them directly to the authors; send an email to
+ core.devel.alat@corest.com, describing the problem the most you can,
+ containing also machine description, hardware description, the
+-configuration file (/etc/syslog.conf), the OS description, and the
++configuration file (/etc/msyslog/msyslog.conf), the OS description, and the
+ invoking command line.
+ The more you describe the bug, the faster we can fix it.
+ .El
+ .Sh SEE ALSO
+ .Xr syslog 3 ,
+-.Xr syslog.conf 5 ,
++.Xr msyslog.conf 5 ,
+ .Xr om_classic 8 ,
+ .Xr om_mysql 8 ,
+ .Xr om_peo 8 ,
diff --git a/app-admin/msyslog/files/msyslog-confd b/app-admin/msyslog/files/msyslog-confd
new file mode 100644
index 000000000000..84b87f80d97e
--- /dev/null
+++ b/app-admin/msyslog/files/msyslog-confd
@@ -0,0 +1,4 @@
+# Config file for /etc/init.d/msyslog
+
+# Passed to /usr/sbin/msyslogd...
+MSYSLOG_OPTS="-i unix /dev/log -i linux"
diff --git a/app-admin/msyslog/files/msyslog-init b/app-admin/msyslog/files/msyslog-init
new file mode 100644
index 000000000000..5fb1ebd173df
--- /dev/null
+++ b/app-admin/msyslog/files/msyslog-init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-admin/msyslog/files/msyslog-init,v 1.1 2002/01/13 23:46:59 woodchip Exp $
+
+depend() {
+ need clock
+}
+
+start() {
+ ebegin "Starting msyslog"
+ start-stop-daemon --start --quiet --exec /usr/sbin/msyslogd -- ${MSYSLOG_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping msyslog"
+ start-stop-daemon --stop --quiet --pidfile /var/run/msyslogd.pid
+ eend $?
+}
diff --git a/app-admin/msyslog/files/msyslog.conf b/app-admin/msyslog/files/msyslog.conf
new file mode 100644
index 000000000000..0eef170b9aea
--- /dev/null
+++ b/app-admin/msyslog/files/msyslog.conf
@@ -0,0 +1,71 @@
+# /etc/msyslog/msyslog.conf: configuration file for msyslogd.
+#
+# Msyslog uses a slightly different syntax than the old syslogd.
+# See below and in /usr/share/doc/msyslog/examples for samples
+# and documentation. See also the manpages for msyslog.conf(5),
+# msyslogd(8), and the output modules: om_mysql(8), om_regex(8),
+# om_pgsql(8), om_classic(8).
+#
+# The logfiles you specify with %classic must exist beforehand;
+# they will not be auto-created.
+
+
+# The default enables these two standard logfiles.
+*.*;auth,authpriv.none %classic /var/log/syslog
+*.warn;mark.*;auth,authpriv.none %classic /var/log/messages
+
+# Emergencies are sent to everybody currently logged in.
+*.emerg %classic *
+
+# The named pipe /dev/xconsole is for the `xconsole' utility.
+# To use it, you must invoke `xconsole' with the `-file' option:
+# $ xconsole -file /dev/xconsole [...]
+*.warn %classic |/dev/xconsole
+
+# This puts everything into one file.
+#*.* %classic /var/log/all
+
+# Sending messages to a virtual console.
+#*.*;auth,authpriv.none %classic /dev/tty8
+
+# Logging by facility.
+#auth,authpriv.* %classic /var/log/auth.log
+#cron.* %classic /var/log/cron.log
+#daemon.* %classic /var/log/daemon.log
+#ftp.* %classic /var/log/ftp.log
+#kern.* %classic /var/log/kern.log
+#lpr.* %classic /var/log/lpr.log
+#mail.* %classic /var/log/mail.log
+#news.* %classic /var/log/news.log
+#syslog.* %classic /var/log/syslog.log
+#user.* %classic /var/log/user.log
+#uucp.* %classic /var/log/uucp.log
+
+# Logging for the mail system.
+#mail.info %classic /var/log/mail.info
+#mail.warn %classic /var/log/mail.warn
+#mail.err %classic /var/log/mail.err
+
+# Logging for INN news system.
+#news.crit %classic /var/log/news/news.crit
+#news.err %classic /var/log/news/news.err
+#news.notice %classic /var/log/news/news.notice
+
+# Send messages to central logging host through UDP transport.
+# See im_udp(8) for how to set up the server.
+#*.* %classic @loghost
+
+# Logging to an SQL database. SECURITY ALERT. Since the mysql/postgresql
+# passwords need to appear here, this file should not be world readable!
+# ---
+# Log to server logger.mydomain.edu through MySQL
+#*.* %mysql -s logger.mydomain.edu -u loguser -p loguserpassword -d syslogDB -t syslogTB
+#
+# Log to server logger.mydomain.edu through MySQL, using DELAYED inserts
+#*.* %mysql -D -s logger.mydomain.edu -u loguser -p loguserpassword -d syslogDB -t syslogTB
+#
+# Log to server logger.mydomain.edu thru PGSQL
+#*.* %pgsql -s logger.mydomain.edu -u loguser -p loguserpassword -d syslogDB -t syslogTB
+
+# Protect a log of classic module.
+#auth.info %peo -l -k /var/lib/msyslog/.var.log.authlog.key %classic /var/log/authlog
diff --git a/app-admin/msyslog/msyslog-1.08a.ebuild b/app-admin/msyslog/msyslog-1.08a.ebuild
new file mode 100644
index 000000000000..6c9b9c77698d
--- /dev/null
+++ b/app-admin/msyslog/msyslog-1.08a.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/msyslog/msyslog-1.08a.ebuild,v 1.1 2002/01/13 23:46:59 woodchip Exp $
+
+DESCRIPTION="Flexible and easy to integrate syslog with modularized input/output"
+HOMEPAGE="http://www.core-sdi.com/download/download1.html"
+SRC_URI="http://community.corest.com/pub/${PN}/${PN}-v${PV}.tgz"
+S=${WORKDIR}/${PN}-v${PV}
+
+RDEPEND="virtual/glibc mysql? ( >=dev-db/mysql-3.23 ) postgres? ( >=dev-db/postgresql-7 )"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # fix paths for pidfile, config file, libdir, logdir, manpages, etc...
+ patch -p1 < ${FILESDIR}/${PN}-${PV}-gentoo.diff || die "bad patchfile"
+}
+
+src_compile() {
+ local myconf
+ use mysql || myconf="${myconf} --without-mysql"
+ use postgres || myconf="${myconf} --without-pgsql"
+
+ ./configure \
+ --prefix=/usr \
+ --with-daemon-name=msyslogd \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodir /var/lib/msyslog
+ dosbin src/msyslogd src/peo/peochk
+
+ exeinto /usr/lib
+ doexe src/modules/lib${PN}.so.${PV/a/}
+ ( cd ${D}/usr/lib ; ln -s lib${PN}.so.${PV/a/} lib${PN}.so )
+
+ # rename these puppies...
+ mv src/man/syslogd.8 src/man/msyslogd.8
+ mv src/man/syslog.conf.5 src/man/msyslog.conf.5
+ doman src/man/*.[85]
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS \
+ QUICK_INSTALL README src/TODO doc/*
+ docinto examples ; dodoc src/examples/*
+
+ insinto /etc/msyslog ; doins ${FILESDIR}/msyslog.conf
+ insinto /etc/conf.d ; newins ${FILESDIR}/msyslog-confd msyslog
+ exeinto /etc/init.d ; newexe ${FILESDIR}/msyslog-init msyslog
+}
+
+pkg_postinst() {
+ # the default /etc/msyslog/msyslog.conf uses these, so make sure
+ # it 'just works' for those who wont bother changing the config.
+ touch ${ROOT}/var/log/messages
+ touch ${ROOT}/var/log/syslog
+}