summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-03-23 16:06:42 +0000
committerJeroen Roovers <jer@gentoo.org>2011-03-23 16:06:42 +0000
commitce75583a89b5f6b20e1712696742dbc819960ec3 (patch)
tree0d1a157c0ea63a2c5900d9c28e9928fbdc625195 /app-admin
parentClean up old revisions. (diff)
downloadgentoo-2-ce75583a89b5f6b20e1712696742dbc819960ec3.tar.gz
gentoo-2-ce75583a89b5f6b20e1712696742dbc819960ec3.tar.bz2
gentoo-2-ce75583a89b5f6b20e1712696742dbc819960ec3.zip
Ignore splitdebug directories thanks to patch by Arfrever Frehtes Taifersar Arahesis (bug #308579).
(Portage version: 2.2.0_alpha28/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/python-updater/ChangeLog11
-rw-r--r--app-admin/python-updater/files/python-updater-0.8-splitdebug.patch22
-rw-r--r--app-admin/python-updater/python-updater-0.8-r1.ebuild (renamed from app-admin/python-updater/python-updater-0.8.ebuild)12
3 files changed, 41 insertions, 4 deletions
diff --git a/app-admin/python-updater/ChangeLog b/app-admin/python-updater/ChangeLog
index f6757bddff72..b2da5eab91ae 100644
--- a/app-admin/python-updater/ChangeLog
+++ b/app-admin/python-updater/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/python-updater
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/ChangeLog,v 1.53 2010/07/30 16:58:01 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/ChangeLog,v 1.54 2011/03/23 16:06:42 jer Exp $
+
+*python-updater-0.8-r1 (23 Mar 2011)
+
+ 23 Mar 2011; Jeroen Roovers <jer@gentoo.org> -python-updater-0.8.ebuild,
+ +python-updater-0.8-r1.ebuild, +files/python-updater-0.8-splitdebug.patch:
+ Ignore splitdebug directories thanks to patch by Arfrever Frehtes Taifersar
+ Arahesis (bug #308579).
30 Jul 2010; Jeroen Roovers <jer@gentoo.org> python-updater-0.8.ebuild:
Stable for HPPA (bug #320043).
diff --git a/app-admin/python-updater/files/python-updater-0.8-splitdebug.patch b/app-admin/python-updater/files/python-updater-0.8-splitdebug.patch
new file mode 100644
index 000000000000..f898228c7632
--- /dev/null
+++ b/app-admin/python-updater/files/python-updater-0.8-splitdebug.patch
@@ -0,0 +1,22 @@
+Index: python-updater
+===================================================================
+--- python-updater (revision 358)
++++ python-updater (working copy)
+@@ -554,7 +554,7 @@
+ fi
+
+ if [[ CHECK_STATIC_LINKING -ne 0 ]]; then
+- binaries="$(scanelf -qs +Py_Initialize < <(grep -E "^obj" "${content}" | cut -d" " -f2) | sed "s/.* //")"
++ binaries="$(scanelf -qs +Py_Initialize < <(grep -E "^obj" "${content}" | cut -d" " -f2 | grep -Ev "^/usr/lib(32|64)?/debug/") | sed "s/.* //")"
+ if [[ -n "${binaries}" ]]; then
+ PKGS_TO_REMERGE+=" ${CATPKGVER}"
+ eindent
+@@ -613,7 +613,7 @@
+ fi
+
+ if [[ CHECK_SHARED_LINKING -ne 0 ]]; then
+- binaries="$(scanelf -qF "%F %n" < <(grep -E "^obj" "${content}" | cut -d" " -f2) | grep -E "( |,)$(get_OLD_PYTHON_SHARED_LIBRARIES_REGEX)(,|$)")"
++ binaries="$(scanelf -qF "%F %n" < <(grep -E "^obj" "${content}" | cut -d" " -f2 | grep -Ev "^/usr/lib(32|64)?/debug/") | grep -E "( |,)$(get_OLD_PYTHON_SHARED_LIBRARIES_REGEX)(,|$)")"
+ if [[ -n "${binaries}" ]]; then
+ PKGS_TO_REMERGE+=" ${CATPKGVER}"
+ eindent
diff --git a/app-admin/python-updater/python-updater-0.8.ebuild b/app-admin/python-updater/python-updater-0.8-r1.ebuild
index e240a6783849..dabe14646ba0 100644
--- a/app-admin/python-updater/python-updater-0.8.ebuild
+++ b/app-admin/python-updater/python-updater-0.8-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.8.ebuild,v 1.8 2010/07/30 16:58:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.8-r1.ebuild,v 1.1 2011/03/23 16:06:42 jer Exp $
+
+inherit eutils
DESCRIPTION="Script used to remerge python packages when changing Python version."
HOMEPAGE="http://www.gentoo.org/proj/en/Python"
@@ -16,6 +18,12 @@ RDEPEND="!<dev-lang/python-2.3.6-r2
dev-lang/python
|| ( >=sys-apps/portage-2.1.2 sys-apps/paludis )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-splitdebug.patch
+}
+
src_install() {
dosbin ${PN} || die "dosbin failed"
doman ${PN}.1 || die "doman failed"