summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-03-03 11:42:24 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-03-03 11:42:24 +0000
commitc64ff95b3cf270d3c775edc52a713a14e007b2f2 (patch)
tree13e6f652f33d80cc4ecdbee11579e2ddf66c655d /app-admin
parentVersion bump (diff)
downloadgentoo-2-c64ff95b3cf270d3c775edc52a713a14e007b2f2.tar.gz
gentoo-2-c64ff95b3cf270d3c775edc52a713a14e007b2f2.tar.bz2
gentoo-2-c64ff95b3cf270d3c775edc52a713a14e007b2f2.zip
Version bump to 1.4.5, fix HOMEPAGE and documentation url. Sync live ebuild
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/ChangeLog8
-rw-r--r--app-admin/ansible/ansible-1.4.3.ebuild8
-rw-r--r--app-admin/ansible/ansible-1.4.5.ebuild62
-rw-r--r--app-admin/ansible/ansible-9999.ebuild8
4 files changed, 77 insertions, 9 deletions
diff --git a/app-admin/ansible/ChangeLog b/app-admin/ansible/ChangeLog
index 7b20d190340d..3a1f770a59aa 100644
--- a/app-admin/ansible/ChangeLog
+++ b/app-admin/ansible/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/ansible
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.32 2014/01/10 13:18:35 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.33 2014/03/03 11:42:24 pinkbyte Exp $
+
+*ansible-1.4.5 (03 Mar 2014)
+
+ 03 Mar 2014; Sergey Popov <pinkbyte@gentoo.org> ansible-1.4.3.ebuild,
+ +ansible-1.4.5.ebuild, ansible-9999.ebuild:
+ Version bump to 1.4.5, fix HOMEPAGE and documentation url. Sync live ebuild
10 Jan 2014; Sergey Popov <pinkbyte@gentoo.org> ansible-1.3.4.ebuild:
Stable on amd64 and x86, wrt bug #495196
diff --git a/app-admin/ansible/ansible-1.4.3.ebuild b/app-admin/ansible/ansible-1.4.3.ebuild
index a659e63e2979..757f56ee6942 100644
--- a/app-admin/ansible/ansible-1.4.3.ebuild
+++ b/app-admin/ansible/ansible-1.4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.4.3.ebuild,v 1.1 2013/12/29 09:15:08 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.4.3.ebuild,v 1.2 2014/03/03 11:42:24 pinkbyte Exp $
EAPI="5"
@@ -9,7 +9,7 @@ PYTHON_COMPAT=( python{2_6,2_7} )
inherit distutils-r1 readme.gentoo
DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
-HOMEPAGE="http://ansible.cc/"
+HOMEPAGE="http://ansible.com/"
SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -32,7 +32,7 @@ RDEPEND="
DOC_CONTENTS="You can define parameters through shell variables OR use config files
Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
You have to create ansible hosts file!\n
-More info on http://ansible.cc/docs/gettingstarted.html"
+More info on http://docs.ansible.com/intro_getting_started.html"
python_prepare_all() {
distutils-r1_python_prepare_all
diff --git a/app-admin/ansible/ansible-1.4.5.ebuild b/app-admin/ansible/ansible-1.4.5.ebuild
new file mode 100644
index 000000000000..31f7ba893284
--- /dev/null
+++ b/app-admin/ansible/ansible-1.4.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.4.5.ebuild,v 1.1 2014/03/03 11:42:24 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
+HOMEPAGE="http://ansible.com/"
+SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/nose
+ dev-vcs/git
+ )"
+RDEPEND="
+ dev-python/jinja
+ dev-python/pyyaml
+ dev-python/paramiko
+ net-misc/sshpass
+ virtual/ssh
+"
+
+DOC_CONTENTS="You can define parameters through shell variables OR use config files
+Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
+You have to create ansible hosts file!\n
+More info on http://docs.ansible.com/intro_getting_started.html"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # Skip tests which need ssh access
+ sed -i 's:$(NOSETESTS) -d -v:\0 -e \\(TestPlayBook.py\\|TestRunner.py\\):' Makefile || die "sed failed"
+}
+
+python_test() {
+ make tests || die "tests failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ # Hint: do not install example config files into /etc
+ # let this choice to user
+
+ newenvd "${FILESDIR}"/${PN}.env 95ansible
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index 0de5ff0ad0a9..1f055096bc9f 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.13 2013/10/11 11:30:57 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.14 2014/03/03 11:42:24 pinkbyte Exp $
EAPI="5"
@@ -12,7 +12,7 @@ EGIT_BRANCH="devel"
inherit distutils-r1 git-2 readme.gentoo
DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
-HOMEPAGE="http://ansible.cc/"
+HOMEPAGE="http://ansible.com/"
SRC_URI=""
KEYWORDS=""
@@ -35,7 +35,7 @@ RDEPEND="
DOC_CONTENTS="You can define parameters through shell variables OR use config files
Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
You have to create ansible hosts file!\n
-More info on http://ansible.cc/docs/gettingstarted.html"
+More info on http://docs.ansible.com/intro_getting_started.html"
python_prepare_all() {
distutils-r1_python_prepare_all