summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-03-27 14:08:23 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2011-03-27 14:08:23 +0000
commitb80c82ee786728fa445ee97f5536ac39ed6a26f2 (patch)
tree3aa1ac0d39899aace248aabd9bfcdf4db34bffa9 /app-admin
parentRevision bump: added security patch from upstream, CVE-2011-1168 (diff)
downloadgentoo-2-b80c82ee786728fa445ee97f5536ac39ed6a26f2.tar.gz
gentoo-2-b80c82ee786728fa445ee97f5536ac39ed6a26f2.tar.bz2
gentoo-2-b80c82ee786728fa445ee97f5536ac39ed6a26f2.zip
Should support library modules on Darwin (dylib).
Cleaner output that now indicates what the application links are. Automatically sets a default when none has been set. Should properly set the library path: LDPATH on a 64 bit system should have been set to /usr/lib64/postgresql-${SLOT}/lib64 instead of /usr/lib64/postgresql-${SLOT}/lib (Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-postgresql/ChangeLog16
-rw-r--r--app-admin/eselect-postgresql/eselect-postgresql-1.0.4.ebuild32
2 files changed, 47 insertions, 1 deletions
diff --git a/app-admin/eselect-postgresql/ChangeLog b/app-admin/eselect-postgresql/ChangeLog
index 55587d9a7804..8212efe2d11a 100644
--- a/app-admin/eselect-postgresql/ChangeLog
+++ b/app-admin/eselect-postgresql/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-admin/eselect-postgresql
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-postgresql/ChangeLog,v 1.12 2011/03/19 21:58:13 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-postgresql/ChangeLog,v 1.13 2011/03/27 14:08:23 titanofold Exp $
+
+*eselect-postgresql-1.0.4 (27 Mar 2011)
+
+ 27 Mar 2011; Aaron W. Swenson <titanofold@gentoo.org>
+ +eselect-postgresql-1.0.4.ebuild:
+ Should support library modules on Darwin (dylib).
+ Cleaner output that now indicates what the application links are.
+ Automatically sets a default when none has been set.
+ Should properly set the library path:
+ LDPATH on a 64 bit system should have been set to
+ /usr/lib64/postgresql-${SLOT}/lib64
+
+ instead of
+ /usr/lib64/postgresql-${SLOT}/lib
*eselect-postgresql-1.0.3 (19 Mar 2011)
diff --git a/app-admin/eselect-postgresql/eselect-postgresql-1.0.4.ebuild b/app-admin/eselect-postgresql/eselect-postgresql-1.0.4.ebuild
new file mode 100644
index 000000000000..ba84c5e1a559
--- /dev/null
+++ b/app-admin/eselect-postgresql/eselect-postgresql-1.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-postgresql/eselect-postgresql-1.0.4.ebuild,v 1.1 2011/03/27 14:08:23 titanofold Exp $
+
+EAPI="4"
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="app-admin/eselect
+ !!dev-db/libpq"
+
+S="${WORKDIR}"
+
+src_install() {
+ keepdir /etc/eselect/postgresql
+
+ insinto /usr/share/eselect/modules
+ doins postgresql.eselect
+
+ dosym /usr/bin/eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+ elog "You need to set your default slot:"
+ elog " eselect postgresql set <slot>"
+}