summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 21:32:09 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 21:32:09 +0000
commitb029c97621dddfc5bafbaad498aa6660284cb6f6 (patch)
tree2029c6f8712ed8dedea3c62e94d43da7568efd9f /app-admin
parentAdd new version for Gnome 2.30 (diff)
downloadgentoo-2-b029c97621dddfc5bafbaad498aa6660284cb6f6.tar.gz
gentoo-2-b029c97621dddfc5bafbaad498aa6660284cb6f6.tar.bz2
gentoo-2-b029c97621dddfc5bafbaad498aa6660284cb6f6.zip
Add new version for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sabayon/ChangeLog7
-rw-r--r--app-admin/sabayon/sabayon-2.30.0.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/app-admin/sabayon/ChangeLog b/app-admin/sabayon/ChangeLog
index 499a7f9e3743..89182f693375 100644
--- a/app-admin/sabayon/ChangeLog
+++ b/app-admin/sabayon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sabayon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sabayon/ChangeLog,v 1.69 2010/06/04 20:21:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sabayon/ChangeLog,v 1.70 2010/06/13 21:32:09 pacho Exp $
+
+*sabayon-2.30.0 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +sabayon-2.30.0.ebuild:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org> sabayon-2.28.1.ebuild:
x86 stable, bug #314899
diff --git a/app-admin/sabayon/sabayon-2.30.0.ebuild b/app-admin/sabayon/sabayon-2.30.0.ebuild
new file mode 100644
index 000000000000..6c1be701b1ff
--- /dev/null
+++ b/app-admin/sabayon/sabayon-2.30.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sabayon/sabayon-2.30.0.ebuild,v 1.1 2010/06/13 21:32:09 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils python multilib
+
+DESCRIPTION="Tool to maintain user profiles in a GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/sabayon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Unfortunately the configure.ac is wildly insufficient, so dependencies have
+# to be got from the RPM .spec file...
+# But the .spec file got removed :/
+COMMON_DEPEND=">=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.6.0
+ >=dev-python/pygtk-2.16
+ >=dev-python/pygobject-2.15
+ x11-libs/pango
+ dev-python/python-ldap
+ x11-base/xorg-server[kdrive]"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyxdg
+ dev-libs/libxml2[python]
+ >=gnome-base/gconf-2.8.1
+ >=dev-python/libbonobo-python-2.6
+ >=dev-python/gconf-python-2.6
+ x11-libs/gksu"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40"
+
+DOCS="AUTHORS ChangeLog ISSUES NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --with-distro=gentoo
+ --with-prototype-user=${PN}-admin
+ --enable-console-helper=no"
+
+ einfo "Adding user '${PN}-admin' as the prototype user"
+ # I think /var/lib/sabayon is the correct directory to use here.
+ enewgroup ${PN}-admin
+ enewuser ${PN}-admin -1 -1 "/var/lib/sabayon" "${PN}-admin"
+ # Should we delete the user/group on unmerge?
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Switch gnomesu to gksu; bug #197865
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop || die "gksu sed failed"
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop.in || die "gksu sed failed"
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/sabayon
+
+ # unfortunately /etc/gconf is CONFIG_PROTECT_MASK'd
+ elog "To apply Sabayon defaults and mandatory settings to all users, put"
+ elog ' include "$(HOME)/.gconf.path.mandatory"'
+ elog "in /etc/gconf/2/local-mandatory.path and put"
+ elog ' include "$(HOME)/.gconf.path.defaults"'
+ elog "in /etc/gconf/2/local-defaults.path."
+ elog "You can safely create these files if they do not already exist."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/sabayon
+}