summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-08-12 16:07:12 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-08-12 16:07:12 +0000
commitaeba0120e14c8df5cb3fc0cf99697a1d12575510 (patch)
treee1c3a18fb321550a7478843227ffa66fb30586ea /app-admin
parentAdded closing bugs to ChangeLog. (Manifest recommit) (diff)
downloadgentoo-2-aeba0120e14c8df5cb3fc0cf99697a1d12575510.tar.gz
gentoo-2-aeba0120e14c8df5cb3fc0cf99697a1d12575510.tar.bz2
gentoo-2-aeba0120e14c8df5cb3fc0cf99697a1d12575510.zip
Closing #60013
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ulogd/ChangeLog5
-rw-r--r--app-admin/ulogd/ulogd-1.02.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/app-admin/ulogd/ChangeLog b/app-admin/ulogd/ChangeLog
index 63d074a2cd69..b6817e6bb231 100644
--- a/app-admin/ulogd/ChangeLog
+++ b/app-admin/ulogd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/ulogd
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ChangeLog,v 1.23 2004/07/19 13:04:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ChangeLog,v 1.24 2004/08/12 16:07:12 aliz Exp $
+
+ 12 Aug 2004; Daniel Ahlberg <aliz@gentoo.org> ulogd-1.02.ebuild:
+ Added postgresql support, closing #60013.
19 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> ulogd-1.01.ebuild,
ulogd-1.02.ebuild:
diff --git a/app-admin/ulogd/ulogd-1.02.ebuild b/app-admin/ulogd/ulogd-1.02.ebuild
index f0ad7a5a3fbe..bf92d80efb62 100644
--- a/app-admin/ulogd/ulogd-1.02.ebuild
+++ b/app-admin/ulogd/ulogd-1.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ulogd-1.02.ebuild,v 1.9 2004/07/19 13:04:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ulogd-1.02.ebuild,v 1.10 2004/08/12 16:07:12 aliz Exp $
DESCRIPTION="iptables daemon for ULOG target for userspace iptables filter logging"
SRC_URI="http://ftp.netfilter.org/pub/ulogd/${P}.tar.bz2"
@@ -9,13 +9,14 @@ HOMEPAGE="http://www.gnumonks.org/gnumonks/projects/project_details?p_id=1"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc -sparc amd64"
-IUSE="mysql"
+IUSE="mysql postgres"
DEPEND="net-firewall/iptables
- mysql? ( dev-db/mysql )"
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
src_compile() {
- econf `use_with mysql` || die "configure failed"
+ econf `use_with mysql` `use_with postgres pgsql` || die "configure failed"
make || die "make failed"
}
@@ -31,8 +32,14 @@ src_install() {
dodoc README AUTHORS Changes
cd doc/
dodoc ulogd.txt ulogd.a4.ps
+
if use mysql; then
dodoc mysql.table mysql.table.ipaddr-as-string
fi
+
+ if use postgres; then
+ dodoc pgsql.table
+ fi
+
dohtml ulogd.html
}