summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-09-18 10:48:38 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-09-18 10:48:38 +0000
commit9bcb500302be3cce7141d762117f97dc28462674 (patch)
tree1e6063023fe98213b79f516412cd44ff76b1991e /app-admin
parentversion bump (diff)
downloadgentoo-2-9bcb500302be3cce7141d762117f97dc28462674.tar.gz
gentoo-2-9bcb500302be3cce7141d762117f97dc28462674.tar.bz2
gentoo-2-9bcb500302be3cce7141d762117f97dc28462674.zip
version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-1.0_rc53.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index ea07f58e7408..f14403e7ae47 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.11 2011/08/23 10:06:40 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.12 2011/09/18 10:48:38 lxnay Exp $
+
+*equo-1.0_rc53 (18 Sep 2011)
+
+ 18 Sep 2011; Fabio Erculiani <lxnay@gentoo.org> +equo-1.0_rc53.ebuild:
+ version bump
*equo-1.0_rc43 (23 Aug 2011)
diff --git a/app-admin/equo/equo-1.0_rc53.ebuild b/app-admin/equo/equo-1.0_rc53.ebuild
new file mode 100644
index 000000000000..95a01527157c
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc53.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc53.ebuild,v 1.1 2011/09/18 10:48:38 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ dobashcompletion "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ bash-completion_pkg_postinst
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}