summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-05 10:00:01 +0000
committerIan Delaney <idella4@gentoo.org>2015-08-05 10:00:01 +0000
commit97f3f4ad342a04a480b55c065745a624059899be (patch)
tree011114ca88bec236d34efd5c5b8578f1a131367a /app-admin
parentia64 stable wrt bug #556314 (diff)
downloadgentoo-2-97f3f4ad342a04a480b55c065745a624059899be.tar.gz
gentoo-2-97f3f4ad342a04a480b55c065745a624059899be.tar.bz2
gentoo-2-97f3f4ad342a04a480b55c065745a624059899be.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/tenshi/ChangeLog9
-rw-r--r--app-admin/tenshi/tenshi-0.15.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-admin/tenshi/ChangeLog b/app-admin/tenshi/ChangeLog
index 5707c5da018a..6a16f1847fa9 100644
--- a/app-admin/tenshi/ChangeLog
+++ b/app-admin/tenshi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/tenshi
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/ChangeLog,v 1.74 2013/12/23 01:11:36 tomwij Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/ChangeLog,v 1.75 2015/08/05 10:00:01 idella4 Exp $
+
+*tenshi-0.15 (05 Aug 2015)
+
+ 05 Aug 2015; Ian Delaney <idella4@gentoo.org> +tenshi-0.15.ebuild:
+ bump
23 Dec 2013; Tom Wijsman <TomWij@gentoo.org>
-files/tenshi-0.10-solo-queue-escalation.patch,
diff --git a/app-admin/tenshi/tenshi-0.15.ebuild b/app-admin/tenshi/tenshi-0.15.ebuild
new file mode 100644
index 000000000000..57a2b3ff8b68
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/tenshi-0.15.ebuild,v 1.1 2015/08/05 10:00:01 idella4 Exp $
+
+EAPI=5
+inherit eutils user
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="http://dev.inversepath.com/trac/tenshi"
+SRC_URI="http://dev.inversepath.com/tenshi/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/IO-BufferedSelect
+ sys-apps/coreutils"
+
+pkg_setup() {
+ enewgroup tenshi
+ enewuser tenshi -1 -1 /var/lib/tenshi tenshi
+}
+
+src_prepare() {
+ # Fix for bug #241254
+ sed -i 's:^docdir =.*:docdir = /usr/share/doc/${PF}:' \
+ Makefile || die "docdir substitution failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ fowners tenshi:root /etc/tenshi/tenshi.conf
+ dodir /var/lib/tenshi
+ fowners tenshi:root /var/lib/tenshi
+ doman tenshi.8
+ newinitd tenshi.gentoo-init tenshi
+ keepdir /var/lib/tenshi
+}
+
+cpkg_postinst() {
+ ewarn "The sample config installed to ${ROOT}etc/tenshi/tenshi.conf"
+ ewarn "monitors /var/log/messages which, by default, can not be read"
+ ewarn "by the tenshi user. Make sure that the tenshi user has read"
+ ewarn "permission on all the files that you want tenshi to monitor."
+}