summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-08-03 03:49:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-08-03 03:49:37 +0000
commit944946e7572100c60f623f4df48986819e99b4eb (patch)
tree74866513b63331adc72edae481f975f65112baf0 /app-admin
parentwhitespace (diff)
downloadgentoo-2-944946e7572100c60f623f4df48986819e99b4eb.tar.gz
gentoo-2-944946e7572100c60f623f4df48986819e99b4eb.tar.bz2
gentoo-2-944946e7572100c60f623f4df48986819e99b4eb.zip
Fix build of the static version.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/testdisk/ChangeLog8
-rw-r--r--app-admin/testdisk/files/digest-testdisk-6.7-r13
-rw-r--r--app-admin/testdisk/testdisk-6.7-r1.ebuild60
3 files changed, 70 insertions, 1 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index bff26315498e..8e84448232e8 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/testdisk
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.24 2007/06/27 08:57:24 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.25 2007/08/03 03:49:37 robbat2 Exp $
+
+*testdisk-6.7-r1 (02 Aug 2007)
+
+ 02 Aug 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +testdisk-6.7-r1.ebuild:
+ Fix build of the static version.
*testdisk-6.7 (27 Jun 2007)
diff --git a/app-admin/testdisk/files/digest-testdisk-6.7-r1 b/app-admin/testdisk/files/digest-testdisk-6.7-r1
new file mode 100644
index 000000000000..8ac9bbde575b
--- /dev/null
+++ b/app-admin/testdisk/files/digest-testdisk-6.7-r1
@@ -0,0 +1,3 @@
+MD5 cf5f633dbbeadfff0c38d39e1fa56b5e testdisk-6.7.tar.bz2 762396
+RMD160 5514ad8ef2dec793cc130916a4e6e62426d6bb24 testdisk-6.7.tar.bz2 762396
+SHA256 dd3acc1f17414e37f8e6ef71736f17cb69b98d5f84863973753edc19bc644bc8 testdisk-6.7.tar.bz2 762396
diff --git a/app-admin/testdisk/testdisk-6.7-r1.ebuild b/app-admin/testdisk/testdisk-6.7-r1.ebuild
new file mode 100644
index 000000000000..8af5573b70bf
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.7-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.7-r1.ebuild,v 1.1 2007/08/03 03:49:37 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multi-platform tool to check and undelete partition, supports reiserfs, ntfs, fat32, ext2/3 and many others. Also includes PhotoRec to recover pictures from digital camera memory."
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs jpeg"
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND=">=sys-libs/ncurses-5.2
+ jpeg? ( media-libs/jpeg )
+ ntfs? ( >=sys-fs/ntfsprogs-1.9.4 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-constdef.patch
+}
+
+src_compile() {
+ local myconf="--without-ewf"
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf="${myconf} --without-reiserfs"
+ use ntfs || myconf="${myconf} --without-ntfs"
+ use jpeg || myconf="${myconf} --without-jpeg"
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf ${myconf} || die
+
+ # perform safety checks for NTFS and REISERFS
+ if useq ntfs && egrep -q 'undef HAVE_LIBNTFS\>' ${S}/config.h ; then
+ die "Failed to find NTFS library."
+ fi
+ if useq reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' ${S}/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if useq jpeg && egrep -q 'undef HAVE_LIBJPEG\>' ${S}/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ [ "$PF" != "$P" ] && mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+}