summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-06 16:30:22 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-06 16:30:22 +0000
commit6e7f2416f4a834c3d76e8d19e7e0eff8f19d9e69 (patch)
tree927caa8d9cabe1cf7a73a8dee6ff8c3be98212a8 /app-admin
parentDrop old. (diff)
downloadgentoo-2-6e7f2416f4a834c3d76e8d19e7e0eff8f19d9e69.tar.gz
gentoo-2-6e7f2416f4a834c3d76e8d19e7e0eff8f19d9e69.tar.bz2
gentoo-2-6e7f2416f4a834c3d76e8d19e7e0eff8f19d9e69.zip
Added /etc/openldap/schema/puppet.schema, bug #239433.
Removed PUPPETMASTER_MANIFEST FROM /etc/init.d/puppetmaster, bug #240266. (Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog11
-rw-r--r--app-admin/puppet/files/puppetmaster.confd9
-rwxr-xr-xapp-admin/puppet/files/puppetmaster.init10
-rw-r--r--app-admin/puppet/puppet-0.24.5-r1.ebuild119
-rw-r--r--app-admin/puppet/puppet-0.24.5-r4.ebuild (renamed from app-admin/puppet/puppet-0.24.5-r2.ebuild)31
5 files changed, 43 insertions, 137 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index fcacd96d27f5..6533138892da 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.26 2008/10/02 17:06:06 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.27 2008/10/06 16:30:22 matsuu Exp $
+
+*puppet-0.24.5-r4 (06 Oct 2008)
+
+ 06 Oct 2008; MATSUU Takuto <matsuu@gentoo.org> +files/puppetmaster.confd,
+ files/puppetmaster.init, -puppet-0.24.5-r1.ebuild,
+ -puppet-0.24.5-r2.ebuild, +puppet-0.24.5-r4.ebuild:
+ Added /etc/openldap/schema/puppet.schema, bug #239433. Removed
+ PUPPETMASTER_MANIFEST FROM /etc/init.d/puppetmaster, bug #240266. Removed
+ old versions.
*puppet-0.24.5-r3 (02 Oct 2008)
diff --git a/app-admin/puppet/files/puppetmaster.confd b/app-admin/puppet/files/puppetmaster.confd
new file mode 100644
index 000000000000..812967e80158
--- /dev/null
+++ b/app-admin/puppet/files/puppetmaster.confd
@@ -0,0 +1,9 @@
+# Location of PID files
+PUPPETMASTER_PID_DIR="/var/run/puppet"
+
+# Where to log general messages to.
+# Specify syslog to send log messages to the system log.
+#PUPPETMASTER_LOG="syslog"
+
+# You may specify other parameters to the puppetmaster here
+#PUPPETMASTER_EXTRA_OPTS="--noca"
diff --git a/app-admin/puppet/files/puppetmaster.init b/app-admin/puppet/files/puppetmaster.init
index 992a47e9dc6e..200ab9ecb3e2 100755
--- a/app-admin/puppet/files/puppetmaster.init
+++ b/app-admin/puppet/files/puppetmaster.init
@@ -15,14 +15,6 @@ checkconfig() {
return 1
fi
- local site_manifest="/etc/puppet/manifests/site.pp"
- [ -n "${PUPPETMASTER_MANIFEST}" ] && site_manifest="${PUPPETMASTER_MANIFEST}"
-
- if [ ! -f "${site_manifest}" ] ; then
- eerror "Please create ${site_manifest} before running puppet"
- return 1
- fi
-
return 0
}
@@ -30,8 +22,6 @@ start() {
checkconfig || return $?
local options=""
- [ -n "${PUPPETMASTER_MANIFEST}" ] && options="${options} --manifest=${PUPPETMASTER_MANIFEST}"
- [ -n "${PUPPETMASTER_LOG}" ] && options="${options} --logdest=${PUPPETMASTER_LOG}"
[ -n "${PUPPETMASTER_EXTRA_OPTS}" ] && options="${options} ${PUPPETMASTER_EXTRA_OPTS}"
ebegin "Starting puppetmaster"
diff --git a/app-admin/puppet/puppet-0.24.5-r1.ebuild b/app-admin/puppet/puppet-0.24.5-r1.ebuild
deleted file mode 100644
index 3991fd57f470..000000000000
--- a/app-admin/puppet/puppet-0.24.5-r1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.24.5-r1.ebuild,v 1.2 2008/09/15 00:35:23 matsuu Exp $
-
-inherit elisp-common eutils ruby
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://reductivelabs.com/projects/puppet/index.html"
-SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="emacs vim-syntax"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}
- >=dev-ruby/facter-1.3.5
- >=app-portage/eix-0.9.4"
-
-USE_RUBY="ruby18"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- built_with_use virtual/ruby ipv6 || \
- die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
-
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.24.2-gentoo.patch"
-}
-
-src_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- DESTDIR="${D}" ruby_einstall "$@" || die
- DESTDIR="${D}" erubydoc
-
- #
- # bug #237071
- #
- #doinitd conf/gentoo/init.d/puppetmaster
- newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
- doconfd conf/gentoo/conf.d/puppetmaster
- #doinitd conf/gentoo/init.d/puppet
- newinitd "${FILESDIR}"/puppet.init puppet
- doconfd conf/gentoo/conf.d/puppet
-
- # Initial configuration files
- keepdir /etc/puppet/manifests
- insinto /etc/puppet
- doins conf/gentoo/puppet/*
-
- # Location of log and data files
- keepdir /var/run/puppet
- keepdir /var/log/puppet
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/{run,log,lib}/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto $(dirname ${f})
- dodoc ${f}
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${ROOT}/etc/puppet/puppetd.conf" -o \
- -f "${ROOT}/etc/puppet/puppetmaster.conf" -o \
- -f "${ROOT}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
- use emacs && elisp-site-regen
-}
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-0.24.5-r2.ebuild b/app-admin/puppet/puppet-0.24.5-r4.ebuild
index ed200019b3f0..51dcf75455fa 100644
--- a/app-admin/puppet/puppet-0.24.5-r2.ebuild
+++ b/app-admin/puppet/puppet-0.24.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.24.5-r2.ebuild,v 1.2 2008/09/27 10:40:26 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.24.5-r4.ebuild,v 1.1 2008/10/06 16:30:22 matsuu Exp $
inherit elisp-common eutils ruby
@@ -11,15 +11,19 @@ SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
IUSE="emacs ldap rrdtool vim-syntax"
-#KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-KEYWORDS="~amd64 ~sparc ~x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
DEPEND="emacs? ( virtual/emacs )
>=dev-ruby/facter-1.1.0"
RDEPEND="${DEPEND}
>=app-portage/eix-0.9.4
ldap? ( dev-ruby/ruby-ldap )
- rrdtool? ( dev-ruby/ruby-rrd )"
+ rrdtool? (
+ || (
+ >=net-analyzer/rrdtool-1.2.23
+ dev-ruby/ruby-rrd
+ )
+ )"
# || (
# www-servers/webrick
# www-servers/mongrel
@@ -36,6 +40,13 @@ pkg_setup() {
built_with_use virtual/ruby ipv6 || \
die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
+ if use rrdtool && \
+ has_version '>=net-analyzer/rrdtool-1.2.23' && \
+ ! built_with_use '>=net-analyzer/rrdtool-1.2.23' ruby
+ then
+ die "net-analyzer/rrdtool must be built with ruby USE flag."
+ fi
+
enewgroup puppet
enewuser puppet -1 -1 /var/lib/puppet puppet
}
@@ -45,6 +56,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-0.24.2-gentoo.patch"
+ epatch "${FILESDIR}/${P}-eix-0.14.0.patch"
}
src_compile() {
@@ -62,7 +74,8 @@ src_install() {
#
#doinitd conf/gentoo/init.d/puppetmaster
newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
- doconfd conf/gentoo/conf.d/puppetmaster
+ #doconfd conf/gentoo/conf.d/puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
#doinitd conf/gentoo/init.d/puppet
newinitd "${FILESDIR}"/puppet.init puppet
doconfd conf/gentoo/conf.d/puppet
@@ -84,6 +97,10 @@ src_install() {
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
if use vim-syntax ; then
insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
@@ -91,9 +108,9 @@ src_install() {
# ext and examples files
for f in $(find ext examples -type f) ; do
- docinto $(dirname ${f})
- dodoc ${f}
+ docinto "$(dirname ${f})"; dodoc "${f}"
done
+ docinto conf; dodoc conf/namespaceauth.conf
}
pkg_postinst() {