summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-02-02 21:04:24 +0000
committerPacho Ramos <pacho@gentoo.org>2014-02-02 21:04:24 +0000
commit4d3bc0ea8ca3c76e15ea3833f476c7362448771f (patch)
tree8753679d18da63405f62563b4f941e9f3d5fa424 /app-admin
parentBump. (diff)
downloadgentoo-2-4d3bc0ea8ca3c76e15ea3833f476c7362448771f.tar.gz
gentoo-2-4d3bc0ea8ca3c76e15ea3833f476c7362448771f.tar.bz2
gentoo-2-4d3bc0ea8ca3c76e15ea3833f476c7362448771f.zip
Rework systemd support (#439918)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-php/ChangeLog9
-rw-r--r--app-admin/eselect-php/eselect-php-0.7.1-r3.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/app-admin/eselect-php/ChangeLog b/app-admin/eselect-php/ChangeLog
index ee303ba3709c..47c451349e0a 100644
--- a/app-admin/eselect-php/ChangeLog
+++ b/app-admin/eselect-php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/eselect-php
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-php/ChangeLog,v 1.57 2013/08/06 12:35:13 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-php/ChangeLog,v 1.58 2014/02/02 21:04:24 pacho Exp $
+
+*eselect-php-0.7.1-r3 (02 Feb 2014)
+
+ 02 Feb 2014; Pacho Ramos <pacho@gentoo.org> +eselect-php-0.7.1-r3.ebuild:
+ Rework systemd support (#439918)
06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> eselect-php-0.7.1.ebuild:
Stable for s390, wrt bug #472558
diff --git a/app-admin/eselect-php/eselect-php-0.7.1-r3.ebuild b/app-admin/eselect-php/eselect-php-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..ab41ebf87b08
--- /dev/null
+++ b/app-admin/eselect-php/eselect-php-0.7.1-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-php/eselect-php-0.7.1-r3.ebuild,v 1.1 2014/02/02 21:04:24 pacho Exp $
+
+EAPI=5
+
+inherit depend.apache systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="http://dev.gentoo.org/~olemarkus/eselect-php/eselect-php-${PV}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+DEPEND=">=app-admin/eselect-1.2.4
+ !<dev-lang/php-5.3.23-r1:5.3
+ !<dev-lang/php-5.4.13-r1:5.4
+ !<dev-lang/php-5.5.0_beta1-r2:5.5
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+want_apache
+
+src_install() {
+ mv eselect-php-${PV} php.eselect
+ insinto /usr/share/eselect/modules/
+ doins php.eselect
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
+ newins "${FILESDIR}/70_mod_php5.conf-apache2" \
+ "70_mod_php5.conf"
+ fi
+
+ if use fpm ; then
+ dodir "/etc/init.d"
+ insinto "/etc/init.d"
+ newinitd "${FILESDIR}/php-fpm-r1.init" "php-fpm"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}