summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-12-07 22:11:47 +0000
committerUlrich Müller <ulm@gentoo.org>2009-12-07 22:11:47 +0000
commit3a3c14d1e278da710dc1fccfb29d84c3a4298e94 (patch)
tree9af2e3f5c287a711ce159e56b57cb83efe5bd1db /app-admin
parentAdd dep on net-dns/libidn with USE=nls. (diff)
downloadgentoo-2-3a3c14d1e278da710dc1fccfb29d84c3a4298e94.tar.gz
gentoo-2-3a3c14d1e278da710dc1fccfb29d84c3a4298e94.tar.bz2
gentoo-2-3a3c14d1e278da710dc1fccfb29d84c3a4298e94.zip
Add Prefix support and KEYWORDS. Change EAPI to 2.
(Portage version: 2.2_rc55/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/emacs-updater/ChangeLog7
-rw-r--r--app-admin/emacs-updater/emacs-updater-1.6-r1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/app-admin/emacs-updater/ChangeLog b/app-admin/emacs-updater/ChangeLog
index f779ed7d3d20..0e000503a17b 100644
--- a/app-admin/emacs-updater/ChangeLog
+++ b/app-admin/emacs-updater/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/emacs-updater
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/emacs-updater/ChangeLog,v 1.33 2009/11/26 11:33:41 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/emacs-updater/ChangeLog,v 1.34 2009/12/07 22:11:47 ulm Exp $
+
+*emacs-updater-1.6-r1 (07 Dec 2009)
+
+ 07 Dec 2009; Ulrich Mueller <ulm@gentoo.org> +emacs-updater-1.6-r1.ebuild:
+ Add Prefix support and KEYWORDS. Change EAPI to 2.
26 Nov 2009; Christian Faulhammer <fauli@gentoo.org>
-emacs-updater-1.5.ebuild:
diff --git a/app-admin/emacs-updater/emacs-updater-1.6-r1.ebuild b/app-admin/emacs-updater/emacs-updater-1.6-r1.ebuild
new file mode 100644
index 000000000000..82c4df2446c3
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-1.6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/emacs-updater/emacs-updater-1.6-r1.ebuild,v 1.1 2009/12/07 22:11:47 ulm Exp $
+
+EAPI=2
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<=app-admin/eselect-emacs-1.5
+ >=app-portage/portage-utils-0.1.28
+ virtual/emacs"
+
+src_prepare() {
+ if [ -n "${EPREFIX}" ]; then
+ sed -i -e "1s:/:${EPREFIX%/}/:" \
+ -e "s:^\(EMACS\|SITELISP\)=:&${EPREFIX%/}:" \
+ emacs-updater || die
+ fi
+}
+
+src_install() {
+ dosbin emacs-updater || die "dosbin failed"
+ doman emacs-updater.8 || die "doman failed"
+}