summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2011-02-18 17:15:03 +0000
committerBenedikt Boehm <hollow@gentoo.org>2011-02-18 17:15:03 +0000
commit323d9ea35577c5fef82601ddb7b57d34fbaefd95 (patch)
tree736cee470ebfa98f86d8613b2d20dcbd5e0b7bff /app-admin
parentStable for HPPA (bug #354267). (diff)
downloadgentoo-2-323d9ea35577c5fef82601ddb7b57d34fbaefd95.tar.gz
gentoo-2-323d9ea35577c5fef82601ddb7b57d34fbaefd95.tar.bz2
gentoo-2-323d9ea35577c5fef82601ddb7b57d34fbaefd95.zip
version bump wrt #342055
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/apache-tools/ChangeLog10
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.17.ebuild91
2 files changed, 99 insertions, 2 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 94d22cf9dfd9..04810009b586 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.84 2010/09/19 17:40:01 gmsoft Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.85 2011/02/18 17:15:03 hollow Exp $
+
+*apache-tools-2.2.17 (18 Feb 2011)
+
+ 18 Feb 2011; Benedikt Böhm <hollow@gentoo.org>
+ +apache-tools-2.2.17.ebuild:
+ version bump wrt #342055
19 Sep 2010; Guy Martin <gmsoft@gentoo.org> apache-tools-2.2.16.ebuild:
hppa stable wrt #330195
diff --git a/app-admin/apache-tools/apache-tools-2.2.17.ebuild b/app-admin/apache-tools/apache-tools-2.2.17.ebuild
new file mode 100644
index 000000000000..4ec83fad718e
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.17.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.17.ebuild,v 1.1 2011/02/18 17:15:03 hollow Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply these patches:
+ # (1) apache-tools-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ local myconf=""
+ cd "${S}"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ # Thanks to Harald van Dijk
+ append-ldflags $(no-as-needed)
+
+ if use ssl ; then
+ myconf="${myconf} --with-ssl=/usr --enable-ssl"
+ fi
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf} || die "econf failed!"
+
+ cd support
+ emake || die "emake support/ failed!"
+}
+
+src_install () {
+ cd "${S}"/support
+
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+
+ for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+
+ # Provide a symlink for ab-ssl
+ if use ssl ; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}