summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-05 10:22:37 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-05 10:22:37 +0000
commit31ce949f9311d5b142ec34aa4658aa4d3c06f8e2 (patch)
tree81c67182088c94f0139da6e2eb1d805117e53205 /app-admin
parentfix bug 519032, remove hard doxygen dep, thanks Johannes Janssen (diff)
downloadgentoo-2-31ce949f9311d5b142ec34aa4658aa4d3c06f8e2.tar.gz
gentoo-2-31ce949f9311d5b142ec34aa4658aa4d3c06f8e2.tar.bz2
gentoo-2-31ce949f9311d5b142ec34aa4658aa4d3c06f8e2.zip
Fix parsing metalog entries with days starting with 0 by Amyas (bug #518988).
(Portage version: 2.2.11/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sshguard/ChangeLog10
-rw-r--r--app-admin/sshguard/files/sshguard-1.5-day-starts-with-0.patch11
-rw-r--r--app-admin/sshguard/sshguard-1.5-r3.ebuild58
3 files changed, 77 insertions, 2 deletions
diff --git a/app-admin/sshguard/ChangeLog b/app-admin/sshguard/ChangeLog
index b84fbbc0b02f..08b7c37f5351 100644
--- a/app-admin/sshguard/ChangeLog
+++ b/app-admin/sshguard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/sshguard
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.20 2013/01/31 16:36:47 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.21 2014/08/05 10:22:37 jer Exp $
+
+*sshguard-1.5-r3 (05 Aug 2014)
+
+ 05 Aug 2014; Jeroen Roovers <jer@gentoo.org> +sshguard-1.5-r3.ebuild,
+ +files/sshguard-1.5-day-starts-with-0.patch:
+ Fix parsing metalog entries with days starting with 0 by Amyas (bug #518988).
31 Jan 2013; Jeroen Roovers <jer@gentoo.org> files/sshguard.confd:
Fix case in man page reference, by Marckus J. (bug #454788).
diff --git a/app-admin/sshguard/files/sshguard-1.5-day-starts-with-0.patch b/app-admin/sshguard/files/sshguard-1.5-day-starts-with-0.patch
new file mode 100644
index 000000000000..a8f9ad090019
--- /dev/null
+++ b/app-admin/sshguard/files/sshguard-1.5-day-starts-with-0.patch
@@ -0,0 +1,11 @@
+--- a/src/parser/attack_scanner.l
++++ b/src/parser/attack_scanner.l
+@@ -72,7 +72,7 @@
+
+
+ MONTH (Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)
+-DAYNO [1-9][0-9]?
++DAYNO [0-9][0-9]?
+ HOUR (0|1)[0-9]|2[0-4]
+ MINPS [0-5][0-9]
+ WORD [a-zA-Z0-9][-_a-zA-Z0-9]+
diff --git a/app-admin/sshguard/sshguard-1.5-r3.ebuild b/app-admin/sshguard/sshguard-1.5-r3.ebuild
new file mode 100644
index 000000000000..3d30d3c69664
--- /dev/null
+++ b/app-admin/sshguard/sshguard-1.5-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/sshguard-1.5-r3.ebuild,v 1.1 2014/08/05 10:22:37 jer Exp $
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="http://sshguard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="ipfilter kernel_FreeBSD kernel_linux"
+
+CDEPEND="kernel_linux? ( net-firewall/iptables )
+ kernel_FreeBSD? ( !ipfilter? ( sys-freebsd/freebsd-pf ) )"
+DEPEND="${CDEPEND}
+ sys-devel/flex"
+RDEPEND="${CDEPEND}
+ sys-apps/openrc
+ virtual/logger"
+
+DOCS=( README Changes scripts/sshguard_backendgen.sh )
+
+src_prepare() {
+ sed -i -e '/OPTIMIZER_CFLAGS=/d' configure || die
+ epatch "${FILESDIR}"/${P}-day-starts-with-0.patch
+}
+
+src_configure() {
+ # Needed for usleep(3), see "nasty" in src/sshguard_logsuck.c
+ append-cppflags -D_BSD_SOURCE
+
+ local myconf
+ if use kernel_linux; then
+ einfo "Selected firewall backend: iptables"
+ myconf="--with-firewall=iptables"
+ elif use kernel_FreeBSD; then
+ if use ipfilter; then
+ einfo "Selected firewall backend: ipfw"
+ myconf="--with-firewall=ipfw"
+ else
+ einfo "Selected firewall backend: pf"
+ myconf="--with-firewall=pf"
+ fi
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ default
+ dodoc examples/*
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}