summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-03-10 02:01:55 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-03-10 02:01:55 +0000
commit31ba09ef12b70fb69e59f15845e6d99b1b5cd4cc (patch)
treed83577a92aba0b44381670f757d50dbb8bc86328 /app-admin
parentVersion bump for scapy. (diff)
downloadgentoo-2-31ba09ef12b70fb69e59f15845e6d99b1b5cd4cc.tar.gz
gentoo-2-31ba09ef12b70fb69e59f15845e6d99b1b5cd4cc.tar.bz2
gentoo-2-31ba09ef12b70fb69e59f15845e6d99b1b5cd4cc.zip
Bump to logrotate-3.7.8
- Update to EAPI 2 (Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logrotate/ChangeLog9
-rw-r--r--app-admin/logrotate/logrotate-3.7.8.ebuild69
2 files changed, 77 insertions, 1 deletions
diff --git a/app-admin/logrotate/ChangeLog b/app-admin/logrotate/ChangeLog
index 460a7e49a595..84127d9b69a9 100644
--- a/app-admin/logrotate/ChangeLog
+++ b/app-admin/logrotate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/logrotate
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.76 2009/01/25 19:42:45 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.77 2009/03/10 02:01:55 dang Exp $
+
+*logrotate-3.7.8 (10 Mar 2009)
+
+ 10 Mar 2009; Daniel Gryniewicz <dang@gentoo.org> +logrotate-3.7.8.ebuild:
+ Bump to logrotate-3.7.8
+
+ - Update to EAPI 2
25 Jan 2009; Daniel Gryniewicz <dang@gentoo.org>
files/logrotate-3.7.7-fbsd.patch:
diff --git a/app-admin/logrotate/logrotate-3.7.8.ebuild b/app-admin/logrotate/logrotate-3.7.8.ebuild
new file mode 100644
index 000000000000..f12f5806800b
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.7.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.8.ebuild,v 1.1 2009/03/10 02:01:55 dang Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://fedorahosted.org/logrotate/"
+SRC_URI="https://fedorahosted.org/releases/l/o/logrotate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+RDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? ( sys-libs/libselinux )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ selinux? ( sec-policy/selinux-logrotate )"
+
+src_prepare() {
+ strip-flags
+
+ epatch ${FILESDIR}/${PN}-3.7.7-datehack.patch
+ epatch ${FILESDIR}/${PN}-3.7.7-ignore-hidden.patch
+ epatch ${FILESDIR}/${PN}-3.7.7-weekly.patch
+ epatch ${FILESDIR}/${PN}-3.7.7-fbsd.patch
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ local myconf
+ myconf="CC=$(tc-getCC)"
+ useq selinux && myconf="${myconf} WITH_SELINUX=yes"
+ use elibc_FreeBSD && append-flags -DNO_ALLOCA_H
+ emake ${myconf} RPM_OPT_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ insinto /usr
+ dosbin logrotate
+ doman logrotate.8
+ dodoc examples/logrotate*
+
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/logrotate.cron
+
+ insinto /etc
+ doins ${FILESDIR}/logrotate.conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+}