summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-09-09 09:20:05 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-09-09 09:20:05 +0000
commit2831caaf80bab46e126734dfc7f66753d1574d02 (patch)
tree98b6a53ea60bd7df9eb141d6d73f3c05c8f70fd6 /app-admin
parentVersion bump (diff)
downloadgentoo-2-2831caaf80bab46e126734dfc7f66753d1574d02.tar.gz
gentoo-2-2831caaf80bab46e126734dfc7f66753d1574d02.tar.bz2
gentoo-2-2831caaf80bab46e126734dfc7f66753d1574d02.zip
Fixed init.d issue, bug 237071.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog8
-rwxr-xr-xapp-admin/puppet/files/puppet.init38
-rwxr-xr-xapp-admin/puppet/files/puppetmaster.init3
-rw-r--r--app-admin/puppet/puppet-0.24.5-r1.ebuild119
4 files changed, 166 insertions, 2 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 9268a63f7091..760855ab73a3 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.20 2008/08/13 16:51:00 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.21 2008/09/09 09:20:04 matsuu Exp $
+
+*puppet-0.24.5-r1 (09 Sep 2008)
+
+ 09 Sep 2008; MATSUU Takuto <matsuu@gentoo.org> +files/puppet.init,
+ files/puppetmaster.init, +puppet-0.24.5-r1.ebuild:
+ Fixed init.d issue, bug 237071.
*puppet-0.24.5 (13 Aug 2008)
diff --git a/app-admin/puppet/files/puppet.init b/app-admin/puppet/files/puppet.init
new file mode 100755
index 000000000000..019b51680ac7
--- /dev/null
+++ b/app-admin/puppet/files/puppet.init
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/files/puppet.init,v 1.1 2008/09/09 09:20:05 matsuu Exp $
+
+depend() {
+ need net
+ use dns logger
+}
+
+checkconfig() {
+ if [[ ! -d "${PUPPET_PID_DIR}" ]] ; then
+ eerror "Please make sure PUPPET_PID_DIR is defined and points to a existing directory"
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ local options=""
+ [[ -n "${PUPPET_EXTRA_OPTS}" ]] && options="${options} ${PUPPET_EXTRA_OPTS}"
+
+ ebegin "Starting puppet"
+ start-stop-daemon --start --quiet --exec /usr/bin/puppetd -- ${options}
+ eend $? "Failed to start puppet"
+}
+
+stop() {
+ ebegin "Stopping puppet"
+ start-stop-daemon --stop --quiet --pidfile ${PUPPET_PID_DIR}/puppetd.pid
+ local ret=$?
+ eend ${ret} "Failed to stop puppet"
+ rm -f ${PUPPET_PID_DIR}/puppetd.pid
+ return ${ret}
+}
diff --git a/app-admin/puppet/files/puppetmaster.init b/app-admin/puppet/files/puppetmaster.init
index 60231530a08e..e5ff580f6758 100755
--- a/app-admin/puppet/files/puppetmaster.init
+++ b/app-admin/puppet/files/puppetmaster.init
@@ -34,7 +34,7 @@ start() {
[[ -n "${PUPPETMASTER_EXTRA_OPTS}" ]] && options="${options} ${PUPPETMASTER_EXTRA_OPTS}"
ebegin "Starting puppetmaster"
- start-stop-daemon --start --quiet --exec /usr/bin/ruby /usr/bin/puppetmasterd \
+ start-stop-daemon --start --quiet --exec /usr/bin/puppetmasterd \
-- ${options}
eend $? "Failed to start puppetmaster"
}
@@ -48,3 +48,4 @@ stop() {
rm -f ${PUPPETMASTER_PID_DIR}/puppetmasterd.pid
return ${ret}
}
+
diff --git a/app-admin/puppet/puppet-0.24.5-r1.ebuild b/app-admin/puppet/puppet-0.24.5-r1.ebuild
new file mode 100644
index 000000000000..5356d867a653
--- /dev/null
+++ b/app-admin/puppet/puppet-0.24.5-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.24.5-r1.ebuild,v 1.1 2008/09/09 09:20:04 matsuu Exp $
+
+inherit elisp-common eutils ruby
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="http://reductivelabs.com/projects/puppet/index.html"
+SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="emacs vim-syntax"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ >=dev-ruby/facter-1.3.5
+ >=app-portage/eix-0.9.4"
+
+USE_RUBY="ruby18"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+ built_with_use virtual/ruby ipv6 || \
+ die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
+
+ enewgroup puppet || die "Problem creating group puppet"
+ enewuser puppet -1 -1 /var/lib/puppet puppet || die "Problem creating user puppet"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.24.2-gentoo.patch"
+}
+
+src_compile() {
+ if use emacs ; then
+ elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ DESTDIR="${D}" ruby_einstall "$@" || die
+ DESTDIR="${D}" erubydoc
+
+ #
+ # bug #237071
+ #
+ #doinitd conf/gentoo/init.d/puppetmaster
+ newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
+ doconfd conf/gentoo/conf.d/puppetmaster
+ #doinitd conf/gentoo/init.d/puppet
+ newinitd "${FILESDIR}"/puppet.init puppet
+ doconfd conf/gentoo/conf.d/puppet
+
+ # Initial configuration files
+ keepdir /etc/puppet/manifests
+ insinto /etc/puppet
+ doins conf/gentoo/puppet/*
+
+ # Location of log and data files
+ keepdir /var/run/puppet
+ keepdir /var/log/puppet
+ keepdir /var/lib/puppet/ssl
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/{run,log,lib}/puppet
+
+ if use emacs ; then
+ elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
+ insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto $(dirname ${f})
+ dodoc ${f}
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Puppet uses eix to get information about currently installed packages,"
+ elog "so please keep the eix metadata cache updated so puppet is able to properly"
+ elog "handle package installations."
+ elog
+ elog "Currently puppet only supports adding and removing services to the default"
+ elog "runlevel, if you want to add/remove a service from another runlevel you may"
+ elog "do so using symlinking."
+ elog
+
+ if [ \
+ -f "${ROOT}/etc/puppet/puppetd.conf" -o \
+ -f "${ROOT}/etc/puppet/puppetmaster.conf" -o \
+ -f "${ROOT}/etc/puppet/puppetca.conf" \
+ ] ; then
+ elog
+ elog "Please remove deprecated config files."
+ elog " /etc/puppet/puppetca.conf"
+ elog " /etc/puppet/puppetd.conf"
+ elog " /etc/puppet/puppetmasterd.conf"
+ elog
+ fi
+ use emacs && elisp-site-regen
+}
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}