summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-15 06:05:28 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-15 06:05:28 +0000
commit104e13bf4e495e8b1edb630cabdd4b14c2132a17 (patch)
tree7785a57cf79701097c080040e89619da57ef7e35 /app-admin
parentQA: eautoreconf should be before gnome2_src_prepare. (diff)
downloadgentoo-2-104e13bf4e495e8b1edb630cabdd4b14c2132a17.tar.gz
gentoo-2-104e13bf4e495e8b1edb630cabdd4b14c2132a17.tar.bz2
gentoo-2-104e13bf4e495e8b1edb630cabdd4b14c2132a17.zip
Simplify ebuild a bit, and fix translation installation wrt LINGUAS.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sudo/ChangeLog8
-rw-r--r--app-admin/sudo/files/sudo-1.8.3_p1-linguas.patch25
-rw-r--r--app-admin/sudo/sudo-1.8.3_p1-r1.ebuild173
3 files changed, 205 insertions, 1 deletions
diff --git a/app-admin/sudo/ChangeLog b/app-admin/sudo/ChangeLog
index 876b3efcd19e..815c7f4bddaa 100644
--- a/app-admin/sudo/ChangeLog
+++ b/app-admin/sudo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/sudo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/ChangeLog,v 1.284 2011/10/28 14:36:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/ChangeLog,v 1.285 2011/11/15 06:05:28 vapier Exp $
+
+*sudo-1.8.3_p1-r1 (15 Nov 2011)
+
+ 15 Nov 2011; Mike Frysinger <vapier@gentoo.org> +sudo-1.8.3_p1-r1.ebuild,
+ +files/sudo-1.8.3_p1-linguas.patch:
+ Simplify ebuild a bit, and fix translation installation wrt LINGUAS.
*sudo-1.8.3_p1 (28 Oct 2011)
diff --git a/app-admin/sudo/files/sudo-1.8.3_p1-linguas.patch b/app-admin/sudo/files/sudo-1.8.3_p1-linguas.patch
new file mode 100644
index 000000000000..68c34aa48fc2
--- /dev/null
+++ b/app-admin/sudo/files/sudo-1.8.3_p1-linguas.patch
@@ -0,0 +1,25 @@
+respect user LINGUAS when installing translations
+
+http://www.sudo.ws/pipermail/sudo-workers/2011-November/000701.html
+
+diff -r ecd3533cb711 -r f99b940123fa Makefile.in
+--- a/Makefile.in Fri Oct 07 13:52:45 2011 -0400
++++ b/Makefile.in Tue Nov 15 00:53:52 2011 -0500
+@@ -226,6 +226,7 @@
+
+ install-nls:
+ @if test "$(NLS)" = "enabled"; then \
++ install_mos="$(LINGUAS)"; \
+ cd $(top_srcdir); \
+ for pot in $(POTFILES); do \
+ podir=`dirname $$pot`; \
+@@ -233,6 +234,9 @@
+ echo $(ECHO_N) "Installing $$domain message catalogs:$(ECHO_C)"; \
+ for mo in $$podir/*.mo; do \
+ lang=`basename $$mo .mo`; \
++ if [ -n "$$install_mos" ]; then \
++ case " $$install_mos " in *" $$lang "*) :;; *) continue;; esac; \
++ fi; \
+ echo $(ECHO_N) " $$lang$(ECHO_C)"; \
+ $(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES; \
+ $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0644 $$mo $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$$domain.mo; \
diff --git a/app-admin/sudo/sudo-1.8.3_p1-r1.ebuild b/app-admin/sudo/sudo-1.8.3_p1-r1.ebuild
new file mode 100644
index 000000000000..1632b6692625
--- /dev/null
+++ b/app-admin/sudo/sudo-1.8.3_p1-r1.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.8.3_p1-r1.ebuild,v 1.1 2011/11/15 06:05:28 vapier Exp $
+
+EAPI="4"
+
+inherit eutils pam libtool
+
+MY_P=${P/_/}
+MY_P=${MY_P/beta/b}
+
+uri_prefix=
+case ${P} in
+*_beta*|*_rc*) uri_prefix=beta/ ;;
+esac
+
+DESCRIPTION="Allows users or groups to run commands as other users"
+HOMEPAGE="http://www.sudo.ws/"
+SRC_URI="http://www.sudo.ws/sudo/dist/${uri_prefix}${MY_P}.tar.gz
+ ftp://ftp.sudo.ws/pub/sudo/${uri_prefix}${MY_P}.tar.gz"
+
+# Basic license is ISC-style as-is, some files are released under
+# 3-clause BSD license
+LICENSE="as-is BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="pam offensive ldap selinux skey"
+
+DEPEND="pam? ( virtual/pam )
+ skey? ( >=sys-auth/skey-1.1.5-r1 )
+ ldap? (
+ >=net-nds/openldap-2.1.30-r1
+ dev-libs/cyrus-sasl
+ )
+ >=app-misc/editor-wrapper-3
+ sys-libs/zlib
+ virtual/editor
+ virtual/mta"
+RDEPEND="selinux? ( sec-policy/selinux-sudo )
+ ldap? ( dev-lang/perl )
+ pam? ( sys-auth/pambase )
+ ${DEPEND}"
+DEPEND="${DEPEND}
+ sys-devel/bison"
+
+S=${WORKDIR}/${MY_P}
+
+REQUIRED_USE="pam? ( !skey ) skey? ( !pam )"
+
+MAKEOPTS+=" SAMPLES="
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linguas.patch
+ elibtoolize
+}
+
+set_rootpath() {
+ # FIXME: secure_path is a compile time setting. using ROOTPATH
+ # is not perfect, env-update may invalidate this, but until it
+ # is available as a sudoers setting this will have to do.
+ einfo "Setting secure_path ..."
+
+ # first extract the default ROOTPATH from build env
+ ROOTPATH=$(unset ROOTPATH; . /etc/profile.env; echo "${ROOTPATH}")
+ if [[ -z ${ROOTPATH} ]] ; then
+ ewarn " Failed to find ROOTPATH, please report this"
+ fi
+
+ # then remove duplicate path entries
+ cleanpath() {
+ local newpath thisp IFS=:
+ for thisp in $1 ; do
+ if [[ :${newpath}: != *:${thisp}:* ]] ; then
+ newpath+=:$thisp
+ else
+ einfo " Duplicate entry ${thisp} removed..."
+ fi
+ done
+ ROOTPATH=${newpath#:}
+ }
+ cleanpath /bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin${ROOTPATH:+:${ROOTPATH}}
+
+ # finally, strip gcc paths #136027
+ rmpath() {
+ local e newpath thisp IFS=:
+ for thisp in ${ROOTPATH} ; do
+ for e ; do [[ $thisp == $e ]] && continue 2 ; done
+ newpath+=:$thisp
+ done
+ ROOTPATH=${newpath#:}
+ }
+ rmpath '*/gcc-bin/*' '*/gnat-gcc-bin/*' '*/gnat-gcc/*'
+
+ einfo "... done"
+}
+
+src_configure() {
+ local ROOTPATH
+ set_rootpath
+
+ # audit: somebody got to explain me how I can test this before I
+ # enable it.. - Diego
+ econf \
+ --enable-zlib=system \
+ --with-secure-path="${ROOTPATH}" \
+ --with-editor=/usr/libexec/editor \
+ --with-env-editor \
+ $(use_with offensive insults) \
+ $(use_with offensive all-insults) \
+ $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo) \
+ $(use_with ldap) \
+ $(use_with pam) \
+ $(use_with skey) \
+ --without-opie \
+ --without-linux-audit \
+ --with-timedir=/var/db/sudo \
+ --with-plugindir='${libdir}'/sudo \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use ldap ; then
+ dodoc README.LDAP doc/schema.OpenLDAP
+ dosbin plugins/sudoers/sudoers2ldif
+
+ cat <<-EOF > "${T}"/ldap.conf.sudo
+ # See ldap.conf(5) and README.LDAP for details
+ # This file should only be readable by root
+
+ # supported directives: host, port, ssl, ldap_version
+ # uri, binddn, bindpw, sudoers_base, sudoers_debug
+ # tls_{checkpeer,cacertfile,cacertdir,randfile,ciphers,cert,key
+ EOF
+
+ insinto /etc
+ doins "${T}"/ldap.conf.sudo
+ fperms 0440 /etc/ldap.conf.sudo
+ fi
+
+ pamd_mimic system-auth sudo auth account session
+
+ keepdir /var/db/sudo
+ fperms 0700 /var/db/sudo
+}
+
+pkg_postinst() {
+ if use ldap ; then
+ ewarn
+ ewarn "sudo uses the /etc/ldap.conf.sudo file for ldap configuration."
+ ewarn
+ if grep -qs '^[[:space:]]*sudoers:' "${ROOT}"/etc/nsswitch.conf ; then
+ ewarn "In 1.7 series, LDAP is no more consulted, unless explicitly"
+ ewarn "configured in /etc/nsswitch.conf."
+ ewarn
+ ewarn "To make use of LDAP, add this line to your /etc/nsswitch.conf:"
+ ewarn " sudoers: ldap files"
+ ewarn
+ fi
+ fi
+
+ elog "To use the -A (askpass) option, you need to install a compatible"
+ elog "password program from the following list. Starred packages will"
+ elog "automatically register for the use with sudo (but will not force"
+ elog "the -A option):"
+ elog ""
+ elog " [*] net-misc/ssh-askpass-fullscreen"
+ elog " net-misc/x11-ssh-askpass"
+ elog ""
+ elog "You can override the choice by setting the SUDO_ASKPASS environmnent"
+ elog "variable to the program you want to use."
+}