summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-18 18:15:01 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-18 18:15:01 +0000
commit0efad233d0aff4b51a0369c30cda287ef9d6053d (patch)
treec9c3466b19d8c2221f04871a5392abcb9d5fbc8c /app-admin
parentVersion bump. This corresponds to Emacs 23.3. (diff)
downloadgentoo-2-0efad233d0aff4b51a0369c30cda287ef9d6053d.tar.gz
gentoo-2-0efad233d0aff4b51a0369c30cda287ef9d6053d.tar.bz2
gentoo-2-0efad233d0aff4b51a0369c30cda287ef9d6053d.zip
Version bump to fix #316921.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-opengl/ChangeLog7
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.2.4.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-admin/eselect-opengl/ChangeLog b/app-admin/eselect-opengl/ChangeLog
index 70e1e59a4d14..43bd12565328 100644
--- a/app-admin/eselect-opengl/ChangeLog
+++ b/app-admin/eselect-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/eselect-opengl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.83 2011/07/13 14:14:05 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.84 2011/08/18 18:15:01 vapier Exp $
+
+*eselect-opengl-1.2.4 (18 Aug 2011)
+
+ 18 Aug 2011; Mike Frysinger <vapier@gentoo.org> +eselect-opengl-1.2.4.ebuild:
+ Version bump to fix #316921.
*eselect-opengl-1.2.3 (13 Jul 2011)
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.2.4.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.2.4.ebuild
new file mode 100644
index 000000000000..3fe0fac644d8
--- /dev/null
+++ b/app-admin/eselect-opengl/eselect-opengl-1.2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.2.4.ebuild,v 1.1 2011/08/18 18:15:01 vapier Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Utility to change the OpenGL interface being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+# Source:
+# http://www.opengl.org/registry/api/glext.h
+# http://www.opengl.org/registry/api/glxext.h
+GLEXT="67"
+GLXEXT="32"
+
+MIRROR="http://dev.gentooexperimental.org/~scarabeus/"
+SRC_URI="${MIRROR}/glext.h.${GLEXT}.xz
+ ${MIRROR}/glxext.h.${GLXEXT}.xz
+ mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-admin/eselect-1.2.4"
+
+pkg_postinst() {
+ local impl="$(eselect opengl show)"
+ if [[ -n "${impl}" && "${impl}" != '(none)' ]] ; then
+ eselect opengl set "${impl}"
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/eselect/modules"
+ doins opengl.eselect
+ doman opengl.eselect.5
+
+ # Install global glext.h and glxext.h
+ insinto "/usr/$(get_libdir)/opengl/global/include"
+ cd "${WORKDIR}"
+ newins glext.h.${GLEXT} glext.h
+ newins glxext.h.${GLXEXT} glxext.h
+}