summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-11-16 20:59:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-11-16 20:59:46 +0000
commit0bb951a2c805f678cc0697b97c505c02a46011b2 (patch)
tree091c6e9575a24ace6fe110c04fc7f5fd1c8c4c4b /app-admin
parentForgot to inherit eutils. Brown paper bag commit. (diff)
downloadgentoo-2-0bb951a2c805f678cc0697b97c505c02a46011b2.tar.gz
gentoo-2-0bb951a2c805f678cc0697b97c505c02a46011b2.tar.bz2
gentoo-2-0bb951a2c805f678cc0697b97c505c02a46011b2.zip
Version bump.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/testdisk/ChangeLog7
-rw-r--r--app-admin/testdisk/testdisk-6.13.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index 98b77b244601..40082c62803c 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/testdisk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.44 2011/10/16 13:37:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.45 2011/11/16 20:59:45 robbat2 Exp $
+
+*testdisk-6.13 (16 Nov 2011)
+
+ 16 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> +testdisk-6.13.ebuild:
+ Version bump.
16 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> -testdisk-6.8-r1.ebuild,
-files/testdisk-6.8-jpeg.patch, -testdisk-6.10.ebuild,
diff --git a/app-admin/testdisk/testdisk-6.13.ebuild b/app-admin/testdisk/testdisk-6.13.ebuild
new file mode 100644
index 000000000000..f25644ff203a
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.13.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.13.ebuild,v 1.1 2011/11/16 20:59:46 robbat2 Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs jpeg"
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND=">=sys-libs/ncurses-5.2
+ jpeg? ( virtual/jpeg )
+ ntfs? ( || ( >=sys-fs/ntfsprogs-2.0.0 sys-fs/ntfs3g ) )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35
+ sys-libs/zlib"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_configure() {
+ local myconf
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf+=" --without-reiserfs"
+ use ntfs || myconf+=" --without-ntfs"
+ use jpeg || myconf+=" --without-jpeg"
+
+ econf \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --without-ewf \
+ --enable-sudo \
+ ${myconf}
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}