summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-07-14 19:46:43 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-07-14 19:46:43 +0000
commit644e53ca038356edb4813d43c668ff709178c69b (patch)
tree7a404d4c4621956c9451ab724b71896668abc54c /app-admin/xsu/xsu-0.2.3.ebuild
parentRepoman fix: Missing DESCRIPTION tag (diff)
downloadgentoo-2-644e53ca038356edb4813d43c668ff709178c69b.tar.gz
gentoo-2-644e53ca038356edb4813d43c668ff709178c69b.tar.bz2
gentoo-2-644e53ca038356edb4813d43c668ff709178c69b.zip
initial version contributed by erikg@wired-networks.net (Erik Grinaker)
Diffstat (limited to 'app-admin/xsu/xsu-0.2.3.ebuild')
-rw-r--r--app-admin/xsu/xsu-0.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/xsu/xsu-0.2.3.ebuild b/app-admin/xsu/xsu-0.2.3.ebuild
new file mode 100644
index 000000000000..f02b788f046c
--- /dev/null
+++ b/app-admin/xsu/xsu-0.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/xsu/xsu-0.2.3.ebuild,v 1.1 2002/07/14 19:46:43 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Interface for 'su - username -c command' in GNOME."
+SRC_URI="http://xsu.freax.eu.org/files/${P}.tar.gz"
+HOMEPAGE="http://xsu.freax.eu.org"
+SLOT="0"
+KEYWORDS="*"
+DEPEND="=gnome-base/gnome-libs-1.4*
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*"
+
+src_compile() {
+
+ # xsu uses its own custom configure script with unflexible Makefiles
+ ./configure --prefix=/usr -man-base=/usr/share/man --doc-path=/usr/share/doc || die
+
+ make CC="gcc ${CFLAGS}" || die
+
+}
+
+src_install() {
+ dobin bin/xsu
+ doman doc/man/xsu.8
+ dodoc AUTHORS CHANGELOG COPYING INSTALL README
+ dohtml doc/html/xsu_doc.html doc/html/xsu_example.jpg \
+ doc/html/xsu_example2.png doc/html/xsu_example3.png \
+ doc/html/xsu_in_gmenu.jpg
+}
+