summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-07 08:29:42 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-07 08:29:42 +0000
commit991a33d5d4ff5d6808e0fd9adaf2c4dc04d18ba5 (patch)
treef384df461d8c08fbc56df330d4dc06a8206ff583 /app-admin/webmin
parentremoving obselete ebuilds (Manifest recommit) (diff)
downloadgentoo-2-991a33d5d4ff5d6808e0fd9adaf2c4dc04d18ba5.tar.gz
gentoo-2-991a33d5d4ff5d6808e0fd9adaf2c4dc04d18ba5.tar.bz2
gentoo-2-991a33d5d4ff5d6808e0fd9adaf2c4dc04d18ba5.zip
Version bump
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog7
-rw-r--r--app-admin/webmin/Manifest2
-rw-r--r--app-admin/webmin/files/digest-webmin-1.1401
-rw-r--r--app-admin/webmin/webmin-1.140.ebuild82
4 files changed, 91 insertions, 1 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index 8cc34f648336..9bd7ab0bd595 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webmin
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.37 2004/04/07 08:13:03 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.38 2004/04/07 08:29:42 eradicator Exp $
+
+*webmin-1.140 (07 Apr 2004)
+
+ 07 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org> webmin-1.140.ebuild:
+ Version bump
*webmin-1.130-r1 (07 Apr 2004)
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index f10573d33653..bb4b70d0d2fe 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,3 +1,4 @@
+MD5 3ef0b1f756a46f3728ebd498ebabad44 webmin-1.140.ebuild 1989
MD5 e1448effc29a46897c48b774ec52a127 webmin-1.080.ebuild 1760
MD5 f5f16f198582b89165595878bb861c64 webmin-1.130-r1.ebuild 1980
MD5 871a442fb0428ebaeb78601de262b8b5 webmin-1.110.ebuild 1869
@@ -11,5 +12,6 @@ MD5 c2e70e10958f50cd84c377b5963a8ced files/digest-webmin-1.080 65
MD5 7f0f3de1fc4601b588dc143645df86b7 files/digest-webmin-1.110 65
MD5 e6cc2ef57317e815592875f7d6d3e386 files/digest-webmin-1.121 65
MD5 45eacf952391438a2db6170312783f32 files/digest-webmin-1.130 65
+MD5 764bde81bfa9cb97e455324ea0033759 files/digest-webmin-1.140 65
MD5 cadb87585ab39215aea085411ba590af files/webmin-1.130-webalizer.patch 595
MD5 45eacf952391438a2db6170312783f32 files/digest-webmin-1.130-r1 65
diff --git a/app-admin/webmin/files/digest-webmin-1.140 b/app-admin/webmin/files/digest-webmin-1.140
new file mode 100644
index 000000000000..3fd54bfe7b2a
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.140
@@ -0,0 +1 @@
+MD5 462b1db35e3e6eb6b29d6c658184af4f webmin-1.140.tar.gz 7006739
diff --git a/app-admin/webmin/webmin-1.140.ebuild b/app-admin/webmin/webmin-1.140.ebuild
new file mode 100644
index 000000000000..858d1d5e078a
--- /dev/null
+++ b/app-admin/webmin/webmin-1.140.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.140.ebuild,v 1.1 2004/04/07 08:29:42 eradicator Exp $
+
+inherit eutils
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ # Bug #47020
+ pushd ${D}/usr/libexec/webmin/webalizer
+ epatch ${FILESDIR}/${PN}-1.130-webalizer.patch
+ popd
+
+ exeinto /etc/init.d
+ newexe webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+ use ssl && sed -i 's:ssl=$ssl:ssl=1:' setup.sh
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}
+
+pkg_prerm() {
+ webmin stop
+}