summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-17 18:06:03 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-17 18:06:03 +0000
commit8db906c52326ceb90777878b5cc9d247be134e89 (patch)
tree32a1771a602e8cbc9a1bf8ae1966062a57d0c7e4 /app-admin/webapp-config
parentfix bug #204308 (diff)
downloadgentoo-2-8db906c52326ceb90777878b5cc9d247be134e89.tar.gz
gentoo-2-8db906c52326ceb90777878b5cc9d247be134e89.tar.bz2
gentoo-2-8db906c52326ceb90777878b5cc9d247be134e89.zip
fix #166853, #181938, #206669
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/ChangeLog12
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.50.16-absolute-paths.patch42
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.50.16-htdocs-symlink.patch13
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild66
4 files changed, 131 insertions, 2 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 337659138137..276651c431f5 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/webapp-config
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.61 2007/09/09 21:11:40 hollow Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.62 2008/02/17 18:06:02 hollow Exp $
+
+*webapp-config-1.50.16-r3 (17 Feb 2008)
+
+ 17 Feb 2008; Benedikt Böhm <hollow@gentoo.org>
+ +files/webapp-config-1.50.16-absolute-paths.patch,
+ +files/webapp-config-1.50.16-htdocs-symlink.patch,
+ +webapp-config-1.50.16-r3.ebuild:
+ fix #166853, #181938, #206669
*webapp-config-1.50.16-r2 (09 Sep 2007)
diff --git a/app-admin/webapp-config/files/webapp-config-1.50.16-absolute-paths.patch b/app-admin/webapp-config/files/webapp-config-1.50.16-absolute-paths.patch
new file mode 100644
index 000000000000..c74fff9b2079
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.50.16-absolute-paths.patch
@@ -0,0 +1,42 @@
+Index: webapp-config-1.50.16/WebappConfig/config.py
+===================================================================
+--- webapp-config-1.50.16.orig/WebappConfig/config.py
++++ webapp-config-1.50.16/WebappConfig/config.py
+@@ -204,6 +204,7 @@ class Config:
+ pass
+
+ self.__d = {
++ 'allow_absolute' : 'no',
+ 'config_protect' : wrapper.config_protect,
+ # Necessary to load the config file
+ 'my_etcconfig' : '/etc/vhosts/webapp-config',
+@@ -870,8 +871,13 @@ class Config:
+ #
+ # this makes sure we don't write rubbish into the installs list
+
+- installpath = self.config.get('USER', 'g_htdocsdir') + '/' + \
+- self.config.get('USER', 'g_installdir')
++ g_installdir = self.config.get('USER', 'g_installdir')
++
++ if (os.path.isabs(g_installdir)
++ and self.config.get('USER', 'allow_absolute') == 'yes'):
++ installpath = g_installdir
++ else:
++ installpath = self.config.get('USER', 'g_htdocsdir') + '/' + g_installdir
+
+ installpath = re.compile('/+').sub('/', self.__root + installpath)
+
+Index: webapp-config-1.50.16/config/webapp-config
+===================================================================
+--- webapp-config-1.50.16.orig/config/webapp-config
++++ webapp-config-1.50.16/config/webapp-config
+@@ -183,6 +183,9 @@ vhost_perms_virtualowned_file="o-w"
+
+ vhost_perms_installdir="0755"
+
++# Allow specifying absolute path names using the -d option?
++allow_absolute="no"
++
+
+ # ========================================================================
+ # END OF USER-EDITABLE SETTINGS
diff --git a/app-admin/webapp-config/files/webapp-config-1.50.16-htdocs-symlink.patch b/app-admin/webapp-config/files/webapp-config-1.50.16-htdocs-symlink.patch
new file mode 100644
index 000000000000..a7421b9b2c21
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.50.16-htdocs-symlink.patch
@@ -0,0 +1,13 @@
+Index: webapp-config-1.50.16/WebappConfig/server.py
+===================================================================
+--- webapp-config-1.50.16.orig/WebappConfig/server.py
++++ webapp-config-1.50.16/WebappConfig/server.py
+@@ -158,7 +158,7 @@ class Basic:
+
+ # is the installation directory empty?
+
+- if not os.listdir(self.__destd):
++ if not os.listdir(self.__destd) and os.path.isdir(self.__destd):
+ if not self.__p:
+ os.rmdir(self.__destd)
+ else:
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
new file mode 100644
index 000000000000..12eb57b92aa7
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild,v 1.1 2008/02/17 18:06:02 hollow Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://build.pardus.de/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-apache-move.patch
+ epatch "${FILESDIR}"/${P}-baselayout2.patch
+ epatch "${FILESDIR}"/${P}-htdocs-symlink.patch
+ epatch "${FILESDIR}"/${P}-absolute-paths.patch
+}
+
+src_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/*.[58]
+ dohtml doc/*.[58].html
+}
+
+src_test() {
+ distutils_python_version
+ if [[ $PYVER_MAJOR -gt 1 ]] && [[ $PYVER_MINOR -gt 3 ]] ; then
+ elog "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+ else
+ elog "Python version below 2.4! Disabling tests."
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+ echo
+ epause 5
+}