summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-25 13:48:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-25 13:48:39 +0000
commit560e9c9d3c373d57d3649dceb60ecfb92f074980 (patch)
treefcf11bad444b57b2ff51ce5b39142ae0bba9ea05 /app-admin/watchdog/watchdog-5.2.ebuild
parentfix badmask (diff)
downloadgentoo-2-560e9c9d3c373d57d3649dceb60ecfb92f074980.tar.gz
gentoo-2-560e9c9d3c373d57d3649dceb60ecfb92f074980.tar.bz2
gentoo-2-560e9c9d3c373d57d3649dceb60ecfb92f074980.zip
repoman'd
Diffstat (limited to 'app-admin/watchdog/watchdog-5.2.ebuild')
-rw-r--r--app-admin/watchdog/watchdog-5.2.ebuild52
1 files changed, 26 insertions, 26 deletions
diff --git a/app-admin/watchdog/watchdog-5.2.ebuild b/app-admin/watchdog/watchdog-5.2.ebuild
index cb6f7db6314e..8cad68a7ac72 100644
--- a/app-admin/watchdog/watchdog-5.2.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.ebuild
@@ -1,44 +1,44 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.5 2002/07/17 20:43:17 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.6 2002/07/25 13:48:39 seemant Exp $
+S="${WORKDIR}/${P}"
DESCRIPTION="A software watchdog."
HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
SRC_URI="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${P}.tar.gz"
+
SLOT="0"
-S="${WORKDIR}/${P}"
LICENSE="GPL-2"
+KEYWORDS="x86"
src_compile() {
- # Two configure switches have been added to use /etc/watchdog
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/watchdog \
- --with-configfile=/etc/watchdog/watchdog.conf \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
- emake || die
+ # Two configure switches have been added to use /etc/watchdog
+ econf \
+ --sysconfdir=/etc/watchdog \
+ --with-configfile=/etc/watchdog/watchdog.conf \
+ || die "./configure failed"
+
+ emake || die
}
src_install () {
- dodir /etc/watchdog
- make DESTDIR="${D}" install || die
+ dodir /etc/watchdog
+ make DESTDIR="${D}" install || die
- exeinto /etc/init.d
- doexe "${FILESDIR}/${PVR}/watchdog"
+ exeinto /etc/init.d
+ doexe "${FILESDIR}/${PVR}/watchdog"
}
pkg_postinst () {
- einfo
- einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
- einfo
- if [ ! -e /dev/watchdog ]
- then
- ewarn
- ewarn "No /dev/watchdog found! Make sure your kernel has watchdog support"
- ewarn "compiled in or the kernel module is loaded. The watchdog service"
- ewarn "will not start at boot until your kernel is configured properly."
- ewarn
- fi
+ einfo
+ einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
+ einfo
+ if [ ! -e /dev/watchdog ]
+ then
+ ewarn
+ ewarn "No /dev/watchdog found! Make sure your kernel has watchdog support"
+ ewarn "compiled in or the kernel module is loaded. The watchdog service"
+ ewarn "will not start at boot until your kernel is configured properly."
+ ewarn
+ fi
}