summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-30 04:13:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-30 04:13:29 +0000
commitade7e981ff6815c6ad0d92e79909ef77c8136945 (patch)
tree7bf755a0fefcc11b6956257950afda7fb35657f8 /app-admin/usermin
parentRun enewuser in pkg_postinst() where it is used. (diff)
downloadgentoo-2-ade7e981ff6815c6ad0d92e79909ef77c8136945.tar.gz
gentoo-2-ade7e981ff6815c6ad0d92e79909ef77c8136945.tar.bz2
gentoo-2-ade7e981ff6815c6ad0d92e79909ef77c8136945.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin/usermin')
-rw-r--r--app-admin/usermin/ChangeLog9
-rw-r--r--app-admin/usermin/usermin-1.530.ebuild85
2 files changed, 92 insertions, 2 deletions
diff --git a/app-admin/usermin/ChangeLog b/app-admin/usermin/ChangeLog
index 76daf612ad14..7916b09a4ea5 100644
--- a/app-admin/usermin/ChangeLog
+++ b/app-admin/usermin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/usermin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.153 2012/07/12 15:14:55 axs Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.154 2013/01/30 04:13:29 patrick Exp $
+
+*usermin-1.530 (30 Jan 2013)
+
+ 30 Jan 2013; Patrick Lauer <patrick@gentoo.org> +usermin-1.530.ebuild:
+ Bump
12 Jul 2012; Ian Stakenvicius <axs@gentoo.org> usermin-1.430.ebuild:
added GPL-2 to LICENSE per bug 425880
diff --git a/app-admin/usermin/usermin-1.530.ebuild b/app-admin/usermin/usermin-1.530.ebuild
new file mode 100644
index 000000000000..f4a0649e9607
--- /dev/null
+++ b/app-admin/usermin/usermin-1.530.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.530.ebuild,v 1.1 2013/01/30 04:13:29 patrick Exp $
+
+IUSE="ssl"
+
+inherit eutils pam
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="${DEPEND}
+ sys-process/lsof
+ ssl? ( dev-perl/Net-SSLeay )"
+
+# pam? ( dev-perl/Authen-PAM )
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # Point to the correct mysql location
+ sed -i -e "s:/usr/local/mysql:/usr:g" mysql/config
+
+ epatch "${FILESDIR}"/${PN}-1.080-safestop.patch
+ epatch "${FILESDIR}"/${PN}-1.150-setup-nocheck.patch
+}
+
+src_install() {
+ # Change /usr/local/bin/perl references
+ find . -type f | xargs sed -i -e 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+
+ dodir /usr/libexec/usermin
+ cp -pR * "${D}"/usr/libexec/usermin
+
+ newinitd "${FILESDIR}"/init.d.usermin usermin
+
+ newpamd "${FILESDIR}"/${PN}.pam-include.1 ${PN}
+
+ # Fix ownership
+ chown -R root:0 "${D}"
+
+ dodir /etc/usermin
+ dodir /var/log/usermin
+
+ config_dir=${D}/etc/usermin
+ var_dir=${D}/var/log/usermin
+ perl=/usr/bin/perl
+ autoos=1
+ port=20000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ "${D}"/usr/libexec/usermin/setup.sh > "${T}"/usermin-setup.out 2>&1 || die "Failed to create initial usermin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=/var/run/usermin.pid:" "${D}"/etc/usermin/miniserv.conf
+ find "${D}"/etc/usermin -type f | xargs sed -i -e "s:${D}:/:g"
+
+ # Cleanup from the config script
+ rm -rf "${D}"/var/log/usermin
+ keepdir /var/log/usermin/
+}
+
+pkg_postinst() {
+ elog "To make usermin start at boot time, run: 'rc-update add usermin default'."
+ elog "Point your web browser to https://localhost:20000 to use usermin."
+}