summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-08-16 10:20:29 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-08-16 10:20:29 +0000
commit9f200b426fd97c3fb7ae86d1f0fe168ddb945530 (patch)
tree85e5a9f95eead41db7da0d202f6e189b55cd70b3 /app-admin/torsmo
parentx86 stable (Manifest recommit) (diff)
downloadgentoo-2-9f200b426fd97c3fb7ae86d1f0fe168ddb945530.tar.gz
gentoo-2-9f200b426fd97c3fb7ae86d1f0fe168ddb945530.tar.bz2
gentoo-2-9f200b426fd97c3fb7ae86d1f0fe168ddb945530.zip
Mozilla patch by affinity <waffinity@gmail.com> in bug #60526
Diffstat (limited to 'app-admin/torsmo')
-rw-r--r--app-admin/torsmo/ChangeLog6
-rw-r--r--app-admin/torsmo/files/torsmo-0.17-mozilla.patch17
-rw-r--r--app-admin/torsmo/torsmo-0.17.ebuild12
3 files changed, 32 insertions, 3 deletions
diff --git a/app-admin/torsmo/ChangeLog b/app-admin/torsmo/ChangeLog
index ee7722081975..36192a5387cd 100644
--- a/app-admin/torsmo/ChangeLog
+++ b/app-admin/torsmo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/torsmo
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/ChangeLog,v 1.9 2004/07/18 05:55:31 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/ChangeLog,v 1.10 2004/08/16 10:20:29 dragonheart Exp $
+
+ 16 Aug 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/torsmo-0.17-mozilla.patch, torsmo-0.17.ebuild:
+ Mozilla patch by affinity <waffinity@gmail.com> in bug #60526
18 Jul 2004; Daniel Black <dragonheart@gentoo.org> torsmo-0.17.ebuild:
x86 stable
diff --git a/app-admin/torsmo/files/torsmo-0.17-mozilla.patch b/app-admin/torsmo/files/torsmo-0.17-mozilla.patch
new file mode 100644
index 000000000000..4a348a589005
--- /dev/null
+++ b/app-admin/torsmo/files/torsmo-0.17-mozilla.patch
@@ -0,0 +1,17 @@
+--- torsmo-orig/torsmo.c 2004-05-25 13:58:51.000000000 +0300
++++ torsmo-0.17/torsmo.c 2004-08-16 08:24:36.080635032 +0300
+@@ -342,6 +342,14 @@
+ }
+ }
+ else {
++ if (reading_status && strncmp(buf, "X-Mozilla-Status:", 17) == 0) {
++ /* check that mail isn't already read */
++ if (strchr(buf+21, '0'))
++ new_mail_count++;
++
++ reading_status = 0;
++ continue;
++ }
+ if (reading_status && strncmp(buf, "Status:", 7) == 0) {
+ /* check that mail isn't already read */
+ if (strchr(buf+7, 'R') == NULL)
diff --git a/app-admin/torsmo/torsmo-0.17.ebuild b/app-admin/torsmo/torsmo-0.17.ebuild
index f989cd0e0903..59d3f6b648d7 100644
--- a/app-admin/torsmo/torsmo-0.17.ebuild
+++ b/app-admin/torsmo/torsmo-0.17.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.17.ebuild,v 1.6 2004/07/18 05:55:31 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.17.ebuild,v 1.7 2004/08/16 10:20:29 dragonheart Exp $
+
+inherit eutils
DESCRIPTION="system monitor that sits in the corner of your desktop"
HOMEPAGE="http://torsmo.sourceforge.net/"
@@ -9,7 +11,7 @@ SRC_URI="mirror://sourceforge/torsmo/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 ~ppc ~amd64"
-IUSE=""
+IUSE="mozilla"
RDEPEND="virtual/libc
virtual/x11"
@@ -20,6 +22,12 @@ DEPEND="${RDEPEND}
sys-apps/sed
sys-devel/gcc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use mozilla && epatch ${FILESDIR}/${P}-mozilla.patch
+}
+
src_install() {
emake DESTDIR=${D} install || die "make install failed"
dodoc ChangeLog AUTHORS README NEWS torsmorc.sample