summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-08 13:32:48 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-08 13:32:48 +0000
commit93b24ae28cd968e717488651a6fa7fdb9609f729 (patch)
tree74c0714a13f0b8a0bb2ba1309fc79b29b8658365 /app-admin/sxid/sxid-4.0.2.ebuild
parentFHS fix (diff)
downloadgentoo-2-93b24ae28cd968e717488651a6fa7fdb9609f729.tar.gz
gentoo-2-93b24ae28cd968e717488651a6fa7fdb9609f729.tar.bz2
gentoo-2-93b24ae28cd968e717488651a6fa7fdb9609f729.zip
Initial import
Diffstat (limited to 'app-admin/sxid/sxid-4.0.2.ebuild')
-rw-r--r--app-admin/sxid/sxid-4.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/sxid/sxid-4.0.2.ebuild b/app-admin/sxid/sxid-4.0.2.ebuild
new file mode 100644
index 000000000000..5121d4482f76
--- /dev/null
+++ b/app-admin/sxid/sxid-4.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.0.2.ebuild,v 1.1 2002/11/08 13:32:48 aliz Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="suid, sgid file and directory checking"
+SRC_URI="ftp://marcus.seva.net/pub/sxid/${P/-/_}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ cd source
+ sed s/bindir/sbindir/g < Makefile.in > Makefile.in.new
+ mv -f Makefile.in.new Makefile.in
+ cd ..
+
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README docs/sxid.conf.example docs/sxid.cron.example
+
+ einfo "You will need to configure sxid.conf for your system using the manpage and example"
+}
+