summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-15 17:46:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-15 17:46:07 +0000
commit44331591e621a6cdddfa7875bb22fa99e2a9550f (patch)
tree52ad0289109f41b219b138efa93b947192fe77d9 /app-admin/sudo
parentFix tests wrt bug #310725 (diff)
downloadgentoo-2-44331591e621a6cdddfa7875bb22fa99e2a9550f.tar.gz
gentoo-2-44331591e621a6cdddfa7875bb22fa99e2a9550f.tar.bz2
gentoo-2-44331591e621a6cdddfa7875bb22fa99e2a9550f.zip
Version bump and cleanup old version. Version 1.7.3_beta1 is gone because it is not covered by the latest two security announces.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/sudo')
-rw-r--r--app-admin/sudo/ChangeLog10
-rw-r--r--app-admin/sudo/sudo-1.7.2_p1.ebuild214
-rw-r--r--app-admin/sudo/sudo-1.7.2_p6.ebuild (renamed from app-admin/sudo/sudo-1.7.2_p3.ebuild)2
-rw-r--r--app-admin/sudo/sudo-1.7.3_beta1.ebuild221
4 files changed, 10 insertions, 437 deletions
diff --git a/app-admin/sudo/ChangeLog b/app-admin/sudo/ChangeLog
index 9d688b644342..6502b91d8979 100644
--- a/app-admin/sudo/ChangeLog
+++ b/app-admin/sudo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/sudo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/ChangeLog,v 1.214 2010/03/01 20:31:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/ChangeLog,v 1.215 2010/04/15 17:46:07 flameeyes Exp $
+
+*sudo-1.7.2_p6 (15 Apr 2010)
+
+ 15 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -sudo-1.7.2_p1.ebuild, -sudo-1.7.2_p3.ebuild, +sudo-1.7.2_p6.ebuild,
+ -sudo-1.7.3_beta1.ebuild:
+ Version bump and cleanup old version. Version 1.7.3_beta1 is gone because
+ it is not covered by the latest two security announces.
01 Mar 2010; Raúl Porcel <armin76@gentoo.org> sudo-1.7.2_p4.ebuild:
alpha/arm/ia64/m68k/s390/sh/sparc stable wrt #306865
diff --git a/app-admin/sudo/sudo-1.7.2_p1.ebuild b/app-admin/sudo/sudo-1.7.2_p1.ebuild
deleted file mode 100644
index 4e8c6f7520bd..000000000000
--- a/app-admin/sudo/sudo-1.7.2_p1.ebuild
+++ /dev/null
@@ -1,214 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.7.2_p1.ebuild,v 1.10 2009/10/09 17:48:38 armin76 Exp $
-
-inherit eutils pam confutils autotools
-
-MY_P=${P/_/}
-MY_P=${MY_P/beta/b}
-
-case "${P}" in
- *_beta* | *_rc*)
- uri_prefix=beta/
- ;;
- *)
- uri_prefix=""
- ;;
-esac
-
-DESCRIPTION="Allows users or groups to run commands as other users"
-HOMEPAGE="http://www.sudo.ws/"
-SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${uri_prefix}${MY_P}.tar.gz"
-# Basic license is ISC-style as-is, some files are released under
-# 3-clause BSD license
-LICENSE="as-is BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="pam skey offensive ldap selinux"
-
-DEPEND="pam? ( virtual/pam )
- ldap? (
- >=net-nds/openldap-2.1.30-r1
- dev-libs/cyrus-sasl
- )
- skey? ( >=sys-auth/skey-1.1.5-r1 )
- virtual/editor
- virtual/mta"
-RDEPEND="selinux? ( sec-policy/selinux-sudo )
- ldap? ( dev-lang/perl )
- pam? ( sys-auth/pambase )
- ${DEPEND}"
-DEPEND="${DEPEND} sys-devel/bison"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- confutils_use_conflict skey pam
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-
- # compatability fix.
- epatch "${FILESDIR}"/${PN}-skeychallengeargs.diff
-
- # additional variables to disallow, should user disable env_reset.
-
- # NOTE: this is not a supported mode of operation, these variables
- # are added to the blacklist as a convenience to administrators
- # who fail to heed the warnings of allowing untrusted users
- # to access sudo.
- #
- # there is *no possible way* to foresee all attack vectors in
- # all possible applications that could potentially be used via
- # sudo, these settings will just delay the inevitable.
- #
- # that said, I will accept suggestions for variables that can
- # be misused in _common_ interpreters or libraries, such as
- # perl, bash, python, ruby, etc., in the hope of dissuading
- # a casual attacker.
-
- # XXX: perl should be using suid_perl.
- # XXX: users can remove/add more via env_delete and env_check.
- # XXX: <?> = probably safe enough for most circumstances.
-
- einfo "Blacklisting common variables (env_delete)..."
- sudo_bad_var() {
- local target='env.c' marker='\*initial_badenv_table\[\]'
-
- ebegin " $1"
- sed -i 's#\(^.*'${marker}'.*$\)#\1\n\t"'${1}'",#' "${S}"/${target}
- eend $?
- }
-
- sudo_bad_var 'PERLIO_DEBUG' # perl, write debug to file.
- sudo_bad_var 'FPATH' # ksh, search path for functions.
- sudo_bad_var 'NULLCMD' # zsh, command on null-redir. <?>
- sudo_bad_var 'READNULLCMD' # zsh, command on null-redir. <?>
- sudo_bad_var 'GLOBIGNORE' # bash, glob paterns to ignore. <?>
- sudo_bad_var 'PYTHONHOME' # python, module search path.
- sudo_bad_var 'PYTHONPATH' # python, search path.
- sudo_bad_var 'PYTHONINSPECT' # python, allow inspection.
- sudo_bad_var 'RUBYLIB' # ruby, lib load path.
- sudo_bad_var 'RUBYOPT' # ruby, cl options.
- sudo_bad_var 'ZDOTDIR' # zsh, path to search for dotfiles.
- einfo "...done."
-
- # prevent binaries from being stripped.
- sed -i 's/\($(INSTALL).*\) -s \(.*[(sudo|visudo)]\)/\1 \2/g' Makefile.in
-
- epatch "${FILESDIR}"/${MY_P}-securepath.patch
-
- eautoconf
-}
-
-src_compile() {
- local line ROOTPATH
-
- # FIXME: secure_path is a compile time setting. using ROOTPATH
- # is not perfect, env-update may invalidate this, but until it
- # is available as a sudoers setting this will have to do.
- einfo "Setting secure_path..."
-
- # why not use grep? variable might be expanded from other variables
- # declared in that file. cannot just source the file, would override
- # any variables already set.
- eval `PS4= bash -x /etc/profile.env 2>&1 | \
- while read line; do
- case $line in
- ROOTPATH=*) echo $line; break;;
- *) continue;;
- esac
- done` && einfo " Found ROOTPATH..." || \
- ewarn " Failed to find ROOTPATH, please report this."
-
- # remove duplicate path entries from $1
- cleanpath() {
- local i=1 x n IFS=:
- local -a paths; paths=($1)
-
- for ((n=${#paths[*]}-1;i<=n;i++)); do
- for ((x=0;x<i;x++)); do
- test "${paths[i]}" == "${paths[x]}" && {
- einfo " Duplicate entry ${paths[i]} removed..." 1>&2
- unset paths[i]; continue 2; }
- done; # einfo " Adding ${paths[i]}..." 1>&2
- done; echo "${paths[*]}"
- }
-
- ROOTPATH=$(cleanpath /bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin${ROOTPATH:+:${ROOTPATH}})
-
- # strip gcc path (bug #136027)
- rmpath() {
- declare e newpath oldpath=${!1} PATHvar=$1 thisp IFS=:
- shift
- for thisp in $oldpath; do
- for e; do [[ $thisp == $e ]] && continue 2; done
- newpath=$newpath:$thisp
- done
- eval $PATHvar='${newpath#:}'
- }
-
- rmpath ROOTPATH '*/gcc-bin/*'
-
- einfo "...done."
-
- # XXX: --disable-path-info closes an info leak, but may be confusing.
- # XXX: /bin/vi may not be available, make nano visudo's default.
- econf --with-secure-path="${ROOTPATH}" \
- --with-editor="${EDITOR:-/bin/nano}" \
- --with-env-editor \
- $(use_with offensive insults) \
- $(use_with offensive all-insults) \
- $(use_with pam) \
- $(use_with skey) \
- $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo) \
- $(use_with ldap) || die
-
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog HISTORY PORTING README TROUBLESHOOTING \
- UPGRADE WHATSNEW sample.sudoers sample.syslog.conf
-
- if use ldap; then
- dodoc README.LDAP schema.OpenLDAP
- dosbin sudoers2ldif
-
- cat - > "${T}"/ldap.conf.sudo <<EOF
-# See ldap.conf(5) and README.LDAP for details\n"
-# This file should only be readable by root\n\n"
-# supported directives: host, port, ssl, ldap_version\n"
-# uri, binddn, bindpw, sudoers_base, sudoers_debug\n"
-# tls_{checkpeer,cacertfile,cacertdir,randfile,ciphers,cert,key
-EOF
-
- insinto /etc
- doins "${T}"/ldap.conf.sudo
- fperms 0440 /etc/ldap.conf.sudo
- fi
-
- pamd_mimic system-auth sudo auth account password session
-
- insinto /etc
- doins "${S}"/sudoers
- fperms 0440 /etc/sudoers
-}
-
-pkg_postinst() {
- if use ldap; then
- ewarn
- ewarn "sudo uses the /etc/ldap.conf.sudo file for ldap configuration."
- ewarn
- if egrep -q '^[[:space:]]*sudoers:' "${ROOT}"/etc/nsswitch.conf; then
- ewarn "In 1.7 series, LDAP is no more consulted, unless explicitly"
- ewarn "configured in /etc/nsswitch.conf."
- ewarn
- ewarn "To make use of LDAP, add this line to your /etc/nsswitch.conf:"
- ewarn " sudoers: ldap files"
- ewarn
- fi
- fi
-}
diff --git a/app-admin/sudo/sudo-1.7.2_p3.ebuild b/app-admin/sudo/sudo-1.7.2_p6.ebuild
index 67ab671aa1d0..3a3b6b9c0944 100644
--- a/app-admin/sudo/sudo-1.7.2_p3.ebuild
+++ b/app-admin/sudo/sudo-1.7.2_p6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.7.2_p3.ebuild,v 1.1 2010/02/20 18:58:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.7.2_p6.ebuild,v 1.1 2010/04/15 17:46:07 flameeyes Exp $
inherit eutils pam confutils
diff --git a/app-admin/sudo/sudo-1.7.3_beta1.ebuild b/app-admin/sudo/sudo-1.7.3_beta1.ebuild
deleted file mode 100644
index f9376c9e9681..000000000000
--- a/app-admin/sudo/sudo-1.7.3_beta1.ebuild
+++ /dev/null
@@ -1,221 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.7.3_beta1.ebuild,v 1.4 2009/12/31 13:46:18 ranger Exp $
-
-inherit eutils pam confutils
-
-MY_P=${P/_/}
-MY_P=${MY_P/beta/b}
-
-case "${P}" in
- *_beta* | *_rc*)
- uri_prefix=beta/
- ;;
- *)
- uri_prefix=""
- ;;
-esac
-
-DESCRIPTION="Allows users or groups to run commands as other users"
-HOMEPAGE="http://www.sudo.ws/"
-SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${uri_prefix}${MY_P}.tar.gz"
-# Basic license is ISC-style as-is, some files are released under
-# 3-clause BSD license
-LICENSE="as-is BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="pam skey offensive ldap selinux"
-
-DEPEND="pam? ( virtual/pam )
- ldap? (
- >=net-nds/openldap-2.1.30-r1
- dev-libs/cyrus-sasl
- )
- skey? ( >=sys-auth/skey-1.1.5-r1 )
- app-editors/gentoo-editor
- virtual/editor
- virtual/mta"
-RDEPEND="selinux? ( sec-policy/selinux-sudo )
- ldap? ( dev-lang/perl )
- pam? ( sys-auth/pambase )
- ${DEPEND}"
-DEPEND="${DEPEND} sys-devel/bison"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- confutils_use_conflict skey pam
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-
- # compatability fix.
- epatch "${FILESDIR}"/${PN}-skeychallengeargs.diff
-
- # additional variables to disallow, should user disable env_reset.
-
- # NOTE: this is not a supported mode of operation, these variables
- # are added to the blacklist as a convenience to administrators
- # who fail to heed the warnings of allowing untrusted users
- # to access sudo.
- #
- # there is *no possible way* to foresee all attack vectors in
- # all possible applications that could potentially be used via
- # sudo, these settings will just delay the inevitable.
- #
- # that said, I will accept suggestions for variables that can
- # be misused in _common_ interpreters or libraries, such as
- # perl, bash, python, ruby, etc., in the hope of dissuading
- # a casual attacker.
-
- # XXX: perl should be using suid_perl.
- # XXX: users can remove/add more via env_delete and env_check.
- # XXX: <?> = probably safe enough for most circumstances.
-
- einfo "Blacklisting common variables (env_delete)..."
- sudo_bad_var() {
- local target='env.c' marker='\*initial_badenv_table\[\]'
-
- ebegin " $1"
- sed -i 's#\(^.*'${marker}'.*$\)#\1\n\t"'${1}'",#' "${S}"/${target}
- eend $?
- }
-
- sudo_bad_var 'PERLIO_DEBUG' # perl, write debug to file.
- sudo_bad_var 'FPATH' # ksh, search path for functions.
- sudo_bad_var 'NULLCMD' # zsh, command on null-redir. <?>
- sudo_bad_var 'READNULLCMD' # zsh, command on null-redir. <?>
- sudo_bad_var 'GLOBIGNORE' # bash, glob paterns to ignore. <?>
- sudo_bad_var 'PYTHONHOME' # python, module search path.
- sudo_bad_var 'PYTHONPATH' # python, search path.
- sudo_bad_var 'PYTHONINSPECT' # python, allow inspection.
- sudo_bad_var 'RUBYLIB' # ruby, lib load path.
- sudo_bad_var 'RUBYOPT' # ruby, cl options.
- sudo_bad_var 'ZDOTDIR' # zsh, path to search for dotfiles.
- einfo "...done."
-
- # prevent binaries from being stripped.
- sed -i 's/\($(INSTALL).*\) -s \(.*[(sudo|visudo)]\)/\1 \2/g' Makefile.in
-}
-
-src_compile() {
- local line ROOTPATH
-
- # FIXME: secure_path is a compile time setting. using ROOTPATH
- # is not perfect, env-update may invalidate this, but until it
- # is available as a sudoers setting this will have to do.
- einfo "Setting secure_path..."
-
- # why not use grep? variable might be expanded from other variables
- # declared in that file. cannot just source the file, would override
- # any variables already set.
- eval `PS4= bash -x /etc/profile.env 2>&1 | \
- while read line; do
- case $line in
- ROOTPATH=*) echo $line; break;;
- *) continue;;
- esac
- done` && einfo " Found ROOTPATH..." || \
- ewarn " Failed to find ROOTPATH, please report this."
-
- # remove duplicate path entries from $1
- cleanpath() {
- local i=1 x n IFS=:
- local -a paths; paths=($1)
-
- for ((n=${#paths[*]}-1;i<=n;i++)); do
- for ((x=0;x<i;x++)); do
- test "${paths[i]}" == "${paths[x]}" && {
- einfo " Duplicate entry ${paths[i]} removed..." 1>&2
- unset paths[i]; continue 2; }
- done; # einfo " Adding ${paths[i]}..." 1>&2
- done; echo "${paths[*]}"
- }
-
- ROOTPATH=$(cleanpath /bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin${ROOTPATH:+:${ROOTPATH}})
-
- # strip gcc path (bug #136027)
- rmpath() {
- declare e newpath oldpath=${!1} PATHvar=$1 thisp IFS=:
- shift
- for thisp in $oldpath; do
- for e; do [[ $thisp == $e ]] && continue 2; done
- newpath=$newpath:$thisp
- done
- eval $PATHvar='${newpath#:}'
- }
-
- rmpath ROOTPATH '*/gcc-bin/*'
-
- einfo "...done."
-
- # XXX: --disable-path-info closes an info leak, but may be confusing.
- econf --with-secure-path="${ROOTPATH}" \
- --with-editor=/usr/libexec/gentoo-editor \
- --with-env-editor \
- $(use_with offensive insults) \
- $(use_with offensive all-insults) \
- $(use_with pam) \
- $(use_with skey) \
- $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo) \
- $(use_with ldap) || die
-
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog HISTORY PORTING README TROUBLESHOOTING \
- UPGRADE WHATSNEW sample.sudoers sample.syslog.conf
-
- if use ldap; then
- dodoc README.LDAP schema.OpenLDAP
- dosbin sudoers2ldif
-
- cat - > "${T}"/ldap.conf.sudo <<EOF
-# See ldap.conf(5) and README.LDAP for details\n"
-# This file should only be readable by root\n\n"
-# supported directives: host, port, ssl, ldap_version\n"
-# uri, binddn, bindpw, sudoers_base, sudoers_debug\n"
-# tls_{checkpeer,cacertfile,cacertdir,randfile,ciphers,cert,key
-EOF
-
- insinto /etc
- doins "${T}"/ldap.conf.sudo
- fperms 0440 /etc/ldap.conf.sudo
- fi
-
- pamd_mimic system-auth sudo auth account password session
-
- insinto /etc
- doins "${S}"/sudoers
- fperms 0440 /etc/sudoers
-}
-
-pkg_postinst() {
- if use ldap; then
- ewarn
- ewarn "sudo uses the /etc/ldap.conf.sudo file for ldap configuration."
- ewarn
- if egrep -q '^[[:space:]]*sudoers:' "${ROOT}"/etc/nsswitch.conf; then
- ewarn "In 1.7 series, LDAP is no more consulted, unless explicitly"
- ewarn "configured in /etc/nsswitch.conf."
- ewarn
- ewarn "To make use of LDAP, add this line to your /etc/nsswitch.conf:"
- ewarn " sudoers: ldap files"
- ewarn
- fi
- fi
-
- elog "To use the -A (askpass) option, you need to install a compatible"
- elog "password program from the following list. Starred packages will"
- elog "automatically register for the use with sudo (but will not force"
- elog "the -A option):"
- elog ""
- elog " [*] net-misc/ssh-askpass-fullscreen"
- elog " net-misc/x11-ssh-askpass"
- elog ""
- elog "You can override the choice by setting the SUDO_ASKPASS environmnent"
- elog "variable to the program you want to use."
-}