summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2010-05-12 13:30:25 +0000
committerChris PeBenito <pebenito@gentoo.org>2010-05-12 13:30:25 +0000
commita62876c1f53b7a947e601d8097a24a7b96af4977 (patch)
tree8b294dbe8be46b80cc68ff22107f564134930a75 /app-admin/setools
parentAdded missing fortran_pkg_setup (diff)
downloadgentoo-2-a62876c1f53b7a947e601d8097a24a7b96af4977.tar.gz
gentoo-2-a62876c1f53b7a947e601d8097a24a7b96af4977.tar.bz2
gentoo-2-a62876c1f53b7a947e601d8097a24a7b96af4977.zip
New upstream release of setools
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/setools')
-rw-r--r--app-admin/setools/ChangeLog9
-rw-r--r--app-admin/setools/setools-3.3.7.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/app-admin/setools/ChangeLog b/app-admin/setools/ChangeLog
index d835d064bfa5..52247b50a05a 100644
--- a/app-admin/setools/ChangeLog
+++ b/app-admin/setools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/setools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/ChangeLog,v 1.61 2009/09/20 22:35:02 pebenito Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/ChangeLog,v 1.62 2010/05/12 13:30:25 pebenito Exp $
+
+*setools-3.3.7 (12 May 2010)
+
+ 12 May 2010; Chris PeBenito <pebenito@gentoo.org> +setools-3.3.7.ebuild:
+ New upstream release.
20 Sep 2009; Chris PeBenito <pebenito@gentoo.org> setools-3.3.6.ebuild,
+files/setools-3.3.6-headers.diff:
diff --git a/app-admin/setools/setools-3.3.7.ebuild b/app-admin/setools/setools-3.3.7.ebuild
new file mode 100644
index 000000000000..57c2a645a5fe
--- /dev/null
+++ b/app-admin/setools/setools-3.3.7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-3.3.7.ebuild,v 1.1 2010/05/12 13:30:25 pebenito Exp $
+
+inherit java-pkg-opt-2 autotools
+
+DESCRIPTION="SELinux policy tools"
+HOMEPAGE="http://www.tresys.com/selinux/selinux_policy_tools.shtml"
+SRC_URI="http://oss.tresys.com/projects/setools/chrome/site/dists/${PN}-${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X debug java python"
+
+DEPEND=">=sys-libs/libsepol-2.0.37
+ sys-libs/libselinux
+ sys-devel/bison
+ sys-devel/flex
+ >=dev-db/sqlite-3.2
+ dev-libs/libxml2
+ dev-util/pkgconfig
+ java? (
+ >=dev-lang/swig-1.3.28
+ >=virtual/jdk-1.4
+ )
+ python? (
+ >=dev-lang/python-2.4
+ >=dev-lang/swig-1.3.28
+ )
+ X? (
+ >=dev-lang/tk-8.4.9
+ >=gnome-base/libglade-2.0
+ >=x11-libs/gtk+-2.8
+ )"
+
+RDEPEND=">=sys-libs/libsepol-2.0.37
+ sys-libs/libselinux
+ >=dev-db/sqlite-3.2
+ dev-libs/libxml2
+ java? ( >=virtual/jre-1.4 )
+ python? ( >=dev-lang/python-2.4 )
+ X? (
+ >=dev-lang/tk-8.4.9
+ >=dev-tcltk/bwidget-1.8
+ >=gnome-base/libglade-2.0
+ >=x11-libs/gtk+-2.8
+ )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-java-prefix=${JAVA_HOME} \
+ --disable-selinux-check \
+ --disable-bwidget-check \
+ $(use_enable python swig-python) \
+ $(use_enable java swig-java) \
+ $(use_enable X swig-tcl) \
+ $(use_enable X gui) \
+ $(use_enable debug)
+
+ # work around swig c99 issues. it does not require
+ # c99 anyway.
+ sed -i -e 's/-std=gnu99//' "${S}/libseaudit/swig/python/Makefile"
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed."
+}