summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-09-29 12:03:18 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-09-29 12:03:18 +0000
commit2f1d7e0f3baca25664967afe259e88fac56c0604 (patch)
treeeadb277d93d949cba8025b5007b1bfec47c7df86 /app-admin/rsyslog/rsyslog-3.21.4.ebuild
parentVersion bump. Does not install the HTML documentation twice any more and uses... (diff)
downloadgentoo-2-2f1d7e0f3baca25664967afe259e88fac56c0604.tar.gz
gentoo-2-2f1d7e0f3baca25664967afe259e88fac56c0604.tar.bz2
gentoo-2-2f1d7e0f3baca25664967afe259e88fac56c0604.zip
Version bump for stable and devel branch (changelog says we don't want 3.18.3 stable, so dropping it)
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'app-admin/rsyslog/rsyslog-3.21.4.ebuild')
-rw-r--r--app-admin/rsyslog/rsyslog-3.21.4.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/rsyslog/rsyslog-3.21.4.ebuild b/app-admin/rsyslog/rsyslog-3.21.4.ebuild
new file mode 100644
index 000000000000..256cbbf211c1
--- /dev/null
+++ b/app-admin/rsyslog/rsyslog-3.21.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rsyslog/rsyslog-3.21.4.ebuild,v 1.1 2008/09/29 12:03:18 dev-zero Exp $
+
+inherit versionator
+
+DESCRIPTION="An enhanced multi-threaded syslogd with database support and more."
+HOMEPAGE="http://www.rsyslog.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug kerberos dbi gnutls mysql postgres relp snmp zlib"
+
+DEPEND="kerberos? ( virtual/krb5 )
+ dbi? ( dev-db/libdbi )
+ gnutls? ( net-libs/gnutls )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ relp? ( >=dev-libs/librelp-0.1.1 )
+ snmp? ( net-analyzer/net-snmp )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/logger"
+
+BRANCH="3-devel"
+
+src_compile() {
+ # Maintainer notes:
+ # * rsyslog-3 doesn't support single threading anymore
+ # * rfc3195 needs a library
+ # * OpenSSL detection is present in ./configure but nothing
+ # in the code actually needs it
+ econf \
+ --enable-largefile \
+ --enable-regexp \
+ $(use_enable zlib) \
+ $(use_enable kerberos gssapi-krb5) \
+ --enable-pthreads \
+ --enable-klog \
+ --enable-unix \
+ --enable-inet \
+ --enable-fsstnd \
+ $(use_enable debug) \
+ $(use_enable debug rtinst) \
+ $(use_enable debug valgrind) \
+ $(use_enable debug diagtools) \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable dbi libdbi) \
+ $(use_enable snmp) \
+ $(use_enable gnutls) \
+ --enable-rsyslogrt \
+ --enable-rsyslogd \
+ --enable-mail \
+ $(use_enable debug imdiag) \
+ $(use_enable relp) \
+ --disable-rfc3195 \
+ --enable-imfile \
+ --disable-imtemplate
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /usr/share/doc/${PF}/scripts/mysql
+ doins plugins/ommysql/{createDB.sql,contrib/delete_mysql}
+
+ insinto /usr/share/doc/${PF}/scripts/pgsql
+ doins plugins/ompgsql/createDB.sql
+
+ elog "SQL scripts to create the tables for MySQL or PostgreSQL have been installed to:"
+ elog " /usr/share/doc/${PF}/scripts"
+
+ dodoc AUTHORS ChangeLog doc/rsyslog-example.conf
+ dohtml doc/*
+
+ insinto /etc
+ newins "${FILESDIR}/${BRANCH}/rsyslog-gentoo.conf" rsyslog.conf
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/${BRANCH}/rsyslog.logrotate" rsyslog
+
+ newconfd "${FILESDIR}/${BRANCH}/rsyslog.conf" rsyslog
+ newinitd "${FILESDIR}/${BRANCH}/rsyslog.init" rsyslog
+}